Bug 268056 - kopete crash every time when i close it
Summary: kopete crash every time when i close it
Status: RESOLVED FIXED
Alias: None
Product: kopete
Classification: Applications
Component: general (show other bugs)
Version: 1.0.80
Platform: Compiled Sources Linux
: NOR crash with 62 votes (vote)
Target Milestone: ---
Assignee: Kopete Developers
URL:
Keywords:
: 272150 272555 273289 274421 276006 278107 280546 283655 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-03-09 14:54 UTC by desaparecido
Modified: 2011-10-14 15:38 UTC (History)
23 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.7.3


Attachments
New crash information added by DrKonqi (6.64 KB, text/plain)
2011-04-06 18:48 UTC, Karl Ferdinand Ebert
Details
New crash information added by DrKonqi (6.08 KB, text/plain)
2011-04-06 23:18 UTC, Karl Ferdinand Ebert
Details
New crash information added by DrKonqi (6.28 KB, text/plain)
2011-04-16 09:59 UTC, Valentyn Pavliuchenko
Details
New crash information added by DrKonqi (7.20 KB, text/plain)
2011-06-02 21:47 UTC, Troy Cotter
Details
New crash information added by DrKonqi (3.64 KB, text/plain)
2011-06-11 21:21 UTC, Evgenij Besogonov
Details
New crash information added by DrKonqi (6.37 KB, text/plain)
2011-06-26 04:11 UTC, Troy Cotter
Details
New crash information added by DrKonqi (4.84 KB, text/plain)
2011-07-13 20:45 UTC, Evgeny
Details
New crash information added by DrKonqi (6.38 KB, text/plain)
2011-07-27 03:06 UTC, Troy Cotter
Details
New crash information added by DrKonqi (7.28 KB, text/plain)
2011-07-31 14:04 UTC, root
Details
New crash information added by DrKonqi (4.31 KB, text/plain)
2011-09-04 23:37 UTC, Raimund Machacek
Details
New crash information added by DrKonqi (4.61 KB, text/plain)
2011-09-12 15:57 UTC, N3661
Details
New crash information added by DrKonqi (3.35 KB, text/plain)
2011-09-15 15:42 UTC, pregenitor
Details
Patch to fix the bug for Yahoo and GroupWise accounts (14.45 KB, patch)
2011-10-14 13:49 UTC, Ralf Jung
Details

Note You need to log in before you can comment on or make changes to this bug.
Description desaparecido 2011-03-09 14:54:05 UTC
Application: kopete (1.0.80)
KDE Platform Version: 4.6.41 (4.7 >= 20110106) (Compiled from sources)
Qt Version: 4.7.2
Operating System: Linux 2.6.37-ARCH i686
Distribution (Platform): Archlinux Packages

-- Information about the crash:
- What I was doing when the application crashed:
i close kopete application (close during my session kde or not, or when shutdown by shutdown button)
- Custom settings of the application:
my accounts are: 2-msn, 2-yahoo, 3-gtalk (jabber), 1-facebook (jabber), 1 skype

The crash can be reproduced every time.

-- Backtrace:
Application: Kopete (kopete), signal: Segmentation fault
[Current thread is 1 (Thread 0xb45e2aa0 (LWP 5122))]

Thread 2 (Thread 0xb0ab8b70 (LWP 5457)):
#0  0xb5dbe8ba in ?? () from /lib/libc.so.6
#1  0xb5da66a0 in poll () from /lib/libc.so.6
#2  0xb515f40b in g_poll () from /usr/lib/libglib-2.0.so.0
#3  0xb514ef9f in ?? () from /usr/lib/libglib-2.0.so.0
#4  0xb514f314 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#5  0xb6b9f807 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0xb6b71389 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0xb6b7162a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#8  0xb286f26b in XMPP::SyncThread::run (this=0x9df4e88) at /home/build/build/i686/kdenetwork/src/kdenetwork/kopete/protocols/jabber/libiris/iris/irisnet/corelib/netinterface.cpp:151
#9  0xb6a7cdc2 in ?? () from /usr/lib/libQtCore.so.4
#10 0xb5c78df0 in start_thread () from /lib/libpthread.so.0
#11 0xb5db098e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb45e2aa0 (LWP 5122)):
[KCrash Handler]
#7  0xb51f6fd4 in ?? () from /usr/lib/libfam.so.0
#8  0xb24cf722 in Client::~Client (this=0x9932da8, __in_chrg=<value optimized out>) at /home/build/build/i686/kdenetwork/src/kdenetwork/kopete/protocols/yahoo/libkyahoo/client.cpp:150
#9  0xb6b85d57 in QObjectPrivate::deleteChildren() () from /usr/lib/libQtCore.so.4
#10 0xb6b8a5ef in QObject::~QObject() () from /usr/lib/libQtCore.so.4
#11 0xb762bf65 in Kopete::Account::~Account (this=0x983a948, __in_chrg=<value optimized out>) at /home/build/build/i686/kdenetwork/src/kdenetwork/kopete/libkopete/kopeteaccount.cpp:118
#12 0xb766a875 in Kopete::PasswordedAccount::~PasswordedAccount (this=0x983a948, __in_chrg=<value optimized out>) at /home/build/build/i686/kdenetwork/src/kdenetwork/kopete/libkopete/kopetepasswordedaccount.cpp:39
#13 0xb25621ef in YahooAccount::~YahooAccount (this=0x983a948, __in_chrg=<value optimized out>) at /home/build/build/i686/kdenetwork/src/kdenetwork/kopete/protocols/yahoo/yahooaccount.cpp:124
#14 0xb2562222 in YahooAccount::~YahooAccount (this=0x983a948, __in_chrg=<value optimized out>) at /home/build/build/i686/kdenetwork/src/kdenetwork/kopete/protocols/yahoo/yahooaccount.cpp:128
#15 0xb6b84d75 in qDeleteInEventHandler(QObject*) () from /usr/lib/libQtCore.so.4
#16 0xb6b875e0 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#17 0xb6049ac4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#18 0xb604e74e in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#19 0xb710e63a in KApplication::notify (this=0xbf8823f4, receiver=0x983a948, event=0x9a029c8) at /home/build/build/i686/kdelibs/src/kdelibs/kdeui/kernel/kapplication.cpp:311
#20 0xb6b721cb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#21 0xb6b75de5 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#22 0xb6b75fbd in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#23 0xb6b760c9 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#24 0xb6047917 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#25 0x0805870e in main (argc=) at /home/build/build/i686/kdenetwork/src/kdenetwork/kopete/kopete/main.cpp:105

Possible duplicates by query: bug 249579.

Reported using DrKonqi
Comment 1 Karl Ferdinand Ebert 2011-04-06 18:48:57 UTC
Created attachment 58643 [details]
New crash information added by DrKonqi

kopete (1.0.80) on KDE Platform 4.6.1 (4.6.1) using Qt 4.7.2

- What I was doing when the application crashed:

Closing kopete with accounts Jabber, ICQ and Skype (I think this the reason, because Skype does not close but goes offline).

-- Backtrace (Reduced):
#7  0x00007f63c319fd99 in Client::~Client (this=0x1755ad0, __in_chrg=<value optimized out>) at ../../../../../kopete/protocols/oscar/liboscar/client.cpp:220
#8  0x00007f63dba596d4 in QObjectPrivate::deleteChildren (this=0x17495d0) at kernel/qobject.cpp:1955
#9  0x00007f63dba5e212 in QObject::~QObject (this=0x1750df0, __in_chrg=<value optimized out>) at kernel/qobject.cpp:946
#10 0x00007f63dd6b6ef4 in Kopete::Account::~Account (this=0x1750df0, __in_chrg=<value optimized out>) at ../../../kopete/libkopete/kopeteaccount.cpp:118
#11 0x00007f63c3758489 in ICQAccount::~ICQAccount (this=0x1750df0, __in_chrg=<value optimized out>) at ../../../../../kopete/protocols/oscar/icq/icqaccount.cpp:156
Comment 2 Karl Ferdinand Ebert 2011-04-06 23:18:25 UTC
Created attachment 58654 [details]
New crash information added by DrKonqi

kopete (1.0.80) on KDE Platform 4.6.1 (4.6.1) using Qt 4.7.2

- What I was doing when the application crashed:

Closing first Skype, then Kopete caused Kopete to crash and also Plasma.

-- Backtrace (Reduced):
#7  0x00007f63f1b08d99 in Client::~Client (this=0x19f00e0, __in_chrg=<value optimized out>) at ../../../../../kopete/protocols/oscar/liboscar/client.cpp:220
#8  0x00007f640a3c26d4 in QObjectPrivate::deleteChildren (this=0x19df920) at kernel/qobject.cpp:1955
#9  0x00007f640a3c7212 in QObject::~QObject (this=0x19f3610, __in_chrg=<value optimized out>) at kernel/qobject.cpp:946
#10 0x00007f640c01fef4 in Kopete::Account::~Account (this=0x19f3610, __in_chrg=<value optimized out>) at ../../../kopete/libkopete/kopeteaccount.cpp:118
#11 0x00007f63f20c1489 in ICQAccount::~ICQAccount (this=0x19f3610, __in_chrg=<value optimized out>) at ../../../../../kopete/protocols/oscar/icq/icqaccount.cpp:156
Comment 3 Valentyn Pavliuchenko 2011-04-16 09:59:53 UTC
Created attachment 59032 [details]
New crash information added by DrKonqi

kopete (1.0.80) on KDE Platform 4.6.1 (4.6.1) using Qt 4.7.2

- What I was doing when the application crashed:

I use kopete for ICQ and jabber.

When I close kopete (manually or as the result of a shutdown) I got this crash. It's 100% reproducible.
Crash doesn't depend on whether I was logged in before closing or not.

-- Backtrace (Reduced):
#6  0x000000000000000b in ?? () at /usr/include/qt4/QtCore/qatomic_x86_64.h:133
#7  0x00007fa11274ad99 in Client::~Client (this=0xf7daf0, __in_chrg=<value optimized out>) at ../../../../../kopete/protocols/oscar/liboscar/client.cpp:220
#8  0x00007fa1284126d4 in QObjectPrivate::deleteChildren (this=0xf0fdb0) at kernel/qobject.cpp:1955
#9  0x00007fa128417212 in QObject::~QObject (this=0xc3ecd0, __in_chrg=<value optimized out>) at kernel/qobject.cpp:946
#10 0x00007fa12a06fef4 in Kopete::Account::~Account (this=0xc3ecd0, __in_chrg=<value optimized out>) at ../../../kopete/libkopete/kopeteaccount.cpp:118
Comment 4 Modestas Vainius 2011-05-08 17:48:03 UTC
*** Bug 272555 has been marked as a duplicate of this bug. ***
Comment 5 Modestas Vainius 2011-05-08 17:48:32 UTC
*** Bug 272150 has been marked as a duplicate of this bug. ***
Comment 6 Wolfgang Scheicher 2011-05-27 13:24:22 UTC
Still happens with the kde sc 4.6.3 now in debian sid :(
Comment 7 Valentyn Pavliuchenko 2011-05-27 22:31:25 UTC
My occurrence is also in Debian, but in experimental, amd64. Tried to debug, but it looks like it's a memory corruption of the class virtual table or object virtual table pointer. Crashes in ~Client() destructor even if the destructor is empty. valgrind didn't give any useful information.
Comment 8 Troy Cotter 2011-06-02 04:16:44 UTC
*** Bug 273289 has been marked as a duplicate of this bug. ***
Comment 9 Troy Cotter 2011-06-02 21:47:37 UTC
Created attachment 60563 [details]
New crash information added by DrKonqi

kopete (1.0.80) on KDE Platform 4.6.3 (4.6.3) using Qt 4.7.3

- What I was doing when the application crashed:
Just booted up, started Kopete and closed it.

- Custom settings of the application:
I have one AIM account and one account using the Jabber protocol.

-- Backtrace (Reduced):
#7  0x00007f7b6c15db89 in Client::~Client (this=0x2162390, __in_chrg=<value optimized out>) at ../../../../../kopete/protocols/oscar/liboscar/client.cpp:220
#8  0x00007f7b825524a5 in QObjectPrivate::deleteChildren (this=0x1e1cdc0) at kernel/qobject.cpp:1955
#9  0x00007f7b82557a49 in QObject::~QObject (this=0x245dbc0, __in_chrg=<value optimized out>) at kernel/qobject.cpp:946
#10 0x00007f7b841b5a2b in Kopete::Account::~Account (this=0x245dbc0, __in_chrg=<value optimized out>) at ../../../kopete/libkopete/kopeteaccount.cpp:118
#11 0x00007f7b6c6ddee9 in AIMAccount::~AIMAccount (this=0x245dbc0, __in_chrg=<value optimized out>) at ../../../../../kopete/protocols/oscar/aim/aimaccount.cpp:245
Comment 10 Evgenij Besogonov 2011-06-11 21:21:35 UTC
Created attachment 60914 [details]
New crash information added by DrKonqi

kopete (1.0.80) on KDE Platform 4.6.3 (4.6.3) using Qt 4.7.3

kopete crashes every time upon exit via kopete's menu

-- Backtrace (Reduced):
#7  0x00007f524ef14b89 in Client::~Client (this=0x1c49260, __in_chrg=<value optimized out>) at ../../../../../kopete/protocols/oscar/liboscar/client.cpp:220
#8  0x00007f5265eac4a5 in QObjectPrivate::deleteChildren (this=0x1cc4430) at kernel/qobject.cpp:1955
#9  0x00007f5265eb1a49 in QObject::~QObject (this=0x1c4a2f0, __in_chrg=<value optimized out>) at kernel/qobject.cpp:946
#10 0x00007f5267b0fa2b in Kopete::Account::~Account (this=0x1c4a2f0, __in_chrg=<value optimized out>) at ../../../kopete/libkopete/kopeteaccount.cpp:118
#11 0x00007f524f4c79a9 in ICQAccount::~ICQAccount (this=0x1c4a2f0, __in_chrg=<value optimized out>) at ../../../../../kopete/protocols/oscar/icq/icqaccount.cpp:156
Comment 11 Martin 2011-06-17 23:15:02 UTC
*** This bug has been confirmed by popular vote. ***
Comment 12 Troy Cotter 2011-06-26 01:28:35 UTC
Just thought I'd let it be known that this bug still occurs on KDE 4.6.4
Comment 13 Troy Cotter 2011-06-26 04:11:06 UTC
Created attachment 61334 [details]
New crash information added by DrKonqi

kopete (1.0.80) on KDE Platform 4.6.4 (4.6.4) using Qt 4.7.3

- What I was doing when the application crashed:
Normal activity, web browsing, music, etc... is pretty irrelevant considering Kopete crashes even when it is the only program open.

-- Backtrace (Reduced):
#6  0x000000000000000c in ?? () at /usr/include/qt4/QtCore/qmap.h:748
#7  0x00007ffddbd97b89 in Client::~Client (this=0x2371ec0, __in_chrg=<value optimized out>) at ../../../../../kopete/protocols/oscar/liboscar/client.cpp:220
#8  0x00007ffdf2897025 in QObjectPrivate::deleteChildren (this=0x2509460) at kernel/qobject.cpp:1955
#9  0x00007ffdf289c5c9 in QObject::~QObject (this=0x2849220, __in_chrg=<value optimized out>) at kernel/qobject.cpp:946
#10 0x00007ffdf44fba2b in Kopete::Account::~Account (this=0x2849220, __in_chrg=<value optimized out>) at ../../../kopete/libkopete/kopeteaccount.cpp:118
Comment 14 Sai Vnoba 2011-07-09 12:43:32 UTC
Just like comment #12, I would like to add that I've the mentioned problem with Kopete: 1.0.80, 
KDE: 4.6.4, 
Qt: 4.7.3. 

I'm running Debian testing and have a yahoo account. 

It happens even when kopete is the only application launched and all I do is to just close it from kopete menu. It can be reproduced every time kopete is launched.

Note: I'm new to bug reporting and as such do not know what information to be provided. My kopete crash window says 'crash information could not be generated'.
Comment 15 Sai Vnoba 2011-07-09 13:58:45 UTC
Hi,
Wrt comment #14, I started kopete from konsole and then closed it. Kopete crashed. I'm pasting the info on the konsole. May be it is useful in someway.

uid1000@wheezy:~$ kopete
Application asked to unregister timer 0x0 which is not registered in this thread. Fix application.
kopete(6706)/kio (KDirWatch) KDirWatchPrivate::removeEntry: doesn't know "/home/uid1000/.kde/share/apps/kabc" 
kopete(6706)/kdecore (KLibrary) kde4Factory: The library "/usr/lib/kde4/kopete_history.so" does not offer a qt_plugin_instance function.
kopete(6706)/libkopete Kopete::PluginManager::loadPluginInternal: Unable to find a plugin named ' "" '! 
uid1000@wheezy:~$ QMetaObject::invokeMethod: No such method HistoryPlugin::shouldExitOnClose()
QMetaObject::invokeMethod: No such method YahooProtocol::shouldExitOnClose()
QMetaObject::invokeMethod: No such method Kopete::Plugin::shouldExitOnClose()
QMetaObject::invokeMethod: No such method Kopete::Plugin::shouldExitOnClose()
kopete(6706)/kdeui (kdelibs) KXMLGUIClient::~KXMLGUIClient: 0x8b492c0 deleted without having been removed from the factory first. This will leak standalone popupmenus and could lead to crashes. 
KCrash: Application 'kopete' crashing...
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
sock_file=/home/uid1000/.kde/socket-wheezy/kdeinit4__0
^C
uid1000@wheezy:~$
Comment 16 Christoph Feck 2011-07-11 12:39:16 UTC
*** Bug 274421 has been marked as a duplicate of this bug. ***
Comment 17 Christoph Feck 2011-07-11 12:39:49 UTC
*** Bug 276006 has been marked as a duplicate of this bug. ***
Comment 18 Evgeny 2011-07-13 20:45:13 UTC
Created attachment 61852 [details]
New crash information added by DrKonqi

kopete (1.0.80) on KDE Platform 4.6.4 (4.6.4) using Qt 4.7.3

- What I was doing when the application crashed:

Closing the kopete. No matter the way I'm trying to close it.

- Custom settings of the application:

-- Backtrace (Reduced):
#7  0x00007f8e92dcbb89 in Client::~Client() () from /usr/lib/liboscar.so.1
#8  0x00007f8eaaf199d5 in QObjectPrivate::deleteChildren() () from /usr/lib/libQtCore.so.4
#9  0x00007f8eaaf1ef79 in QObject::~QObject() () from /usr/lib/libQtCore.so.4
#10 0x00007f8eacb7da2b in Kopete::Account::~Account() () from /usr/lib/libkopete.so.4
[...]
#12 0x00007f8eaaf1e6f8 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
Comment 19 Christoph Feck 2011-07-20 16:14:16 UTC
*** Bug 278107 has been marked as a duplicate of this bug. ***
Comment 20 Troy Cotter 2011-07-27 03:06:17 UTC
Created attachment 62226 [details]
New crash information added by DrKonqi

kopete (1.0.80) on KDE Platform 4.6.5 (4.6.5) using Qt 4.7.3

- What I was doing when the application crashed:
Browsing the internet using Iceweasel Aurora, Kopete crash on exit.

- Custom settings of the application:
Using AIM protocol and Jabber (Facebook Chat) protocol.

-- Backtrace (Reduced):
#6  0x000000000000000c in ?? () at /usr/include/qt4/QtCore/qmap.h:748
#7  0x00007f27c4396c39 in Client::~Client (this=0x1091d10, __in_chrg=<value optimized out>) at ../../../../../kopete/protocols/oscar/liboscar/client.cpp:220
#8  0x00007f27db2dd9d5 in QObjectPrivate::deleteChildren (this=0x15b6b80) at kernel/qobject.cpp:1955
#9  0x00007f27db2e2f79 in QObject::~QObject (this=0xded720, __in_chrg=<value optimized out>) at kernel/qobject.cpp:946
#10 0x00007f27dcf452e3 in Kopete::Account::~Account (this=0xded720, __in_chrg=<value optimized out>) at ../../../kopete/libkopete/kopeteaccount.cpp:118
Comment 21 Ralf Jung 2011-07-29 21:33:05 UTC
I'm having the same issue, too - with 2x Jabber and 1x ICQ as my protocols.
Using KDE 4.6.5 from Debian testing.
Comment 22 root 2011-07-31 14:04:05 UTC
Created attachment 62380 [details]
New crash information added by DrKonqi

kopete (1.0.80) on KDE Platform 4.6.5 (4.6.5) using Qt 4.7.3

A bit longer backtrace, maybe it helps. Are the remaining '??' of any concern? If so what do they belong to?

- What I was doing when the application crashed:
Close Kopete either through menu or on shutdown/reboot/logout.

-- Backtrace (Reduced):
#7  0x00007f80a037ac39 in Client::~Client (this=0x16c7990, __in_chrg=<value optimized out>) at ../../../../../kopete/protocols/oscar/liboscar/client.cpp:220
#8  0x00007f80b86219d5 in QObjectPrivate::deleteChildren (this=0x1471eb0) at kernel/qobject.cpp:1955
#9  0x00007f80b8626f79 in QObject::~QObject (this=0x1565900, __in_chrg=<value optimized out>) at kernel/qobject.cpp:946
#10 0x00007f80ba2892e3 in Kopete::Account::~Account (this=0x1565900, __in_chrg=<value optimized out>) at ../../../kopete/libkopete/kopeteaccount.cpp:118
#11 0x00007f80a092d9a9 in ICQAccount::~ICQAccount (this=0x1565900, __in_chrg=<value optimized out>) at ../../../../../kopete/protocols/oscar/icq/icqaccount.cpp:156
Comment 23 Valentyn Pavliuchenko 2011-08-01 22:50:09 UTC
Bug disappeared after latest updates from Debian unstable/experimental (not sure what exactly except all KDE stuff was updated by me). Current kopete is from 4.6.5 and it works fine.

Can anybody update all KDE stuff from sid and recheck?
Comment 24 Degand Nicolas 2011-08-02 06:42:36 UTC
It still happens to me around 75% of the time. It is true it is not systematic any more.
Comment 25 Wolfgang Scheicher 2011-08-02 08:24:47 UTC
hmm ... i did migrate from wheezy to sid now to test, and so far kopete is still crashing 100% of the time.
Comment 26 Slobodan Simic 2011-08-04 07:17:40 UTC
I'm at aptosid distro which is  Debian unstable based and Kopete crashes every single time when it closes.
Here is terminal output if it can help...

kopete(4047)/kdeui (kdelibs) KXMLGUIClient::~KXMLGUIClient: 0x87c9638 deleted without having been removed from the factory first. This will leak standalone popupmenus and could lead to crashes. 
kopete(4047)/kdeui (kdelibs) KXMLGUIClient::~KXMLGUIClient: 0x863f9a0 deleted without having been removed from the factory first. This will leak standalone popupmenus and could lead to crashes. 
kopete(4047)/kdeui (kdelibs) KXMLGUIClient::~KXMLGUIClient: 0x87b9618 deleted without having been removed from the factory first. This will leak standalone popupmenus and could lead to crashes. 
QSocketNotifier: Invalid socket 14 and type 'Read', disabling...
KCrash: Application 'kopete' crashing...
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
sock_file=/home/slobodan/.kde/socket-hyperspace/kdeinit4__0
Comment 27 Christoph Feck 2011-08-21 23:57:01 UTC
*** Bug 280546 has been marked as a duplicate of this bug. ***
Comment 28 Raimund Machacek 2011-09-04 23:37:03 UTC
Created attachment 63383 [details]
New crash information added by DrKonqi

kopete (1.0.80) on KDE Platform 4.6.5 (4.6.5) using Qt 4.7.3

Linux Mint Debian with KDE

Got a stacktrace from the crash.
The crash can be reproduced every time.

It does not matter if Kopete is focused or not, it also does not matter if Kopete was shut down first or via system shutdown.

-- Backtrace (Reduced):
#7  0x00007f2e759c9c39 in Client::~Client() () from /usr/lib/liboscar.so.1
#8  0x00007f2e934849e5 in QObjectPrivate::deleteChildren (this=0xb0c5b0) at kernel/qobject.cpp:1955
#9  0x00007f2e93489f89 in QObject::~QObject (this=0xb09df0, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#10 0x00007f2e950ec2e3 in Kopete::Account::~Account() () from /usr/lib/libkopete.so.4
[...]
#12 0x00007f2e93489708 in QObject::event (this=0xb09df0, e=<optimized out>) at kernel/qobject.cpp:1200
Comment 29 N3661 2011-09-12 15:57:42 UTC
Created attachment 63589 [details]
New crash information added by DrKonqi

kopete (1.0.80) on KDE Platform 4.6.5 (4.6.5) using Qt 4.7.3

Crashed when i exit closed kopete

-- Backtrace (Reduced):
#7  0x00007f9c8d4c2c39 in Client::~Client (this=0x23e8fd0, __in_chrg=<optimized out>) at ../../../../../kopete/protocols/oscar/liboscar/client.cpp:220
#8  0x00007f9ca57e69d5 in QObjectPrivate::deleteChildren (this=0x23e9d20) at kernel/qobject.cpp:1955
#9  0x00007f9ca57ebf79 in QObject::~QObject (this=0x2155f90, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#10 0x00007f9ca744e2e3 in Kopete::Account::~Account (this=0x2155f90, __in_chrg=<optimized out>) at ../../../kopete/libkopete/kopeteaccount.cpp:118
#11 0x00007f9c8da759a9 in ICQAccount::~ICQAccount (this=0x2155f90, __in_chrg=<optimized out>) at ../../../../../kopete/protocols/oscar/icq/icqaccount.cpp:156
Comment 30 Tudor Lupei 2011-09-12 19:19:40 UTC
Kopete
Version 1.0.80
Using KDE Development Platform 4.6.5 (4.6.5)

I have Jabber and Yahoo accounts. If I remove Yahoo, the crash won't happen anymore. Otherwise it crashes every time. It doesn't matter if the status is Online, Offline or Invisible.

-- Backtrace:

Application: Kopete (kopete), signal: Segmentation fault
[Current thread is 1 (Thread 0xb435e710 (LWP 8185))]

Thread 2 (Thread 0xb19b2b70 (LWP 8191)):
#0  0xb77a0424 in __kernel_vsyscall ()
#1  0xb5baec71 in select () from /lib/i386-linux-gnu/i686/cmov/libc.so.6
#2  0xb69c8674 in QProcessManager::run (this=0xb6b22748) at io/qprocess_unix.cpp:245
#3  0xb68ee503 in QThreadPrivate::start (arg=0xb6b22748) at thread/qthread_unix.cpp:320
#4  0xb4f44c39 in start_thread () from /lib/i386-linux-gnu/i686/cmov/libpthread.so.0
#5  0xb5bb596e in clone () from /lib/i386-linux-gnu/i686/cmov/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb435e710 (LWP 8185)):
[KCrash Handler]
#7  0xb4f33f74 in Client::~Client() () from /usr/lib/libfam.so.0
#8  0xb033b262 in Client::~Client (this=0x9475f30, __in_chrg=<optimized out>) at ../../../../../kopete/protocols/yahoo/libkyahoo/client.cpp:150
#9  0xb69fd0e1 in QObjectPrivate::deleteChildren (this=0x94fb0f0) at kernel/qobject.cpp:1955
#10 0xb6a01cd9 in QObject::~QObject (this=0x94ffc80, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#11 0xb75f6f10 in Kopete::Account::~Account (this=0x94ffc80, __in_chrg=<optimized out>) at ../../../kopete/libkopete/kopeteaccount.cpp:118
#12 0xb7638766 in Kopete::PasswordedAccount::~PasswordedAccount (this=0x94ffc80, __in_chrg=<optimized out>) at ../../../kopete/libkopete/kopetepasswordedaccount.cpp:39
#13 0xb03d4707 in YahooAccount::~YahooAccount (this=0x94ffc80, __in_chrg=<optimized out>) at ../../../../kopete/protocols/yahoo/yahooaccount.cpp:124
#14 0xb03d4772 in YahooAccount::~YahooAccount (this=0x94ffc80, __in_chrg=<optimized out>) at ../../../../kopete/protocols/yahoo/yahooaccount.cpp:128
#15 0xb69fbe73 in qDeleteInEventHandler (o=0x94ffc80) at kernel/qobject.cpp:3986
#16 0xb6a01468 in QObject::event (this=0x94ffc80, e=0x95acf38) at kernel/qobject.cpp:1200
#17 0xb5e9a7a4 in notify_helper (e=0x95acf38, receiver=0x94ffc80, this=0x9266b70) at kernel/qapplication.cpp:4467
#18 QApplicationPrivate::notify_helper (this=0x9266b70, receiver=0x94ffc80, e=0x95acf38) at kernel/qapplication.cpp:4439
#19 0xb5e9fb32 in QApplication::notify (this=0x95acf38, receiver=0x94ffc80, e=0x95acf38) at kernel/qapplication.cpp:4214
#20 0xb7002571 in KApplication::notify (this=0xbfbba2f4, receiver=0x94ffc80, event=0x95acf38) at ../../kdeui/kernel/kapplication.cpp:311
#21 0xb69e922e in QCoreApplication::notifyInternal (this=0xbfbba2f4, receiver=0x94ffc80, event=0x95acf38) at kernel/qcoreapplication.cpp:731
#22 0xb69ec9f4 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#23 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x92364e0) at kernel/qcoreapplication.cpp:1372
#24 0xb69ecb3c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1265
#25 0xb6a17044 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#26 postEventSourceDispatch (s=0x9269680) at kernel/qeventdispatcher_glib.cpp:277
#27 0xb4e89252 in g_main_dispatch (context=0x9268c40) at /build/buildd-glib2.0_2.28.6-1-i386-A3fp41/glib2.0-2.28.6/./glib/gmain.c:2440
#28 g_main_context_dispatch (context=0x9268c40) at /build/buildd-glib2.0_2.28.6-1-i386-A3fp41/glib2.0-2.28.6/./glib/gmain.c:3013
#29 0xb4e89a30 in g_main_context_iterate (context=0x9268c40, block=1, dispatch=1, self=<optimized out>) at /build/buildd-glib2.0_2.28.6-1-i386-A3fp41/glib2.0-2.28.6/./glib/gmain.c:3091
#30 0xb4e89ce4 in g_main_context_iteration (context=0x9268c40, may_block=1) at /build/buildd-glib2.0_2.28.6-1-i386-A3fp41/glib2.0-2.28.6/./glib/gmain.c:3154
#31 0xb6a17477 in QEventDispatcherGlib::processEvents (this=0x9239cf0, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#32 0xb5f4f72a in QGuiEventDispatcherGlib::processEvents (this=0x9239cf0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#33 0xb69e824d in QEventLoop::processEvents (this=0xbfbba254, flags=...) at kernel/qeventloop.cpp:149
#34 0xb69e8491 in QEventLoop::exec (this=0xbfbba254, flags=...) at kernel/qeventloop.cpp:201
#35 0xb69ecbea in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#36 0xb5e98624 in QApplication::exec () at kernel/qapplication.cpp:3741
#37 0x08059428 in main (argc=) at ../../../kopete/kopete/main.cpp:105
Comment 31 pregenitor 2011-09-15 15:42:06 UTC
Created attachment 63668 [details]
New crash information added by DrKonqi

kopete (1.0.80) on KDE Platform 4.6.5 (4.6.5) using Qt 4.7.3

- What I was doing when the application crashed:
kopete krashed on exit and on shutdown every time.
my accounts: 1 - gmail  (jabber)

-- Backtrace (Reduced):
#7  0x00007ff3f85aec39 in Client::~Client() () from /usr/lib/liboscar.so.1
#8  0x00007ff4116839d5 in QObjectPrivate::deleteChildren (this=0x116df40) at kernel/qobject.cpp:1955
#9  0x00007ff411688f79 in QObject::~QObject (this=0x12f6700, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#10 0x00007ff4132eb2e3 in Kopete::Account::~Account() () from /usr/lib/libkopete.so.4
[...]
#12 0x00007ff4116886f8 in QObject::event (this=0x12f6700, e=<optimized out>) at kernel/qobject.cpp:1200
Comment 32 Ralf Jung 2011-10-03 19:22:52 UTC
The crash is caused by symbol collision: Both liboscar and libfam have a class called "Client", and when the destructor of liboscar's Client is called, it actually jumps to the one in libfam... ouch.
Comment 33 Ralf Jung 2011-10-03 19:47:27 UTC
The bug can be fixed by using gamin instead of fam - it has a compatible API, but does not expose the conflicting symbols. So, nag your distribution to use gamin per default ;-)
Comment 34 root 2011-10-03 20:00:59 UTC
Thank you!

Switching to libgamin does work on Debian Testing. And KDE did not blow up! Yet ^^
Comment 35 Troy Cotter 2011-10-03 20:07:53 UTC
Running sid here, can also confirm that installing gamin fixes the crash problem. During installation libfam0 needs to be removed due to a conflict with gamin, but I installed anyways investigation reveals that libfam0 is also a virtual package of libgamin0 so I believe the message is of no consequence.

The following packages will be REMOVED:
  libfam0
The following NEW packages will be installed:
  gamin libgamin0

Parsing Found/Fixed information... Done
dpkg: libfam0: dependency problems, but removing anyway as you requested:
 libkdecore5 depends on libfam0.
(Reading database ... 127140 files and directories currently installed.)
Removing libfam0 ...
Comment 36 Ralf Jung 2011-10-03 20:14:15 UTC
Yes, I am running Debian wheezy (testing) and did the same.

I saw you reported a bug against Debian Kopete, Troy - I already nagged Debian libfam to hide those pointless symbols (they are not part of the actual API).
I also sent a message to kopete-devel asking them to put liboscar into a namespace, which would also fix this.

Now let's hope something moves ;-)
Comment 37 Valentyn Pavliuchenko 2011-10-04 07:44:12 UTC
Replaced lib and don't see any crashes now - confirming the fix on Debian testing. Thanks!
Comment 38 Wolfgang Scheicher 2011-10-04 09:14:39 UTC
Finally!
Many thanks to everybody involved in discovering the cause, the workaround and the hopefully resulting bugfixes, etc ..!

This is really important for me, i can hardly express how grave this bug has affected me and some users i know, since one of the major points for using KDE is how some apps like kmail, knode, kopete, konversation,... play along, share contact information and display online statuse, etc...
And by having kopete as integral part of this crash on each use (even on terminating) for a long time (bug got reported on 2011-03-09), the whole experience suffers and users loose faith.
Comment 39 Valentyn Pavliuchenko 2011-10-04 11:12:47 UTC
So what about renaming Client class?
Comment 40 Ralf Jung 2011-10-04 19:26:11 UTC
The easiest way is to put it into a namespace. Since liboscar does not seem to be exposed the the outer world (no header files are installed), I assume it has no guarantees that could prevent such a change.
Comment 41 Valentyn Pavliuchenko 2011-10-04 19:53:41 UTC
I agree - namespaces are the best thing to avoid such conflicts.
Comment 42 Ralf Jung 2011-10-05 10:23:51 UTC
A patch that moves the class into a namespace has been committed to SVN, so at least KDE 4.8 will finally see this fixed ;-) (I do not know if it was backported to 4.7)
Comment 43 Dario Andres 2011-10-09 22:30:40 UTC
*** Bug 283655 has been marked as a duplicate of this bug. ***
Comment 44 Ralf Jung 2011-10-14 13:49:23 UTC
Created attachment 64518 [details]
Patch to fix the bug for Yahoo and GroupWise accounts

The patch that is committed only fixes the problem for ICQ. The Yahoo and GroupWise protocols have the same issue, attached bug fixes it - could someone commit it please?
Comment 45 Lamarque V. Souza 2011-10-14 15:27:55 UTC
SVN commit 1258907 by lvsouza:

Fix crash when closing Kopete.
Thanks to Ralf Jung for this patch.

REVIEW: 6812
BUG: 268056
FIXED-IN: 4.7.3



 M  +2 -0      groupwise/gwaccount.h  
 M  +4 -2      groupwise/libgroupwise/chatroommanager.h  
 M  +4 -0      groupwise/libgroupwise/client.cpp  
 M  +4 -0      groupwise/libgroupwise/client.h  
 M  +4 -2      groupwise/libgroupwise/privacymanager.h  
 M  +4 -2      groupwise/libgroupwise/task.h  
 M  +2 -0      groupwise/libgroupwise/userdetailsmanager.h  
 M  +3 -0      yahoo/libkyahoo/client.cpp  
 M  +4 -0      yahoo/libkyahoo/client.h  
 M  +2 -0      yahoo/libkyahoo/filetransfernotifiertask.cpp  
 M  +2 -0      yahoo/libkyahoo/logintask.cpp  
 M  +2 -0      yahoo/libkyahoo/messagereceivertask.cpp  
 M  +2 -0      yahoo/libkyahoo/modifyyabtask.cpp  
 M  +1 -0      yahoo/libkyahoo/picturenotifiertask.cpp  
 M  +1 -0      yahoo/libkyahoo/sendfiletask.cpp  
 M  +2 -0      yahoo/libkyahoo/sendmessagetask.cpp  
 M  +1 -0      yahoo/libkyahoo/sendpicturetask.cpp  
 M  +2 -0      yahoo/libkyahoo/statusnotifiertask.cpp  
 M  +2 -0      yahoo/libkyahoo/task.cpp  
 M  +5 -2      yahoo/libkyahoo/task.h  
 M  +1 -0      yahoo/libkyahoo/webcamtask.cpp  
 M  +2 -0      yahoo/libkyahoo/yabtask.cpp  
 M  +2 -0      yahoo/libkyahoo/yahoobuddyiconloader.cpp  
 M  +4 -2      yahoo/libkyahoo/yahoobuddyiconloader.h  
 M  +2 -0      yahoo/libkyahoo/yahoochattask.cpp  
 M  +2 -0      yahoo/yahooaccount.cpp  
 M  +4 -2      yahoo/yahooaccount.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1258907
Comment 46 Lamarque V. Souza 2011-10-14 15:38:11 UTC
SVN commit 1258908 by lvsouza:

Backporting r1258907 from trunk to KDE/4.7 branch

Fix crash when closing Kopete.
Thanks to Ralf Jung for this patch.

REVIEW: 6812
BUG: 268056
FIXED-IN: 4.7.3


 M  +2 -0      groupwise/gwaccount.h  
 M  +4 -2      groupwise/libgroupwise/chatroommanager.h  
 M  +4 -0      groupwise/libgroupwise/client.cpp  
 M  +4 -0      groupwise/libgroupwise/client.h  
 M  +4 -2      groupwise/libgroupwise/privacymanager.h  
 M  +4 -2      groupwise/libgroupwise/task.h  
 M  +2 -0      groupwise/libgroupwise/userdetailsmanager.h  
 M  +3 -0      yahoo/libkyahoo/client.cpp  
 M  +4 -0      yahoo/libkyahoo/client.h  
 M  +2 -0      yahoo/libkyahoo/filetransfernotifiertask.cpp  
 M  +2 -0      yahoo/libkyahoo/logintask.cpp  
 M  +2 -0      yahoo/libkyahoo/messagereceivertask.cpp  
 M  +2 -0      yahoo/libkyahoo/modifyyabtask.cpp  
 M  +1 -0      yahoo/libkyahoo/picturenotifiertask.cpp  
 M  +1 -0      yahoo/libkyahoo/sendfiletask.cpp  
 M  +2 -0      yahoo/libkyahoo/sendmessagetask.cpp  
 M  +1 -0      yahoo/libkyahoo/sendpicturetask.cpp  
 M  +2 -0      yahoo/libkyahoo/statusnotifiertask.cpp  
 M  +2 -0      yahoo/libkyahoo/task.cpp  
 M  +5 -2      yahoo/libkyahoo/task.h  
 M  +1 -0      yahoo/libkyahoo/webcamtask.cpp  
 M  +2 -0      yahoo/libkyahoo/yabtask.cpp  
 M  +2 -0      yahoo/libkyahoo/yahoobuddyiconloader.cpp  
 M  +4 -2      yahoo/libkyahoo/yahoobuddyiconloader.h  
 M  +2 -0      yahoo/libkyahoo/yahoochattask.cpp  
 M  +2 -0      yahoo/yahooaccount.cpp  
 M  +4 -2      yahoo/yahooaccount.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1258908