Bug 268040 - Content of kmail folders cannot be retrieved
Summary: Content of kmail folders cannot be retrieved
Status: RESOLVED UNMAINTAINED
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: Mixed Maildir resource (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-09 09:22 UTC by S. Burmeister
Modified: 2017-01-07 21:42 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description S. Burmeister 2011-03-09 09:22:42 UTC
Version:           unspecified
OS:                Linux

The "account" kmail folders shows all folders that exist in ~/Mail. However if I click on a folder no content is shown. Looking at akonadi's output I see a lot of activity regarding that resource and the following debug output. KMail1 can display the emails just fine thus I do not think it is a permissions issue.

akonadi_mixedmaildir_resource_0(16165)/akonadiresource (maildir): "Cannot add email to folder  because there is no email content" 
akonadi_mixedmaildir_resource_0(16165): "Given folder name is empty" 
akonadi_mixedmaildir_resource_0(16165): Collection ID: 86    remote ID: "" 
   name: "" 
   url: KUrl("akonadi:?collection=86") 
   parent: -133645 "" 
   resource: "akonadi_mixedmaildir_resource_0" 
   rights: QFlags(0x1|0x2|0x4|0x8|0x10|0x20) 
   contents mime type: () 
    CachePolicy:  
   inherit: true 
   interval: -1 
   timeout: -1 
   sync on demand: false 
   local parts: () 
    CollectionStatistics: 
   count: -1 
   unread count: -1 
   size: -1 Item(remoteId= "" , mimeType= "message/rfc822" ) 

Reproducible: Didn't try
Comment 1 S. Burmeister 2011-03-15 13:30:20 UTC
right clicking and "synchronise folder" does help for some but not for others.
Comment 2 Malte 2011-06-27 22:00:25 UTC
Synchronise folder did not help for me either. My trash folder still says 900 messages, 437 unread, but no content, KMail 2.1.0 shows an empty folder.
Comment 3 S. Burmeister 2011-06-27 22:11:35 UTC
You can check with akonadiconsole wheter it's kmail or akonadi.
Comment 4 Lubos Balazovic 2012-01-11 15:15:29 UTC
I have the same problem. I've found out the messages (as text files) in ./kde/share/apps/kmail/mail/.index.directory/../new aren't corrupted, just it is unable to open them in kmail :-(
Comment 5 Denis Kurz 2016-09-24 20:38:34 UTC
This bug has only been reported for versions older than KDEPIM 4.14 (at most akonadi-1.3). Can anyone tell if this bug still present?

If noone confirms this bug for a recent version of akonadi (part of KDE Applications 15.08 or later), it gets closed in about three months.
Comment 6 Denis Kurz 2017-01-07 21:42:58 UTC
Just as announced in my last comment, I close this bug. If you encounter it again in a recent version (at least 5.0 aka 15.08), please open a new one unless it already exists. Thank you for all your input.