Bug 267979 - crash after quitting Kopete
Summary: crash after quitting Kopete
Status: RESOLVED DUPLICATE of bug 241562
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: 4.6.1
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-08 16:51 UTC by Ivan D Vasin
Modified: 2012-05-22 21:11 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan D Vasin 2011-03-08 16:51:12 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.1 (4.6.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-28-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
closing Kopete from the system tray, hitting bug #251226.

- Unusual behavior I noticed:
Kopete hung for a while after i quit it from the system tray.  i tried to open another context menu on its system tray icon.  the icon itself hung for a while (remaining highlighted even after moving the cursor off it), then crashed.  then Plasma also crashed.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f40c853d7a0 (LWP 1793))]

Thread 3 (Thread 0x7f40ab46e700 (LWP 1797)):
#0  0x00007f40c7e43203 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f40bcbfa009 in g_main_context_poll (context=0x17188a0, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:3093
#2  g_main_context_iterate (context=0x17188a0, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2775
#3  0x00007f40bcbfa45c in g_main_context_iteration (context=0x17188a0, may_block=1) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2843
#4  0x00007f40c51bc1e6 in QEventDispatcherGlib::processEvents (this=0x1715740, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#5  0x00007f40c518ea02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#6  0x00007f40c518edec in QEventLoop::exec (this=0x7f40ab46dcb0, flags=) at kernel/qeventloop.cpp:201
#7  0x00007f40c50992fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#8  0x00007f40c516e5f8 in QInotifyFileSystemWatcherEngine::run (this=0x17150e0) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f40c509c27e in QThreadPrivate::start (arg=0x17150e0) at thread/qthread_unix.cpp:266
#10 0x00007f40c042a953 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#11 0x00007f40bd2ac971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#12 0x00007f40c7e4f92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f409d4d9700 (LWP 1824)):
#0  0x00007f40c7e43203 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f40bcbfa009 in g_main_context_poll (context=0x1bec780, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:3093
#2  g_main_context_iterate (context=0x1bec780, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2775
#3  0x00007f40bcbfa45c in g_main_context_iteration (context=0x1bec780, may_block=1) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2843
#4  0x00007f40c51bc1e6 in QEventDispatcherGlib::processEvents (this=0x1bebf50, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#5  0x00007f40c518ea02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#6  0x00007f40c518edec in QEventLoop::exec (this=0x7f409d4d8cb0, flags=) at kernel/qeventloop.cpp:201
#7  0x00007f40c50992fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#8  0x00007f40c516e5f8 in QInotifyFileSystemWatcherEngine::run (this=0x1beb500) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f40c509c27e in QThreadPrivate::start (arg=0x1beb500) at thread/qthread_unix.cpp:266
#10 0x00007f40c042a953 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#11 0x00007f40bd2ac971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#12 0x00007f40c7e4f92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f40c853d7a0 (LWP 1793)):
[KCrash Handler]
#6  QCoreApplication::postEvent (receiver=0x2a34860, event=0x2a03c10, priority=0) at kernel/qcoreapplication.cpp:1133
#7  0x00007f40ac9f9c73 in StatusNotifierItemJob::contextMenuReady (this=0x2a34860, menu=0x1bc3580) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#8  0x00007f40ac9f9ce0 in StatusNotifierItemJob::qt_metacall (this=0x2a34860, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffd3e56af0) at ./statusnotifieritemjob.moc:75
#9  0x00007f40c51a7b27 in QMetaObject::activate (sender=0x2301c70, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3280
#10 0x00007f40ac9f3c7f in StatusNotifierItemSource::contextMenuReady (this=0x2a34860, _t1=0x1bc3580) at ./statusnotifieritemsource.moc:109
#11 0x00007f40ac9f8be4 in StatusNotifierItemSource::qt_metacall (this=0x2301c70, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffd3e56be0) at ./statusnotifieritemsource.moc:90
#12 0x00007f40c51a7b27 in QMetaObject::activate (sender=0x194c620, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3280
#13 0x00007f40bdb2489c in DBusMenuImporter::slotMenuAboutToShow() () from /usr/lib/libdbusmenu-qt.so.2
#14 0x00007f40bdb25a5c in DBusMenuImporter::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libdbusmenu-qt.so.2
#15 0x00007f40c51a7b27 in QMetaObject::activate (sender=0x1bc3580, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3280
#16 0x00007f40c495cf40 in QMenu::qt_metacall (this=0x1bc3580, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffd3e57060) at .moc/release-shared/moc_qmenu.cpp:97
#17 0x00007f40c5198bf9 in QMetaMethod::invoke (this=0x7fffd3e57310, object=0x1bc3580, connectionType=<value optimized out>, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1575
#18 0x00007f40c519a306 in QMetaObject::invokeMethod (obj=0x1bc3580, member=<value optimized out>, type=<value optimized out>, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1148
#19 0x00007f40bdb1f7c1 in DBusMenuImporter::updateMenu() () from /usr/lib/libdbusmenu-qt.so.2
#20 0x00007f40ac9f51bb in StatusNotifierItemSource::contextMenu (this=0x2301c70, x=3161, y=1061) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:466
#21 0x00007f40ac9fb2d8 in StatusNotifierItemJob::start (this=0x2a34860) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#22 0x00007f40c7a090a5 in Plasma::ServiceJob::qt_metacall (this=0x2a34860, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0x2a349d0) at ./servicejob.moc:82
#23 0x00007f40ac9f9cc0 in StatusNotifierItemJob::qt_metacall (this=0x2a34860, _c=44055568, _id=0, _a=0x0) at ./statusnotifieritemjob.moc:70
#24 0x00007f40c51a1bde in QObject::event (this=0x2a34860, e=0x2a34860) at kernel/qobject.cpp:1219
#25 0x00007f40c44f6fdc in QApplicationPrivate::notify_helper (this=0x1095800, receiver=0x2a34860, e=0x2a34e40) at kernel/qapplication.cpp:4396
#26 0x00007f40c44fcaed in QApplication::notify (this=0x1085de0, receiver=0x2a34860, e=0x2a34e40) at kernel/qapplication.cpp:4277
#27 0x00007f40c5e962c6 in KApplication::notify (this=0x1085de0, receiver=0x2a34860, event=0x2a34e40) at ../../kdeui/kernel/kapplication.cpp:311
#28 0x00007f40c518fcdc in QCoreApplication::notifyInternal (this=0x1085de0, receiver=0x2a34860, event=0x2a34e40) at kernel/qcoreapplication.cpp:732
#29 0x00007f40c5192c22 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x1004530) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#30 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x1004530) at kernel/qcoreapplication.cpp:1373
#31 0x00007f40c51bc653 in sendPostedEvents (s=0x1098ea0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#32 postEventSourceDispatch (s=0x1098ea0) at kernel/qeventdispatcher_glib.cpp:277
#33 0x00007f40bcbf6342 in g_main_dispatch (context=0x1098120) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2149
#34 g_main_context_dispatch (context=0x1098120) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2702
#35 0x00007f40bcbfa2a8 in g_main_context_iterate (context=0x1098120, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2780
#36 0x00007f40bcbfa45c in g_main_context_iteration (context=0x1098120, may_block=1) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2843
#37 0x00007f40c51bc193 in QEventDispatcherGlib::processEvents (this=0x1003c20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#38 0x00007f40c45a9a4e in QGuiEventDispatcherGlib::processEvents (this=0x2a34860, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#39 0x00007f40c518ea02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#40 0x00007f40c518edec in QEventLoop::exec (this=0x7fffd3e585d0, flags=) at kernel/qeventloop.cpp:201
#41 0x00007f40c5192ebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#42 0x00007f40c812dcf3 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../../plasma/desktop/shell/main.cpp:118
#43 0x00007f40c7d87d8e in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffd3e589a8) at libc-start.c:226
#44 0x0000000000400669 in _start ()

This bug may be a duplicate of or related to bug 241562.

Possible duplicates by query: bug 267605, bug 267258, bug 267149, bug 267001, bug 266835.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2012-05-22 21:11:02 UTC

*** This bug has been marked as a duplicate of bug 241562 ***