Bug 267853 - KTorrent hangs if a previously set proxy server is down during subsequent downloads; creates defunct process
Summary: KTorrent hangs if a previously set proxy server is down during subsequent dow...
Status: RESOLVED WORKSFORME
Alias: None
Product: ktorrent
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-07 05:23 UTC by Robert Simmons
Modified: 2011-08-06 19:14 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Simmons 2011-03-07 05:23:44 UTC
Version:           unspecified (using KDE 4.6.1) 
OS:                Linux

If you set a proxy server and download a torrent then remove the torrent and close KTorrent you cannot download anything else next time you start KTorrent if that proxy is down because KTorrent gets stuck "Allocating disk space" forever.  Then if you change the proxy server to one that is up nothing happens.  After nothing happening, if you quit KTorrent it leaves you with a defunct process.  You have to reboot your machine to get rid of the defunct process.  While the defunct process is still there you cannot run another instance of KTorrent.

Reproducible: Always

Steps to Reproduce:
configure KTorrent to use a proxy server (not through KDE, but enter the server's address right in the preferences).  Then load a torrent file and download it and remove it from KTorrent.
Then quit KTorrent.
Kill the proxy server so that it is unreachable.
Start KTorrent with a new torrent file and start to download it.
When it gets stuck at disk space allocation try and restart KTorrent, and voila  un(kill -9)able zombie process that prevents KTorrent from ever starting again while it lives.  The only way to kill the defunct process is to restart the OS.

Actual Results:  
creates a defunct process that prevents KTorrent from running.  You must restart to remove the process (it joins the 80-100 kded4 zombies that ya'll also can't seem to figure out how to fix)

Expected Results:  
Graceful error handling when a proxy is down.  An error message perhaps?  An opportunity to change the proxy server's address maybe?

KDE 4.6.1
Kubuntu 10.10
Acer Aspire 3680-2633
Comment 1 Joris Guisson 2011-03-07 18:54:20 UTC
Do you have the "Do not use KIO for tracker announces" option enabled in the advanced preferences ?
Comment 2 Robert Simmons 2011-03-07 20:50:32 UTC
Yes, that's enabled.
Comment 3 Joris Guisson 2011-03-08 19:52:02 UTC
What version are you using ?
Comment 4 Robert Simmons 2011-03-10 05:12:25 UTC
It says 4.0.3 in the about ktorrent screen.

KDE 4.6.1
Comment 5 Joris Guisson 2011-03-13 11:35:56 UTC
Can't seem to reproduce with latest code. Have you tried 4.1rc1 yet ?


Btw, zombies cannot be killed because they are already dead. They are only kept around so that the parent process can call waitpid on them, which will make the zombies go away.
Comment 6 Joris Guisson 2011-03-21 19:27:00 UTC
Not reproducible with 4.1, reopen if you can reproduce it with that version.
Comment 7 Robert Simmons 2011-08-06 19:14:19 UTC
The packages in Ubuntu have been updated to 4.1.1 and the problem is gone for me now.