Bug 267852 - Splash screen hides KWallet password query
Summary: Splash screen hides KWallet password query
Status: RESOLVED FIXED
Alias: None
Product: choqok
Classification: Applications
Component: general (show other bugs)
Version: SVN
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Mehrdad Momeny
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-07 04:34 UTC by Darin McBride
Modified: 2011-03-11 09:12 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Darin McBride 2011-03-07 04:34:31 UTC
Version:           latest svn snapshot (using KDE 4.6.1) 
OS:                Linux

The summary about says it: when starting up Choqok, the splash screen stays up until the password is finished being requested.  However, the splash screen also stays as high in the z-order as possible, hiding the KWallet password dialog, both of which are centered on the first screen.  Since Choqok is the only application I have that requests the local wallet (everything else uses the network wallet), this means that every time Choqok starts up, I have to remember to find the password dialog and put in my password.  I'm fine with having to put in the password, I just wish that the splash screen would go away so I could type in the password.

The splash screen should never last more than 3 seconds, even if the main window can't come up until the password is entered.  Even better would be for the main window to come up, behind the kwallet password dialog, and simply wait for the password before displaying the account tabs or anything in them.

I remember that Windows had a registry entry dictating the longest possible time for a splash screen that all apps were expected to honour.  If KDE has such a global setting somewhere, Choqok should use that time instead of my arbitrary 3 seconds.

Reproducible: Always




OS: Linux (x86_64) release 2.6.36-gentoo-r5
Compiler: x86_64-pc-linux-gnu-gcc
Comment 1 Mehrdad Momeny 2011-03-11 09:11:23 UTC
Git commit 78e7b62d2e64efbf0325d235c8d4afdf453298cd by Mehrdad Momeny.
Committed on 11/03/2011 at 09:09.
Pushed by momeny into branch 'master'.

BUG:267852 First ask for KWallet, and then show up the splash screen ;)
Also, Splash screens are closed by clicking on them!

M  +12   -12   choqok/mainwindow.cpp     

http://commits.kde.org/choqok/78e7b62d2e64efbf0325d235c8d4afdf453298cd
Comment 2 Mehrdad Momeny 2011-03-11 09:12:09 UTC
Git commit 39effecf10c47f9022ee943840c156a0746aa81b by Mehrdad Momeny.
Committed on 11/03/2011 at 09:09.
Pushed by momeny into branch '1.0'.

BUG:267852 First ask for KWallet, and then show up the splash screen ;)
Also, Splash screens are closed by clicking on them!

M  +12   -12   choqok/mainwindow.cpp     

http://commits.kde.org/choqok/39effecf10c47f9022ee943840c156a0746aa81b