Bug 267629 - Special window settings not working
Summary: Special window settings not working
Status: RESOLVED DUPLICATE of bug 264981
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR normal
Target Milestone: ---
Assignee: KWin default assignee
Depends on:
Reported: 2011-03-04 16:03 UTC by Tommi Nieminen
Modified: 2012-03-11 05:18 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:

kwinrulesrc showing a “remember position” rule (776 bytes, text/plain)
2011-03-04 21:31 UTC, Tommi Nieminen

Note You need to log in before you can comment on or make changes to this bug.
Description Tommi Nieminen 2011-03-04 16:03:39 UTC
Version:           4.6 (using KDE 4.6.0) 
OS:                Linux

Remembering special window (and application) settings in KDE 4.6.0 seem not be working at all or act weirdly. For example, Geometry > Position > Remember and Geometry > Size > Remember sometimes seem to be doing something but they do *not* remember the window positions although they might affect the positioning of windows. On the other hand, forcing a setting does seem to work.

Reproducible: Always

Steps to Reproduce:
Right click window title, go to > Advanced settings > Special window (or application) settings > Geometry page, select a setting, close the window, open it again.

Actual Results:  
Mostly the window opening behaviour is not changed.

Expected Results:  
E.g., remember to window position.

Tested by me only in openSUSE 11.4 RC1/RC2 but I’ve heard the same from users using other distributions running KDE 4.6.
Comment 1 Thomas Lübking 2011-03-04 20:14:47 UTC
Works like charm here.

- Does this also happen with xterm?
(some clients reposition after the original map - this remains honored and would have to be forced down as well)
- Does the rule actually apply (is it there if you attempt to re-create it after the fail?)
- Do you use more than one screen?
- What's your window placement strategy?
Comment 2 Tommi Nieminen 2011-03-04 21:02:03 UTC
(In reply to comment #1)

> - Does this also happen with xterm?

Yes. xterm doesn’t respect even the “Force” setting, unlike, say, system-settings.

> - Does the rule actually apply (is it there if you attempt to re-create it
> after the fail?)

Yes. You can see the stored coordinates in system-settings > Window rules > rule so-and-so, and they are correct but not respected.

> - Do you use more than one screen?

No. (Unless you mean virtual desktops but I guess not?)

> - What's your window placement strategy?

Usually “Smart”, but I now tried changing it to “Random” with no results.

(BTW, I’m using KDE in Finnish but it *can’t* be in the localizations, right?)
Comment 3 Thomas Lübking 2011-03-04 21:23:32 UTC
can you please attach ~/.kde/share/config/kwinrulesrc (with such rule being set, oc.)
Comment 4 Tommi Nieminen 2011-03-04 21:31:39 UTC
Created attachment 57681 [details]
kwinrulesrc showing a “remember position” rule

Target is the first rule [1] with which I’ve tried to set the position of KMail’s reader window. For some reason, the title of the last-opened message is shown, but titlematch=0 so this shouldn’t matter.
Comment 5 Thomas Lübking 2011-03-04 22:41:02 UTC
please try to disable the  rolematch ("kcmshell4 kwinrules", select the rule, set the windowrole to "unimportant"...
Comment 6 Tommi Nieminen 2011-03-05 16:49:32 UTC
(In reply to comment #5)

> please try to disable the  rolematch ("kcmshell4 kwinrules", select the rule,
> set the windowrole to "unimportant"...

I’m not quite sure what you hoped to accomplish... The window role was matched for a reason, namely, for the rule to catch only the message reader windows.

In any case, setting the role to unimportant did have a rather unexpected result. It changed the remembered coordinates of the window to 0,0, and true enough, new reader windows pop up at the upper left-hand corner of the screen. Changing the coordinates by hand to something else doesn’t help, as they are always “updated” to 0,0 after the settings window is OK’ḍ away.
Comment 7 Tommi Nieminen 2011-03-05 16:51:46 UTC
No, sorry, I change that.

If “Apply” button is pressed before OK’ing the settings window, the coordinate values *are* remembered (I tried 500,500). It doesn’t however change the position of the opening window, which is still in the upper left-hand corner of the screen.
Comment 8 Tommi Nieminen 2011-03-05 16:54:46 UTC
One more thing to add... I’m not sure if this is relevant, but as I followed your advice to the letter and opened the window settings window from the terminal, there was the following output:

X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 20 (X_GetProperty)
  Resource id:  0x7801cb7

I use Yakuake as my terminal emulator so I didn’t notice this before.
Comment 9 Thomas Lübking 2011-03-05 17:18:08 UTC
The error code isn't important/related.
To put it straight (ftm leaving aside all apply issues to existing windows, button press order):
after removing the rolematch it worked, yes?

(i think the role is added "too late" by the client and as a result doesn't match when calculating the initial position, we'd have to check whether this can be postponed, but i want to ensure that the rolematch is the match blocker)
Comment 10 Tommi Nieminen 2011-03-05 17:29:11 UTC
(In reply to comment #9)

> after removing the rolematch it worked, yes?

Well, no, it doesn’t.

I mean, although something seems to be different since the opening window is always positioned in the upper left-hand corner of the screen, that still doesn’t reflect the saved coordinates (1181,271 at the moment).

Forcing the position still works, no change there.
Comment 11 Tommi Nieminen 2011-03-07 22:55:48 UTC
I’m getting mixed replies from Finnish openSUSE forum... It appears that openSUSE’s KDE 4.6.00 (4.6.0) “release 6” *has* this bug while KDE 4.6.00 (4.6.0) “release 395” doesn’t. I have no idea where the latter version is coming, but this raises the possibility that the problem is openSUSE-specific.
Comment 12 Tommi Nieminen 2011-03-14 21:06:56 UTC
Tested now in Sabayon Linux 5.5 with KDE 4.6.1: this bug is nonexistent there.

I’ve now filed this bug under openSUSE’s Bugzilla.
Comment 13 Thomas Lübking 2011-03-14 21:28:09 UTC
Ok, i'll mark it as downstream ("distro bug")
If it actually turns out to be not, just reopen it.
Comment 14 Tommi Nieminen 2011-03-14 23:28:48 UTC
SORRY! Looks like I was wrong. Sabayon just started to function just like openSUSE did: “remembered” windows open at the upper left-hand corner of the screen. I’m not sure of what has happened. Was I still trying under KDE 4.5 in my first attempts, since updates were still loading?

So, please don’t make it a distro bug, since Sabayon 5.5 with KDE 4.6.1 (note: .1) seems to suffer from the same.
Comment 15 Thomas Lübking 2011-03-14 23:32:20 UTC
ok, resetting to unconfirmed.
have you ever tried this with a new user account?
Comment 16 Thomas Lübking 2012-03-11 05:18:14 UTC
this is for sure the "activities break remember rule" bug. if not, please reopen.

*** This bug has been marked as a duplicate of bug 264981 ***