Bug 267562 - Desktopgrid needs to validate the windowMove pointer on windowDeleted
Summary: Desktopgrid needs to validate the windowMove pointer on windowDeleted
Status: RESOLVED DUPLICATE of bug 233363
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-03 16:32 UTC by Bob K
Modified: 2011-04-03 22:46 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Here you can see that there is a weird single tw icon on the upright (278.97 KB, image/jpeg)
2011-03-03 17:40 UTC, Bob K
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bob K 2011-03-03 16:32:06 UTC
Application: kwin (4.6.00 (4.6.0))
KDE Platform Version: 4.6.00 (4.6.0)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-25-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
I was started a bible study program named theword, which is a windows app so i ran it from wine. After executing i moved into desktop grid and when i exited from it plasma has crashed. Also, theword isn't started up.

I have tried three times, the first was this crash, the second time there are no crash, but theword doesn't started, third time everyting went fine. (After both i tried to do the same thing.)

The crash does not seem to be reproducible.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7826720 (LWP 1683))]

Thread 3 (Thread 0xb3c3bb70 (LWP 1746)):
#0  0x01f64e36 in clock_gettime () from /lib/librt.so.1
#1  0x065b550b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0x0668c6e5 in QTimerInfoList::updateCurrentTime (this=0xa53a030) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0668c72a in QTimerInfoList::timerWait (this=0xa53a030, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x0668dcab in QEventDispatcherUNIX::processEvents (this=0xa549340, flags=...) at kernel/qeventdispatcher_unix.cpp:906
#6  0x0665a609 in QEventLoop::processEvents (this=0xb3c3b280, flags=) at kernel/qeventloop.cpp:149
#7  0x0665aa8a in QEventLoop::exec (this=0xb3c3b280, flags=...) at kernel/qeventloop.cpp:201
#8  0x06556b7e in QThread::exec (this=0xa3f5548) at thread/qthread.cpp:490
#9  0x0663935b in QInotifyFileSystemWatcherEngine::run (this=0xa3f5548) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x06559df9 in QThreadPrivate::start (arg=0xa3f5548) at thread/qthread_unix.cpp:266
#11 0x012a1cc9 in start_thread () from /lib/libpthread.so.0
#12 0x0030b69e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xb343ab70 (LWP 1747)):
#0  0x00110416 in __kernel_vsyscall ()
#1  0x012a64dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x00318d9d in pthread_cond_wait () from /lib/libc.so.6
#3  0x00fb3877 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x10b21a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0x00fb38c1 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x10b21a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0x012a1cc9 in start_thread () from /lib/libpthread.so.0
#6  0x0030b69e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb7826720 (LWP 1683)):
[KCrash Handler]
#7  0x00000000 in ?? ()
#8  0x0379b32e in KWin::DesktopGridEffect::windowInputMouseEvent (this=0xa350da0, e=0xbfa4a688) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:544
#9  0x00df4f10 in KWin::EffectsHandlerImpl::checkInputWindowEvent (this=0xa2f6dd8, e=0xbfa4abec) at ../../kwin/effects.cpp:926
#10 0x00d8005e in KWin::Workspace::workspaceEvent (this=0x9d56a50, e=0xbfa4abec) at ../../kwin/events.cpp:262
#11 0x00d55d52 in KWin::Application::x11EventFilter (this=0xbfa4adf4, e=0xbfa4abec) at ../../kwin/main.cpp:367
#12 0x0725ceb0 in qt_x11EventFilter (ev=0xbfa4abec) at kernel/qapplication_x11.cpp:408
#13 0x0726dab0 in QApplication::x11ProcessEvent (this=0xbfa4adf4, event=0xbfa4abec) at kernel/qapplication_x11.cpp:3248
#14 0x0729efc7 in QEventDispatcherX11::processEvents (this=0x9cdaba0, flags=...) at kernel/qeventdispatcher_x11.cpp:132
#15 0x0665a609 in QEventLoop::processEvents (this=0xbfa4ad24, flags=) at kernel/qeventloop.cpp:149
#16 0x0665aa8a in QEventLoop::exec (this=0xbfa4ad24, flags=...) at kernel/qeventloop.cpp:201
#17 0x0665f00f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#18 0x071dae07 in QApplication::exec () at kernel/qapplication.cpp:3672
#19 0x00d58d00 in kdemain (argc=1, argv=0xbfa4b074) at ../../kwin/main.cpp:542
#20 0x080485ab in main (argc=1, argv=0xbfa4b074) at kwin_dummy.cpp:3

This bug may be a duplicate of or related to bug 253942.

Possible duplicates by query: bug 262893, bug 253942, bug 249137, bug 248817, bug 233363.

Reported using DrKonqi
Comment 1 Thomas Lübking 2011-03-03 16:44:50 UTC
judging from the backtrace, you attempted to move a(n apparently invalid) client - probably the wine application window.

-> (dev note)
windowDeleted() lacks a "if (w == windowMove) windowMove = 0;" statement
Comment 2 Bob K 2011-03-03 17:39:27 UTC
I don't remember exactly, but as i remember theword hasn't got any visible window when it first happened. The other times i'm sure i'm not wanted to move the window.

By the way wine or theword messes something with windowing, i will attach an image about it.
Also, you can simply test it because theword is a free software and can be downloaded at http://theword.net, runs with wine without any messing.
Comment 3 Bob K 2011-03-03 17:40:55 UTC
Created attachment 57647 [details]
Here you can see that there is a weird single tw icon on the upright
Comment 4 Thomas Lübking 2011-03-03 19:21:30 UTC
looks like it adds some completely shaped away client (some "handcrafted" splash or sth.?), but that's OT

more OT:
maybe have a look at http://www.bibletime.info/ - it uses Qt4/KDE4, can say anything about its feature scale/scope though.
Comment 5 Martin Flöser 2011-03-18 19:20:02 UTC

*** This bug has been marked as a duplicate of bug 233363 ***
Comment 6 Thomas Lübking 2011-04-03 22:46:15 UTC
Git commit 0c23185cfd2b0210d58af603b94813a5473a547d by Thomas Lübking.
Committed on 07/03/2011 at 18:38.
Pushed by luebking into branch 'master'.

validate deleted moving window in desktop grid effect

BUG:233363
CCBUG:267562

M  +2    -0    kwin/effects/desktopgrid/desktopgrid.cpp     

http://commits.kde.org/kde-workspace/0c23185cfd2b0210d58af603b94813a5473a547d