Bug 267400 - crashed
Summary: crashed
Status: RESOLVED DUPLICATE of bug 237000
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.3.2
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: 2.4.1
Assignee: Amarok Developers
URL:
Keywords:
: 267410 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-03-01 18:20 UTC by amoffitt07
Modified: 2011-03-05 16:47 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description amoffitt07 2011-03-01 18:20:48 UTC
Application: amarok (2.3.2)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-22-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

It was just opened while the computer was on idle and crashed

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f8f511a1820 (LWP 2106))]

Thread 13 (Thread 0x7f8f311fe710 (LWP 2107)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:212
#1  0x00007f8f375640d1 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f8f4ba88971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#3  0x00007f8f4df8e92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 12 (Thread 0x7f8f309fd710 (LWP 2108)):
#0  0x00007f8f4ba8bc9d in __pthread_mutex_unlock_usercnt (mutex=0x2552728) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x2552728) at pthread_mutex_unlock.c:290
#2  0x00007f8f47cafb51 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#3  0x00007f8f47cafe78 in ?? () from /lib/libglib-2.0.so.0
#4  0x00007f8f47cb045c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x00007f8f4e8dc1e6 in QEventDispatcherGlib::processEvents (this=0x25b4460, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#6  0x00007f8f4e8aea02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#7  0x00007f8f4e8aedec in QEventLoop::exec (this=0x7f8f309fccd0, flags=) at kernel/qeventloop.cpp:201
#8  0x00007f8f4e7b92fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#9  0x00007f8f377c02b0 in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#10 0x00007f8f4e7bc27e in QThreadPrivate::start (arg=0x2550e10) at thread/qthread_unix.cpp:266
#11 0x00007f8f4ba88971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#12 0x00007f8f4df8e92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 11 (Thread 0x7f8f2bdfa710 (LWP 2109)):
#0  0x00007f8f4df821e3 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:85
#1  0x00007f8f45eb640f in ?? () from /usr/lib/libpulse.so.0
#2  0x00007f8f45ea5d76 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#3  0x00007f8f45ea77f9 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#4  0x00007f8f45ea78b0 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#5  0x00007f8f45eb620b in ?? () from /usr/lib/libpulse.so.0
#6  0x00007f8f416a7fb8 in ?? () from /usr/lib/libpulsecommon-0.9.21.so
#7  0x00007f8f4ba88971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#8  0x00007f8f4df8e92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7f8f275f8710 (LWP 2110)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f8f37574e83 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f8f4ba88971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#3  0x00007f8f4df8e92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7f8f269ed710 (LWP 2111)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f8f37574e83 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f8f4ba88971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#3  0x00007f8f4df8e92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f8f261ec710 (LWP 2112)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f8f37574e83 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f8f4ba88971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#3  0x00007f8f4df8e92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f8f259eb710 (LWP 2113)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f8f37574e83 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f8f4ba88971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#3  0x00007f8f4df8e92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f8f240eb710 (LWP 2115)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f8f4e7bce3b in wait (this=<value optimized out>, mutex=0x2e22f50, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x2e22f50, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f8f4a6e7524 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2d6c170, th=0x2d8ad30) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f8f4a6ea72b in ThreadWeaver::WorkingHardState::applyForWork (this=0x2d79530, th=0x2d8ad30) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f8f4a6ea744 in ThreadWeaver::WorkingHardState::applyForWork (this=0x2d79530, th=0x2d8ad30) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f8f4a6e8c9f in ThreadWeaver::ThreadRunHelper::run (this=0x7f8f240ead40, parent=0x2d6c170, th=0x2d8ad30) at ../../../threadweaver/Weaver/Thread.cpp:87
#7  0x00007f8f4a6e91f8 in ThreadWeaver::Thread::run (this=0x2d8ad30) at ../../../threadweaver/Weaver/Thread.cpp:142
#8  0x00007f8f4e7bc27e in QThreadPrivate::start (arg=0x2d8ad30) at thread/qthread_unix.cpp:266
#9  0x00007f8f4ba88971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#10 0x00007f8f4df8e92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f8f1a568710 (LWP 2118)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f8f49f27334 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f8f4a232160) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f8f49f27369 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f8f4a240234) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f8f4ba88971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#4  0x00007f8f4df8e92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f8f16c7f710 (LWP 2120)):
#0  0x00007f8f4df8070d in __read_nocancel () at ../sysdeps/unix/syscall-template.S:82
#1  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f8f162a3710 (LWP 2124)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f8f4e7bce3b in wait (this=<value optimized out>, mutex=0x2e22f50, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x2e22f50, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f8f4a6e7524 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2d6c170, th=0x2c93520) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f8f4a6ea72b in ThreadWeaver::WorkingHardState::applyForWork (this=0x2d79530, th=0x2c93520) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f8f4a6e8c9f in ThreadWeaver::ThreadRunHelper::run (this=0x7f8f162a2d40, parent=0x2d6c170, th=0x2c93520) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f8f4a6e91f8 in ThreadWeaver::Thread::run (this=0x2c93520) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f8f4e7bc27e in QThreadPrivate::start (arg=0x2c93520) at thread/qthread_unix.cpp:266
#8  0x00007f8f4ba88971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#9  0x00007f8f4df8e92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f8f15aa2710 (LWP 2126)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f8f4e7bce3b in wait (this=<value optimized out>, mutex=0x2e22f50, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x2e22f50, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f8f4a6e7524 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2d6c170, th=0x271dd60) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f8f4a6ea72b in ThreadWeaver::WorkingHardState::applyForWork (this=0x2d79530, th=0x271dd60) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f8f4a6ea744 in ThreadWeaver::WorkingHardState::applyForWork (this=0x2d79530, th=0x271dd60) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f8f4a6e8c9f in ThreadWeaver::ThreadRunHelper::run (this=0x7f8f15aa1d40, parent=0x2d6c170, th=0x271dd60) at ../../../threadweaver/Weaver/Thread.cpp:87
#7  0x00007f8f4a6e91f8 in ThreadWeaver::Thread::run (this=0x271dd60) at ../../../threadweaver/Weaver/Thread.cpp:142
#8  0x00007f8f4e7bc27e in QThreadPrivate::start (arg=0x271dd60) at thread/qthread_unix.cpp:266
#9  0x00007f8f4ba88971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#10 0x00007f8f4df8e92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f8f511a1820 (LWP 2106)):
[KCrash Handler]
#6  0x00007f8f227cbc0d in KSharedPtr (this=0x8) at /usr/include/ksharedptr.h:84
#7  Podcasts::UmsPodcastProvider::playlists (this=0x8) at ../../../../../src/core-impl/collections/umscollection/podcasts/UmsPodcastProvider.cpp:168
#8  0x00007f8f5025fc04 in PlaylistBrowserNS::PlaylistBrowserModel::data (this=<value optimized out>, index=<value optimized out>, role=<value optimized out>) at ../../src/browsers/playlistbrowser/PlaylistBrowserModel.cpp:199
#9  0x00007f8f5028b081 in PlaylistBrowserNS::PodcastModel::data (this=0x2ca2210, idx=..., role=16) at ../../src/browsers/playlistbrowser/PodcastModel.cpp:284
#10 0x00007f8f4e8a4877 in QAbstractItemModel::itemData (this=0x2ca2210, index=<value optimized out>) at kernel/qabstractitemmodel.cpp:1647
#11 0x00007f8f5026c729 in QtGroupingProxy::belongsTo (this=<value optimized out>, idx=<value optimized out>) at ../../src/browsers/playlistbrowser/QtGroupingProxy.cpp:64
#12 0x00007f8f5026d689 in QtGroupingProxy::buildTree (this=<value optimized out>) at ../../src/browsers/playlistbrowser/QtGroupingProxy.cpp:151
#13 0x00007f8f4fee9339 in QtGroupingProxy::qt_metacall (this=0x2ca0790, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff8ba29d20) at moc_QtGroupingProxy.cpp:94
#14 0x00007f8f4fee93e5 in PlaylistsByProviderProxy::qt_metacall (this=0x7f8f4e226e40, _c=QMetaObject::QueryPropertyUser, _id=269294360, _a=0x3193601) at moc_PlaylistsByProviderProxy.cpp:73
#15 0x00007f8f4e8c7b27 in QMetaObject::activate (sender=0x2ca2210, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x3193601) at kernel/qobject.cpp:3280
#16 0x00007f8f50256d14 in PlaylistBrowserNS::PlaylistBrowserModel::slotUpdate (this=0x2ca2210) at ../../src/browsers/playlistbrowser/PlaylistBrowserModel.cpp:526
#17 0x00007f8f4fee89f8 in PlaylistBrowserNS::PlaylistBrowserModel::qt_metacall (this=0x2ca2210, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff8ba29f00) at moc_PlaylistBrowserModel.cpp:85
#18 0x00007f8f5028da70 in PlaylistBrowserNS::PodcastModel::qt_metacall (this=0x7f8f4e226e40, _c=QMetaObject::QueryPropertyUser, _id=269294360, _a=0x3193601) at ./PodcastModel.moc:74
#19 0x00007f8f4e8c7b27 in QMetaObject::activate (sender=0x29d1410, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x3193601) at kernel/qobject.cpp:3280
#20 0x00007f8f502a1b28 in PlaylistManager::qt_metacall (this=0x29d1410, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7f8f100b41c0) at ./PlaylistManager.moc:94
#21 0x00007f8f4e8c1bde in QObject::event (this=0x29d1410, e=0x7f8f4e226e40) at kernel/qobject.cpp:1219
#22 0x00007f8f4f265fdc in QApplicationPrivate::notify_helper (this=0x2460ce0, receiver=0x29d1410, e=0x7f8f100bbbf0) at kernel/qapplication.cpp:4396
#23 0x00007f8f4f26baed in QApplication::notify (this=0x7fff8ba2a9a0, receiver=0x29d1410, e=0x7f8f100bbbf0) at kernel/qapplication.cpp:4277
#24 0x00007f8f50ba1156 in KApplication::notify (this=0x7fff8ba2a9a0, receiver=0x29d1410, event=0x7f8f100bbbf0) at ../../kdeui/kernel/kapplication.cpp:310
#25 0x00007f8f4e8afcdc in QCoreApplication::notifyInternal (this=0x7fff8ba2a9a0, receiver=0x29d1410, event=0x7f8f100bbbf0) at kernel/qcoreapplication.cpp:732
#26 0x00007f8f4e8b2c22 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x230c270) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#27 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x230c270) at kernel/qcoreapplication.cpp:1373
#28 0x00007f8f4e8dc653 in sendPostedEvents (s=0x2468480) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#29 postEventSourceDispatch (s=0x2468480) at kernel/qeventdispatcher_glib.cpp:277
#30 0x00007f8f47cac342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#31 0x00007f8f47cb02a8 in ?? () from /lib/libglib-2.0.so.0
#32 0x00007f8f47cb045c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#33 0x00007f8f4e8dc193 in QEventDispatcherGlib::processEvents (this=0x230bd80, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#34 0x00007f8f4f318a4e in QGuiEventDispatcherGlib::processEvents (this=0x7f8f4e226e40, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#35 0x00007f8f4e8aea02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#36 0x00007f8f4e8aedec in QEventLoop::exec (this=0x7fff8ba2a940, flags=) at kernel/qeventloop.cpp:201
#37 0x00007f8f4e8b2ebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#38 0x00000000004081ea in main (argc=<value optimized out>, argv=0x7fff8ba2c908) at ../../src/main.cpp:237

Possible duplicates by query: bug 262909, bug 261944, bug 259550, bug 257863, bug 254714.

Reported using DrKonqi
Comment 1 Kevin Funk 2011-03-02 20:31:18 UTC
*** Bug 267410 has been marked as a duplicate of this bug. ***
Comment 2 Myriam Schweingruber 2011-03-05 16:47:56 UTC

*** This bug has been marked as a duplicate of bug 237000 ***