Bug 267371 - Attach file dialog corrupts directory name, then says "The file or folder does not exist."
Summary: Attach file dialog corrupts directory name, then says "The file or folder doe...
Status: RESOLVED DUPLICATE of bug 322837
Alias: None
Product: kfile
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian stable Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-01 10:57 UTC by usnay12345
Modified: 2018-04-13 16:50 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description usnay12345 2011-03-01 10:57:20 UTC
Version:           1.13.5 (using KDE 4.4.5) 
OS:                Linux

Directories in the root directory whose names are one letter and a colon (:) are not parsed correctly on Linux.

Attempting to switch to the directory /E:/DMW/JOBS fails.
The Attach dialog displays the path as Root > DMW > JOBS
and a popup "The file or folder E:/DMW/JOBS does not exist." is displayed.

Note that the top of the dialog says "Root" where "E:" was expected, and the popup says "E:/..." where "/E:/..." was expected (i.e. the leading '/' which I keyed in has been lost).

Using a symlink or renaming the directory circumvents the problem.

This bug could be in a lower level component, because Konqueror also cannot display file:///E:/DMW/JOBS or just /E:/DMW/JOBS, but doesn't give as much info as the Attach dialog does.

This directory path has been working on KDE 2.x and 3.x for many years.  It has not worked on KDE 4.4.5.  I upgraded from Debian Lenny (KDE 3.5.10) to Debian Squeeze (KDE 4.4.5) last week, and it hasn't worked since.

My best guess is that code which tries to make KMail (or KDE) portable to Windows is at fault, by failing to handle the possibility of a Linux directory with a name similar to a Windows drive.

Reproducible: Didn't try

Steps to Reproduce:
Preparation:
Create the directory /E:/DMW/JOBS and place a file in it.
The directory and file should be owned by the user who will perform the test.
The directory must have permissions 775 and the file 664.

The test:
Create an email.
Press Attach.
Key in directory path /E:/DMW/JOBS/ and press enter.


Actual Results:  
The top of the Attach dialog now says
Root > DMW > JOBS
the list of files is empty
and a popup appears with the message
The file or folder E:/DMW/JOBS does not exist.

Expected Results:  
It should have switched to the specified directory.
The top of the Attach dialog should say:
E: > DMW > JOBS
The list of files in the /E:/DMW/JOBS directory should be displayed,
and the user should be able to select one to attach.

OS: Linux (i686) release 2.6.32-5-686
Compiler: cc
Comment 1 usnay12345 2011-03-01 11:00:04 UTC
"Reproducible: Didn't try"  isn't accurate.  I missed whatever field I was supposed to set for this.  The problem is 100% reproducible.
Comment 2 Christophe Marin 2011-04-30 16:07:37 UTC
reassign to kdelibs. reproducible with eg Dolphin
Comment 3 Nate Graham 2018-04-13 16:50:52 UTC

*** This bug has been marked as a duplicate of bug 322837 ***