Bug 267344 - Okular stops displaying the document when clicked on section in contents pane refering to not existing file.
Summary: Okular stops displaying the document when clicked on section in contents pane...
Status: RESOLVED FIXED
Alias: None
Product: okular
Classification: Unclassified
Component: general (show other bugs)
Version: 0.11.2
Platform: openSUSE RPMs Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-28 22:46 UTC by Jakub Kuzniar
Modified: 2011-08-10 12:46 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.8.0


Attachments
Pdf link test file (5.42 KB, application/pdf)
2011-07-13 22:19 UTC, Jakub Kuzniar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jakub Kuzniar 2011-02-28 22:46:41 UTC
Version:           0.11.2
OS:                Linux

Sometimes I open specific pdf files, with content information (sections, subsections) which are links to other pdf files. Whenever the link cannot be resolved by okular, the message window is displayed with error and information that file cannot be found. The problem is the behaviour of the program which in case of such error, closes already opened document and leaves empty window. I cannot move back. So the easiest way is to close the program and reopen document one more time. When I have a lot of such files, it is annoying to reopen okular whenever I click on wrong section. Also I don't know how to recognize sections pointing to not existing files. So my propose is to simple do file exists check after the user clicks on section pointing to other file and before closing already opened document.

Thank you for your work.



Reproducible: Always

Steps to Reproduce:
1. Find pdf file witch sections pointing to other files (some of scientific journals, knovel.com) 
2. Open pdf file
3. Click on sections in contents pane until you find section pointing to not existing file.
Comment 1 Christopher Reichert 2011-07-13 18:02:38 UTC
Could you please attach a document or a better link to some exact documents. I tried to follow the link but couldn't find a document to reproduce the problem
Comment 2 Jakub Kuzniar 2011-07-13 22:12:27 UTC
Here is the prepared pdf documents. This is not exatly the same, because the 
link is in text not in the toc. But behaviour is the same.



Dnia środa, 13 lipca 2011 o 20:02:38 Christopher Reichert napisał(a):
> https://bugs.kde.org/show_bug.cgi?id=267344
> 
> 
> Christopher Reichert <creichert07@gmail.com> changed:
> 
>            What    |Removed                     |Added
> ---------------------------------------------------------------------------
> - CC|                            |creichert07@gmail.com
> 
> 
> 
> 
> --- Comment #1 from Christopher Reichert <creichert07 gmail com> 
> 2011-07-13 18:02:38 --- Could you please attach a document or a better
> link to some exact documents. I tried to follow the link but couldn't find
> a document to reproduce the problem
Comment 3 Jakub Kuzniar 2011-07-13 22:19:15 UTC
Created attachment 61857 [details]
Pdf link test file
Comment 4 Jakub Kuzniar 2011-07-13 22:20:40 UTC
I am sorry, in in previous comment there was no attachment.
Comment 5 Albert Astals Cid 2011-07-18 14:32:43 UTC
Not sure what the problem is, you click in a link that says "Open this file", and the file does not exist, we give you a warning saying the file does not exist. What is your expectation?
Comment 6 Jakub Kuzniar 2011-07-18 16:58:19 UTC
My  expactation is not to close whole document in case of error.  Imagine that 
you work on a big pdf, a book with table of contents on lthe eft pane.  Whole 
book was divided in several parts. So the toc consist of chapters which are 
links directing to other files. Clicking on some link will eventaully raise 
error and close your for example 10 MB book.  I am usually searching through 
pdf files for specific information like scientific data, so when such error 
appears I would like to continue searching in the same file, but program 
closes the document and forces me to reopen it.

This is rather an usability problem. But I found it very annoying. 

Thank you.

Dnia poniedziałek, 18 lipca 2011 o 16:32:44 Albert Astals Cid napisał(a):
> https://bugs.kde.org/show_bug.cgi?id=267344
> 
> 
> 
> 
> 
> --- Comment #5 from Albert Astals Cid <tsdgeos terra es>  2011-07-18
> 14:32:43 --- Not sure what the problem is, you click in a link that says
> "Open this file", and the file does not exist, we give you a warning
> saying the file does not exist. What is your expectation?
Comment 7 Albert Astals Cid 2011-08-10 09:17:30 UTC
Git commit b8870e5bb04d774d605b3b6fe99b0d38a2038000 by Albert Astals Cid.
Committed on 10/08/2011 at 11:15.
Pushed by aacid into branch 'master'.

Stat the file before switching to it

This way if the document does not exist at least we do not loose the current file
FIXED-IN: 4.8.0
BUGS: 267344

M  +8    -3    part.cpp

http://commits.kde.org/okular/b8870e5bb04d774d605b3b6fe99b0d38a2038000
Comment 8 Jakub Kuzniar 2011-08-10 12:46:55 UTC
Thank you very much.
Best regards.



2011/8/10 Albert Astals Cid <tsdgeos@terra.es>:
> https://bugs.kde.org/show_bug.cgi?id=267344
>
>
> Albert Astals Cid <tsdgeos@terra.es> changed:
>
>           What    |Removed                     |Added
> ----------------------------------------------------------------------------
>             Status|UNCONFIRMED                 |RESOLVED
>   Version Fixed In|                            |4.8.0
>         Resolution|                            |FIXED
>
>
>
>
> --- Comment #7 from Albert Astals Cid <tsdgeos terra es>  2011-08-10 09:17:30 ---
> Git commit b8870e5bb04d774d605b3b6fe99b0d38a2038000 by Albert Astals Cid.
> Committed on 10/08/2011 at 11:15.
> Pushed by aacid into branch 'master'.
>
> Stat the file before switching to it
>
> This way if the document does not exist at least we do not loose the current
> file
> FIXED-IN: 4.8.0
> BUGS: 267344
>
> M  +8    -3    part.cpp
>
> http://commits.kde.org/okular/b8870e5bb04d774d605b3b6fe99b0d38a2038000
>
> --
> Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>