Bug 266967 - na schermbevijliging
Summary: na schermbevijliging
Status: RESOLVED DUPLICATE of bug 240285
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-23 13:45 UTC by moll1
Modified: 2011-03-07 22:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description moll1 2011-02-23 13:45:15 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-25-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
nothing the p.c. just startet from screen/display prtection

-- Backtrace:
Application: Plasma-werkgebied (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7898720 (LWP 1369))]

Thread 2 (Thread 0xaebb9b70 (LWP 1422)):
#0  0x00b88f6a in pthread_mutex_lock () from /lib/libc.so.6
#1  0x02b75ea3 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#2  0x02b76279 in ?? () from /lib/libglib-2.0.so.0
#3  0x02b76848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0x047a559f in QEventDispatcherGlib::processEvents (this=0x9c067d8, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#5  0x04775609 in QEventLoop::processEvents (this=0xaebb9280, flags=) at kernel/qeventloop.cpp:149
#6  0x04775a8a in QEventLoop::exec (this=0xaebb9280, flags=...) at kernel/qeventloop.cpp:201
#7  0x04671b7e in QThread::exec (this=0x9c04ce0) at thread/qthread.cpp:490
#8  0x0475435b in QInotifyFileSystemWatcherEngine::run (this=0x9c04ce0) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x04674df9 in QThreadPrivate::start (arg=0x9c04ce0) at thread/qthread_unix.cpp:266
#10 0x0058ecc9 in start_thread () from /lib/libpthread.so.0
#11 0x00b7b69e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb7898720 (LWP 1369)):
[KCrash Handler]
#7  0x048a7089 in vtable for BackEase () from /usr/lib/libQtCore.so.4
#8  0x0478f0e4 in QObject::disconnect (sender=0x9bc7448, signal=0x0, receiver=0xa0e7050, method=0x325b732 "2hasDefaultRouteChanged(bool)") at kernel/qobject.cpp:2749
#9  0x0324b09d in disconnect (this=0x9bc7448) at /usr/include/qt4/QtCore/qobject.h:229
#10 InterfaceItem::currentConnectionChanged (this=0x9bc7448) at ../../applet/interfaceitem.cpp:311
#11 0x0324a80f in InterfaceItem::setConnectionInfo (this=0x9bc7448) at ../../applet/interfaceitem.cpp:270
#12 0x0324d6ef in WirelessInterfaceItem::setConnectionInfo (this=0x9bc7448) at ../../applet/wirelessinterfaceitem.cpp:64
#13 0x0324d6b4 in WirelessInterfaceItem::updateInfo (this=0x9bc7448) at ../../applet/wirelessinterfaceitem.cpp:54
#14 0x0323fc81 in WirelessInterfaceItem::qt_metacall (this=0x9bc7448, _c=QMetaObject::InvokeMetaMethod, _id=55, _a=0xbfca33e8) at moc_wirelessinterfaceitem.cpp:74
#15 0x0477c8ca in QMetaObject::metacall (object=0x9bc7448, cl=52817907, idx=55, argv=0xbfca33e8) at kernel/qmetaobject.cpp:237
#16 0x0478f6ad in QMetaObject::activate (sender=0x9bd52a0, m=0x325da6c, local_signal_index=0, argv=0xffffc590) at kernel/qobject.cpp:3280
#17 0x0323eac3 in WirelessStatus::strengthChanged (this=0x9bd52a0, _t1=0) at moc_wirelessstatus.cpp:94
#18 0x03257e34 in WirelessStatus::setStrength (this=0x9bd52a0, strength=-14960) at ../../applet/wirelessstatus.cpp:181
#19 0x032581c7 in WirelessStatus::accessPointDestroyed (this=0x9bd52a0, ap=0xffffc590) at ../../applet/wirelessstatus.cpp:215
#20 0x0323ee61 in WirelessStatus::qt_metacall (this=0x9bd52a0, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0xbfca35a8) at moc_wirelessstatus.cpp:82
#21 0x0477c8ca in QMetaObject::metacall (object=0x9bd52a0, cl=52817907, idx=7, argv=0xbfca35a8) at kernel/qmetaobject.cpp:237
#22 0x0478f6ad in QMetaObject::activate (sender=0x9b64ba0, m=0x48a4230, local_signal_index=0, argv=0xffffc590) at kernel/qobject.cpp:3280
#23 0x0478fbd3 in QObject::destroyed (this=0x9b64ba0, _t1=0x9b64ba0) at .moc/release-shared/moc_qobject.cpp:149
#24 0x04790afa in QObject::~QObject (this=0x9b64ba0, __in_chrg=<value optimized out>) at kernel/qobject.cpp:842
#25 0x0681d66c in Solid::Control::AccessPoint::~AccessPoint (this=0x9b64ba0, __in_chrg=<value optimized out>) at ../../../../libs/solid/control/wirelessaccesspoint.cpp:72
#26 0x0681efae in Solid::Control::WirelessNetworkInterface::_k_accessPointRemoved (this=0x9b02110, uni=...) at ../../../../libs/solid/control/wirelessnetworkinterface.cpp:163
#27 0x0681f07d in Solid::Control::WirelessNetworkInterface::qt_metacall (this=0x9b02110, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0xbfca3798) at ./wirelessnetworkinterface.moc:116
#28 0x0477c8ca in QMetaObject::metacall (object=0x9b02110, cl=52817907, idx=14, argv=0xbfca3798) at kernel/qmetaobject.cpp:237
#29 0x0478f6ad in QMetaObject::activate (sender=0x9acdff8, m=0x830b614, local_signal_index=4, argv=0xffffc590) at kernel/qobject.cpp:3280
#30 0x082ef253 in NMWirelessNetworkInterface::accessPointDisappeared (this=0x9acdff8, _t1=...) at moc_wirelessnetworkinterface.cpp:140
#31 0x082fe725 in NMWirelessNetworkInterface::accessPointRemoved (this=0x9acdff8, apPath=...) at ../../../solid/networkmanager-0.7/wirelessnetworkinterface.cpp:188
#32 0x082ef44d in NMWirelessNetworkInterface::qt_metacall (this=0x9acdff8, _c=QMetaObject::InvokeMetaMethod, _id=15, _a=0xbfca3938) at moc_wirelessnetworkinterface.cpp:100
#33 0x0477c8ca in QMetaObject::metacall (object=0x9acdff8, cl=52817907, idx=15, argv=0xbfca3938) at kernel/qmetaobject.cpp:237
#34 0x0478f6ad in QMetaObject::activate (sender=0x9ad1b18, m=0x830cc04, local_signal_index=1, argv=0xffffc590) at kernel/qobject.cpp:3280
#35 0x08304e93 in OrgFreedesktopNetworkManagerDeviceWirelessInterface::AccessPointRemoved (this=0x9ad1b18, _t1=...) at ./nm-device-wifiinterface.moc:141
#36 0x08305205 in OrgFreedesktopNetworkManagerDeviceWirelessInterface::qt_metacall (this=0x9ad1b18, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbfca3b0c) at ./nm-device-wifiinterface.moc:92
#37 0x00cae9dc in QDBusConnectionPrivate::deliverCall (this=0x984e308, object=0x9ad1b18, msg=..., metaTypes=..., slotIdx=6) at qdbusintegrator.cpp:919
#38 0x00cba1f7 in QDBusCallDeliveryEvent::placeMetaCall (this=0xa011e68, object=0x9ad1b18) at qdbusintegrator_p.h:103
#39 0x047896a2 in QObject::event (this=0x9ad1b18, e=0xa0e7050) at kernel/qobject.cpp:1219
#40 0x052dffdc in QApplicationPrivate::notify_helper (this=0x97b0958, receiver=0x9ad1b18, e=0xa011e68) at kernel/qapplication.cpp:4396
#41 0x052e604e in QApplication::notify (this=0x97a5748, receiver=0x9ad1b18, e=0xa011e68) at kernel/qapplication.cpp:3798
#42 0x0111668a in KApplication::notify (this=0x97a5748, receiver=0x9ad1b18, event=0xa011e68) at ../../kdeui/kernel/kapplication.cpp:310
#43 0x04776b3b in QCoreApplication::notifyInternal (this=0x97a5748, receiver=0x9ad1b18, event=0xa011e68) at kernel/qcoreapplication.cpp:732
#44 0x04779d8b in sendEvent (receiver=0x0, event_type=0, data=0x978f028) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#45 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x978f028) at kernel/qcoreapplication.cpp:1373
#46 0x04779f4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#47 0x047a5a74 in sendPostedEvents (s=0x97b2d10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#48 postEventSourceDispatch (s=0x97b2d10) at kernel/qeventdispatcher_glib.cpp:277
#49 0x02b72855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#50 0x02b76668 in ?? () from /lib/libglib-2.0.so.0
#51 0x02b76848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#52 0x047a5565 in QEventDispatcherGlib::processEvents (this=0x978ece8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#53 0x053a1be5 in QGuiEventDispatcherGlib::processEvents (this=0x978ece8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#54 0x04775609 in QEventLoop::processEvents (this=0xbfca4330, flags=) at kernel/qeventloop.cpp:149
#55 0x04775a8a in QEventLoop::exec (this=0xbfca4330, flags=...) at kernel/qeventloop.cpp:201
#56 0x057a8efe in QMenu::exec (this=0xbfca4388, p=..., action=0x0) at widgets/qmenu.cpp:2054
#57 0x001d13c8 in Plasma::ContainmentPrivate::showContextMenu (this=0x9a80da8, point=..., screenPos=..., includeApplet=true, isMouseEvent=true) at ../../plasma/containment.cpp:806
#58 0x001d15ba in Plasma::Containment::contextMenuEvent (this=0x9ad8830, event=0xbfca4a9c) at ../../plasma/containment.cpp:643
#59 0x059921b8 in QGraphicsItem::sceneEvent (this=0x9ad8838, event=0xbfca4a9c) at graphicsview/qgraphicsitem.cpp:6639
#60 0x059e94d7 in QGraphicsWidget::sceneEvent (this=0x9ad8830, event=0xbfca4a9c) at graphicsview/qgraphicswidget.cpp:1173
#61 0x059aa569 in QGraphicsScenePrivate::sendEvent (this=0x98595b8, item=0x9ad8838, event=0xbfca4a9c) at graphicsview/qgraphicsscene.cpp:1211
#62 0x059af1b8 in QGraphicsScene::contextMenuEvent (this=0x985af80, contextMenuEvent=0xbfca4a9c) at graphicsview/qgraphicsscene.cpp:3600
#63 0x059c54cc in QGraphicsScene::event (this=0x985af80, event=0xbfca4a9c) at graphicsview/qgraphicsscene.cpp:3398
#64 0x052dffdc in QApplicationPrivate::notify_helper (this=0x97b0958, receiver=0x985af80, e=0xbfca4a9c) at kernel/qapplication.cpp:4396
#65 0x052e604e in QApplication::notify (this=0x97a5748, receiver=0x985af80, e=0xbfca4a9c) at kernel/qapplication.cpp:3798
#66 0x0111668a in KApplication::notify (this=0x97a5748, receiver=0x985af80, event=0xbfca4a9c) at ../../kdeui/kernel/kapplication.cpp:310
#67 0x04776b3b in QCoreApplication::notifyInternal (this=0x97a5748, receiver=0x985af80, event=0xbfca4a9c) at kernel/qcoreapplication.cpp:732
#68 0x059e19f0 in sendEvent (this=0x9cecce8, event=0xbfca51f8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#69 QGraphicsView::contextMenuEvent (this=0x9cecce8, event=0xbfca51f8) at graphicsview/qgraphicsview.cpp:2888
#70 0x0533e528 in QWidget::event (this=0x9cecce8, event=0xbfca51f8) at kernel/qwidget.cpp:8354
#71 0x0575f763 in QFrame::event (this=0x9cecce8, e=0xbfca51f8) at widgets/qframe.cpp:557
#72 0x057fca82 in QAbstractScrollArea::viewportEvent (this=0x325eff3, e=0xa0e7050) at widgets/qabstractscrollarea.cpp:1043
#73 0x059e0ccb in QGraphicsView::viewportEvent (this=0x9cecce8, event=0xbfca51f8) at graphicsview/qgraphicsview.cpp:2862
#74 0x057ff4d5 in viewportEvent (this=0x9b4a2e8, o=0x9ce3368, e=0xbfca51f8) at widgets/qabstractscrollarea_p.h:100
#75 QAbstractScrollAreaFilter::eventFilter (this=0x9b4a2e8, o=0x9ce3368, e=0xbfca51f8) at widgets/qabstractscrollarea_p.h:116
#76 0x0477629a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x97b0958, receiver=0x9ce3368, event=0xbfca51f8) at kernel/qcoreapplication.cpp:847
#77 0x052dffb9 in QApplicationPrivate::notify_helper (this=0x97b0958, receiver=0x9ce3368, e=0xbfca51f8) at kernel/qapplication.cpp:4392
#78 0x052e6458 in QApplication::notify (this=0x97a5748, receiver=0x9ce3368, e=0xbfca51f8) at kernel/qapplication.cpp:4038
#79 0x0111668a in KApplication::notify (this=0x97a5748, receiver=0x9ce3368, event=0xbfca51f8) at ../../kdeui/kernel/kapplication.cpp:310
#80 0x04776b3b in QCoreApplication::notifyInternal (this=0x97a5748, receiver=0x9ce3368, event=0xbfca51f8) at kernel/qcoreapplication.cpp:732
#81 0x0537862e in QCoreApplication::sendSpontaneousEvent (receiver=0x9ce3368, event=0xa0e7050) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#82 0x05373d7c in QETWidget::translateMouseEvent (this=0x9cecce8, event=0xbfca56ec) at kernel/qapplication_x11.cpp:4408
#83 0x05373151 in QApplication::x11ProcessEvent (this=0x97a5748, event=0xbfca56ec) at kernel/qapplication_x11.cpp:3414
#84 0x053a236a in x11EventSourceDispatch (s=0x97b3ba8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#85 0x02b72855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#86 0x02b76668 in ?? () from /lib/libglib-2.0.so.0
#87 0x02b76848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#88 0x047a5565 in QEventDispatcherGlib::processEvents (this=0x978ece8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#89 0x053a1be5 in QGuiEventDispatcherGlib::processEvents (this=0x978ece8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#90 0x04775609 in QEventLoop::processEvents (this=0xbfca59e4, flags=) at kernel/qeventloop.cpp:149
#91 0x04775a8a in QEventLoop::exec (this=0xbfca59e4, flags=...) at kernel/qeventloop.cpp:201
#92 0x0477a00f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#93 0x052dee07 in QApplication::exec () at kernel/qapplication.cpp:3672
#94 0x008db86e in kdemain (argc=1, argv=0xbfca5bf4) at ../../../../plasma/desktop/shell/main.cpp:118
#95 0x080485bb in main (argc=1, argv=0xbfca5bf4) at plasma-desktop_dummy.cpp:3

Reported using DrKonqi
Comment 1 Dario Andres 2011-03-07 22:35:35 UTC
[Comment from a bug triager]
As bug 263506, this issue is being tracked at bug 240285.
Merging. Thanks

*** This bug has been marked as a duplicate of bug 240285 ***