Bug 266907 - Regression in 2.4.0 overwrites playlists
Summary: Regression in 2.4.0 overwrites playlists
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Playlists/Saved Playlists (show other bugs)
Version: 2.4.0
Platform: Gentoo Packages Linux
: NOR major (vote)
Target Milestone: 2.4.1
Assignee: Amarok Developers
URL:
Keywords:
: 268361 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-02-22 19:13 UTC by Martux
Modified: 2011-03-22 07:54 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.4.1


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martux 2011-02-22 19:13:21 UTC
Version:           2.4.0 (using KDE 4.6.0) 
OS:                Linux

When drag'n'drop a song to a saved playlist, this playlist gets deleted and overwritten with the newly added content instead of the new track just added.

Reproducible: Always

Steps to Reproduce:
1. set context menu to "saved playlists"
2. drag'n'drop another song from the playlist.
3. load previous saved playlist and see all entries except the new ones deleted

Actual Results:  
playlist broken badly

Expected Results:  
song just added at the bottom of saved playlist.
Note: This doesnt occur anymore if downgraded to 2.3.2, 2.4.0 only

OS: Linux (x86_64) release 2.6.37-gentoo
Compiler: x86_64-pc-linux-gnu-gcc

I already tried with a complete collection rescan, deleting all amarok-directories and even with a complete new kde session.
Comment 1 Martux 2011-03-04 22:49:16 UTC
Is anyone even taking notice of this? Confirms? This is a truly showstopper and renders Amarok unusable :(
Comment 2 Bart Cerneels 2011-03-09 09:54:52 UTC
Git commit 378fce0a23fcea0f5ccab615f22a1fb1154a222d by Bart Cerneels.
Committed on 09/03/2011 at 09:52.
Pushed by shanachie into branch 'master'.

Don't overwrite playlist tracks.

When a playlist was not lazy loaded yet it would be possible to overwrite the tracklist.
BUG:266907

M  +10   -2    src/playlistmanager/sql/SqlPlaylist.cpp     

http://commits.kde.org/amarok/378fce0a23fcea0f5ccab615f22a1fb1154a222d
Comment 3 Bart Cerneels 2011-03-09 11:07:54 UTC
Git commit dfe6d15f1e79cd5deb57401d053de06b5308a8ea by Bart Cerneels.
Committed on 09/03/2011 at 10:51.
Pushed by shanachie into branch 'master'.

Make sure track list is not overwritten.

CCBUG:266907

M  +3    -0    src/core-impl/playlists/types/file/xspf/XSPFPlaylist.cpp     

http://commits.kde.org/amarok/dfe6d15f1e79cd5deb57401d053de06b5308a8ea
Comment 4 Martux 2011-03-09 18:31:04 UTC
Wow, you fixed this? Great!! Cannot wait until 2.4.1 gets stable.
Comment 5 Bart Cerneels 2011-03-22 07:54:14 UTC
*** Bug 268361 has been marked as a duplicate of this bug. ***