Bug 266682 - Album view use artist album and not artist
Summary: Album view use artist album and not artist
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Context View/Albums (show other bugs)
Version: 2.5-git
Platform: Compiled Sources Linux
: NOR minor (vote)
Target Milestone: 2.4.1
Assignee: Amarok Developers
URL:
Keywords:
: 271168 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-02-19 19:26 UTC by Stéphane Pontier
Modified: 2011-11-06 09:13 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.5


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stéphane Pontier 2011-02-19 19:26:53 UTC
Version:           2.4-GIT (using KDE 4.6.0) 
OS:                Linux

I don't know if it is a bug or a new behavior induced by all the album artist/compilation change but here is my concern:
I have three album:
 - "Cowboy Bebop" soundrack, no album artist in tag, some file without artist and some tagged sung by "Emily Bindiger". it is viewed as various artist by Amarok
 - "Fiction", album artist: 梶浦由記 (who composed all track), some song of the album are sung by her band, some by "Emily Bindiger", it is viewed by Amarok as a 梶浦由記 album which is correct.

If I play an "Emily Bindiger" song from the Fiction album on Amarok 2.4.0, the album view show me:
Album of Emily Bidinger
 Fiction
  - *Current song* (bold)
  - other songs by Emily Bidinger
  - other songs by other artist
 Cowboy Bebop
  - songs by other artists
  - /Emily Bidinger - songs by Emily Bidinger/ (italic)

If I play an "Emily Bindiger" song from the Cowbow bebop album on Amarok 2.4.0, the album view show me:
Album of Emily Bindiger
 Fiction
  - other songs
 Cowboy Bebop
  - */Emily Bidinger - current song/* (bold and italic)
  - /Emily Bidinger - other songs by Emily Bidinger/ (italic)
  - songs by other artists

If I play an "Emily Bindiger" song from the Fiction album on Amarok GIT, the album view show me:
Album of 梶浦由記
 Fiction
  - *Current song* (bold)
  - other songs

If I play an "Emily Bindiger" song from the Cowbow bebop album on Amarok GIT, the album view show me an empty applet:
Album of Emily Bindiger
 

The Git version is maybe more acurate as showing only "album of album artist" regardless of the singer, but I was mor expecting the old behavior which was showing, "album in which artist has sung something regardless of the album artist". If the new behavior is the one wanted  by Amarok dev, is it possible to have a configuration option (or another applet) to get the result from 2.4.0?




Reproducible: Always
Comment 1 Stéphane Pontier 2011-03-20 12:24:14 UTC
With the latest beta, the behaviour changed, to what it was, when playing the track of an artist on a various artist album (without 'album artist' tag) ie:
------
If I play an "Emily Bindiger" song from the Cowbow bebop album on Amarok 2.4.0 (and now 2.4.1 beta1),
the album view show me:
Album of Emily Bindiger
 Fiction
  - other songs
 Cowboy Bebop
  - */Emily Bidinger - current song/* (bold and italic)
  - /Emily Bidinger - other songs by Emily Bidinger/ (italic)
  - songs by other artists
----

for the other case (playing track from an artist on a album where 'album artist' is credited to another one), it still remains as described previously.
Comment 2 Myriam Schweingruber 2011-04-19 14:35:57 UTC
*** Bug 271168 has been marked as a duplicate of this bug. ***
Comment 3 Myriam Schweingruber 2011-04-19 14:36:24 UTC
Confirmed by duplicate
Comment 4 Myriam Schweingruber 2011-06-04 12:22:38 UTC
This is an automated message from the triager:

Amarok 2.4.1 has been released on May 8 already. Could you please upgrade and test if you can still reproduce this bug?

Without feedback within a month we will close this bug as resolved.

Thank you for your understanding.
Comment 5 goerpr 2011-06-05 09:34:12 UTC
I can confirm "Bug 271168" in Amarok 2.4.1

Thanks and keep up the great work
Comment 6 Myriam Schweingruber 2011-06-05 11:45:26 UTC
Thank you for the fast feedback :)
Comment 7 goerpr 2011-11-01 15:10:01 UTC
Hi there,

is someone fixing this issue? At least for me the severity is not "minor". This issue is very annoying.

Thanks
Ralf
Comment 8 Myriam Schweingruber 2011-11-02 09:27:20 UTC
Is this still an issue with the latest git branch?
Comment 9 goerpr 2011-11-02 21:11:10 UTC
I will check at the next weekend ...

Thanks
Ralf
Comment 10 goerpr 2011-11-05 10:00:49 UTC
same issue with compiled git from 4th Nov ...
Comment 11 Myriam Schweingruber 2011-11-05 12:16:47 UTC
Thank you for the feedback.
Comment 12 Sergey Ivanov 2011-11-05 21:54:21 UTC
Git commit b634fb65b09a8ca35ed66e764b0badf2625754ab by Sergey Ivanov.
Committed on 05/11/2011 at 21:15.
Pushed by ivanov into branch 'master'.

Prefer track artist to album artist in Albums applet fiter.
BUG: 266682
FIXED-IN: 2.5

M  +1    -0    ChangeLog
M  +5    -2    src/context/engines/current/CurrentEngine.cpp

http://commits.kde.org/amarok/b634fb65b09a8ca35ed66e764b0badf2625754ab
Comment 13 goerpr 2011-11-06 09:13:43 UTC
I've compiled git and --- fixed.

Thanks and keep up the great work
Ralf