Bug 266395 - Batch cropping for digikam (cropping made easy)
Summary: Batch cropping for digikam (cropping made easy)
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Plugin-Bqm-Crop (show other bugs)
Version: 1.4.0
Platform: Ubuntu Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-15 19:48 UTC by prot.protagonista
Modified: 2016-07-04 08:06 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 3.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description prot.protagonista 2011-02-15 19:48:46 UTC
Version:           1.4.0 (using KDE 4.5.1) 
OS:                Linux

Hi,

my problem is, that I have a lot of scanned images and most of them need cropping in order to save space on the page (some of them are printed later). I use digikam to manage my images and I love the batch processor, but it doesent support batch cropping. It would be very helpful to make it an easy process. Juts like in gwenview (select the area with a rectangle) but this time in digikam.

I'm not a programmer (if I were, I'd produced a patch already ;) ) but maybe its possible to borrow some code from gwenview to do it faster and with more code reuse? Maybe go further: give the user a way to check if the selected area is ok for all of the images before doing any changes?

It would be a life saver for all hard working students collecting scanned documents for their papers :)

Thanks in advance!

Reproducible: Didn't try
Comment 1 caulier.gilles 2012-12-21 10:27:23 UTC
The question of Batch crop processing is recurrent in bugzilla.

It's possible to make easily a tool to crop an image. But the problem is how to provide a way to see the crop result. BQM is not image editor, and do not include preview (and it's not planed to do it). Don't forget that BQM apply change to multiple items, which can have different size...

So to setup crop properties, only region crop information can be hosted tin tool settings, without to have any visual feedback of the crop.

This is why, i think a crop tool in BQM is not very suitable as well... But it's my viewpoint...

Gilles Caulier
Comment 2 caulier.gilles 2012-12-28 23:14:29 UTC
Git commit 43e6ca4895a1ff6f2b8f98668635a6a64c2a0741 by Gilles Caulier.
Committed on 29/12/2012 at 00:13.
Pushed by cgilles into branch 'master'.

new Batch Queue Manager to crop image.

M  +1    -0    utilities/queuemanager/CMakeLists.txt
A  +208  -0    utilities/queuemanager/basetools/transform/crop.cpp     [License: GPL (v2+)]
A  +66   -0    utilities/queuemanager/basetools/transform/crop.h     [License: GPL (v2+)]
M  +2    -0    utilities/queuemanager/manager/batchtoolsmanager.cpp

http://commits.kde.org/digikam/43e6ca4895a1ff6f2b8f98668635a6a64c2a0741
Comment 3 prot.protagonista 2013-01-03 22:36:50 UTC
So, it's working now? Awesome, really! This will save me lots of hassle and drive space. Thank you so much!