Bug 266387 - ark can not open rar archives with encrypted headers
Summary: ark can not open rar archives with encrypted headers
Status: RESOLVED DUPLICATE of bug 35371
Alias: None
Product: ark
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Raphael Kubo da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-15 17:40 UTC by magist3r
Modified: 2011-02-15 17:49 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description magist3r 2011-02-15 17:40:14 UTC
Version:           unspecified (using KDE 4.6.0) 
OS:                Linux

Subj. I did "strace ark somerararchive.rar" and got this:
poll([{fd=7, events=POLLIN|POLLOUT}], 1, -1) = 1 ([{fd=7, revents=POLLOUT}])
writev(7, [{"&\0\2\0\214\1\0\0", 8}, {NULL, 0}, {"", 0}], 3) = 8
poll([{fd=7, events=POLLIN}], 1, -1)    = 1 ([{fd=7, revents=POLLIN}])
read(7, "\1\1\24\251\0\0\0\0\214\1\0\0z\20\306\1u\2\10\0u\2\10\0\20\0\0\0\0\0\0\0", 4096) = 32
read(7, 0x8085b90, 4096)                = -1 EAGAIN (Resource temporarily unavailable)
read(7, 0x8085b90, 4096)                = -1 EAGAIN (Resource temporarily unavailable)
read(7, 0x8085b90, 4096)                = -1 EAGAIN (Resource temporarily unavailable)

This part repeats many times. 
P.S. Krusader opens this archive and asks password normally.

Reproducible: Always
Comment 1 Raphael Kubo da Costa 2011-02-15 17:49:03 UTC
Most of it should be fixed in 4.7.0 -- if I manage to finish the pending work, the fix should also show up in 4.6.1 or 4.6.2.

*** This bug has been marked as a duplicate of bug 35371 ***