Bug 266200 - No language dictionaries for the language : "pl"
Summary: No language dictionaries for the language : "pl"
Status: RESOLVED DUPLICATE of bug 256896
Alias: None
Product: lokalize
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Nick Shaforostoff
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-13 13:54 UTC by Julian Sikorski
Modified: 2011-03-01 15:53 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Julian Sikorski 2011-02-13 13:54:46 UTC
Version:           unspecified (using KDE 4.5.5) 
OS:                Linux

The summary says quite a lot: I have hunspell-pl and aspell-pl installed, but lokalize still is not happy. Installing enchant-aspell is a workaround, but that dictionary has not been updated in ages. Please fix.

Reproducible: Didn't try

Steps to Reproduce:
1. Install kdesdk and hunspell-pl
2. Switch the locale to Polish
3. Launch lokalize

Actual Results:  
Program fails to load the dictionary

Expected Results:  
Dictionary loads

Full conslole output:
$ lokalize
278 
279 
280 
lokalize(19933): No language dictionaries for the language :  "pl" 

lokalize(19933): No language dictionaries for the language :  "pl" 

lokalize(19933) LokalizeMainWindow::setupActions: finished 135 
lokalize(19933) main: showing LokalizeMainWindow 
lokalize(19933) main: LokalizeMainWindow shown 
lokalize(19933)/lokalize (TM) TM::DBFilesModel::DBFilesModel: initial row count 1 
lokalize(19933): No language dictionaries for the language :  "pl" 

lokalize(19933): No language dictionaries for the language :  "pl" 

lokalize(19933) Catalog::loadFromUrl: file opened in 1845 
autoSave QObject(0x0)  
lokalize(19933): No language dictionaries for the language :  "pl" 

Enchant dict for "en_US" 0x1ae9440 
lokalize(19933): No language dictionaries for the language :  "pl" 

lokalize(19933): No language dictionaries for the language :  "pl" 

lokalize(19933)/kdeui (kdelibs): Attempt to use QAction "showmsgiddiff_action" with KXMLGUIFactory! 
lokalize(19933)/kdeui (kdelibs): Attempt to use QAction "showmergeview_action" with KXMLGUIFactory! 
lokalize(19933)/kdeui (kdelibs): Attempt to use QAction "showmergeviewsecondary_action" with KXMLGUIFactory! 
lokalize(19933)/kdeui (kdelibs): Attempt to use QAction "showcatalogtreeview_action" with KXMLGUIFactory! 
lokalize(19933)/kdeui (kdelibs): Attempt to use QAction "showmsgctxt_action" with KXMLGUIFactory! 
lokalize(19933)/kdeui (kdelibs): Attempt to use QAction "showtmqueryview_action" with KXMLGUIFactory! 
lokalize(19933)/kdeui (kdelibs): Attempt to use QAction "showglossaryview_action" with KXMLGUIFactory! 
lokalize(19933)/kdeui (kdelibs): Attempt to use QAction "showbinunitsview_action" with KXMLGUIFactory! 
lokalize(19933): No language dictionaries for the language :  "pl" 

lokalize(19933): No language dictionaries for the language :  "pl" 

lokalize(19933)/lokalize (TM) TM::OpenDBJob::run: db "default"  opened  2936 "pl" 
lokalize(19933) Catalog::loadFromUrl: file opened in 56 
autoSave QObject(0x0)  
lokalize(19933): No language dictionaries for the language :  "pl" 

Enchant dict for "en_US" 0x1ae9440 
lokalize(19933): No language dictionaries for the language :  "pl" 

lokalize(19933): No language dictionaries for the language :  "pl" 

lokalize(19933)/kdeui (kdelibs): Attempt to use QAction "showmsgiddiff_action" with KXMLGUIFactory! 
lokalize(19933)/kdeui (kdelibs): Attempt to use QAction "showmergeview_action" with KXMLGUIFactory! 
lokalize(19933)/kdeui (kdelibs): Attempt to use QAction "showmergeviewsecondary_action" with KXMLGUIFactory! 
lokalize(19933)/kdeui (kdelibs): Attempt to use QAction "showcatalogtreeview_action" with KXMLGUIFactory! 
lokalize(19933)/kdeui (kdelibs): Attempt to use QAction "showmsgctxt_action" with KXMLGUIFactory! 
lokalize(19933)/kdeui (kdelibs): Attempt to use QAction "showtmqueryview_action" with KXMLGUIFactory! 
lokalize(19933)/kdeui (kdelibs): Attempt to use QAction "showglossaryview_action" with KXMLGUIFactory! 
lokalize(19933)/kdeui (kdelibs): Attempt to use QAction "showbinunitsview_action" with KXMLGUIFactory! 
lokalize(19933)/lokalize (TM) TM::OpenDBJob::run: db "default"  opened  0 "pl" 
loadProjectScripts() 1111 "/" 
loadProjectScripts() 333 
lokalize(19933) ProjectScriptingPlugin::~ProjectScriptingPlugin: () 
loadProjectScripts() 444 
loadProjectScripts() 555 
loadProjectScripts() 666 
lokalize(19933) ProjectScriptingPlugin::~ProjectScriptingPlugin: () 
QCoreApplication::processEvents()... 
Finishing Project jobs... 
Finishing TM jobs... 

** (<unknown>:19933): WARNING **: 1 dictionaries weren't free'd.
Comment 1 Kevin Kofler 2011-02-13 14:07:27 UTC
The hunspell dictionary is called pl_PL, not just pl.

See also 171432, which is about Parley being broken the same way.
Comment 2 Kevin Kofler 2011-02-13 14:08:08 UTC
(I mean: see also bug 171432.)
Comment 3 Kevin Kofler 2011-03-01 15:47:29 UTC

*** This bug has been marked as a duplicate of bug 256896 ***