Bug 266031 - wallet error when starting Kontact
Summary: wallet error when starting Kontact
Status: RESOLVED WORKSFORME
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR normal with 104 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 267038 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-02-10 22:54 UTC by Will Stephenson
Modified: 2011-10-19 15:20 UTC (History)
22 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Will Stephenson 2011-02-10 22:54:17 UTC
Version:           unspecified (using KDE 4.6.0) 
OS:                Linux

When Kontact is started, I get the warning message from kwalletd that: 

There have been repeated failed attempts to gain access to a wallet. An application may be misbehaving.

Am troubleshooting.


Reproducible: Always
Comment 1 Will Stephenson 2011-02-10 23:16:05 UTC
The bug manifests when only the kmail plugin is enabled (no summaries), with a single onlineimap account, and when Akonadi is not running when Kontact is started.
Comment 2 Will Stephenson 2011-02-10 23:18:16 UTC
The bug does not manifest when starting kmail standalone under the same conditions.
Comment 3 Christophe Giboudeaux 2011-02-24 09:58:09 UTC
*** Bug 267038 has been marked as a duplicate of this bug. ***
Comment 4 S. Burmeister 2011-02-24 19:15:12 UTC
I have two IMAP-accounts, so this is not bound to a single online imap account.
Comment 5 Nico Kruber 2011-02-27 19:08:09 UTC
this error does not show if I start akonadi before Kontact instead of the other way around (Kontact will start akonadi).

Akonadi start triggers a Kontact start anyway since I use groupware folders on an IMAP account.
Comment 6 Alex 2011-03-05 15:57:41 UTC
I get the same error since KDE 4.6.1. I have an IMAP account, a Disconnected IMAP account (with groupware folders) and a POP3 account. Only the IMAP account seems to be affected. KMail is able to get the passwords for the POP3 and the Disconnected-IMAP account without problems.
Comment 7 Alessandro Rossini 2011-03-12 20:19:33 UTC
I can confirm the bug.

Version:           4.4.9 (using KDE 4.6.1)
OS:                GNU/Linux
Installed from:    Ubuntu Packages

Best regards.
Comment 8 Leon Maurer 2011-03-16 14:50:37 UTC
I've been running in to this bug too, although it only started up recently. This may just be a coincidence, but I first encountered the bug after I upgraded google chrome to version 10.0.648.127, and (I believe) chrome started using kwallet to store passwords (I know the option to do that existed for some time, but I hadn't used it and I think that version enabled it by default -- although perhaps it was enabled earlier and I just didn't notice).
Comment 9 Stephan Diestelhorst 2011-03-18 19:43:46 UTC
I can confirm, too. However, this is very strange. The first time I start KMail, it warns that Akonadi has errors ("Duplicated agent identifier" issue), and then exits if I close the Akonadi test window. However, during this first start, Kmail seems to properly open the wallet.

Second time I start, KMail cannot find the data in the wallet.

This happened after upgrading 4.6.0 -> 4.6.1 for me, too.
This hence should be flagged as REGRESSION.
Comment 10 J Appel 2011-03-22 09:56:21 UTC
Since 4.6.1:
'There have been repeated failed attempts to gain access to a wallet. An
application may be misbehaving.'

When starting kontact for the first time, or kmail. It doesnt matter if I start kmail as standalone for me.

After killing kontact and restarting it, kwallet is available. My installation does not sport any IMAP accounts, pop & smtp only.
Comment 11 S. Bryant 2011-03-22 21:41:41 UTC
I can also confirm this bug: OpenSUSE 11.3 (x64).  Bug appeared with KDE SC 4.6.1 (from OpenSUSE repositories).

Having KWallet triggered (and authenticated) via a different application such as Konqueror does not help.  The "repeated failed attempts" message appears on the first start of Kontact.  I have multiple POP3 email accounts, and 1 DIMAP with groupware folders.

Steve
Comment 12 S. Bryant 2011-03-22 21:46:19 UTC
One more thing: disabling 'Check mail on startup' for the email accounts seems to alleviate the problem.
:-)
Comment 13 t68b 2011-04-21 04:26:42 UTC
(In reply to comment #12)
> One more thing: disabling 'Check mail on startup' for the email accounts seems
> to alleviate the problem.
> :-)

fyi, I'm still seeing this behavior, _after_ disabling 'Check mail on startup'.

with,

 kdebase4-runtime-4.6.2-3.1.x86_64
 kontact-4.4.10-2.1.x86_64
 kmail-4.4.10-2.1.x86_64
Comment 14 Jaroslav Reznik 2011-04-22 10:18:12 UTC
Confirmed, happens for me too and reported by several Fedora users. It's quite annoying bug, can someone take a closer look?  

kdebase-runtime 4.6.2 with kdepim 4.4.10
Comment 15 t68b 2011-04-27 22:34:38 UTC
just doc'ing.

it had been mentioned to me by the OP in #irc that 4.4.11 _might_ address this issue.

atm, with:

 libkdepimlibs4-4.6.2-3.1.x86_64
 kdepim4-4.4.11.1-3.1.x86_64
 libkdepim4-4.4.11.1-3.1.x86_64
 kdepimlibs4-4.6.2-3.1.x86_64
 kdepim4-runtime-4.4.11.1-3.1.x86_64
 kdepim4-wizards-4.4.11.1-3.1.x86_64

i'm still seeing these messages.
Comment 16 info 2011-05-08 19:31:46 UTC
I can confirm this too on Archlinux (i686) with KDE 4.6.3:

kdepim-kmail 4.4.11.1-1
kdepim-korganizer 4.4.11.1-1
kdepim-libkdepim 4.4.11.1-1
kdepimlibs 4.6.3-1
kdepim-runtime 4.4.11.1-1

I get this message mostly on the second account i created. The first email account is using kwallet.

Sorry for my bad english.
Comment 17 jos poortvliet 2011-06-21 09:50:40 UTC
I'm unfortunately also suffering from this, KDE & KDE PIM 4.6.4 "release 8" (latest as of today in openSUSE's KDE repositories for oS 11.4). Unfortunately, while KMail asks on startup to migrate my password for my disconnected IMAP gmail account to KWallet, it doesn't actually seem to work. kquitapp kmail, restarting akonadi, turning off 'check mail on startup', cleaning up KWallet of all KMail related data - none of it seems to work. I have to enter my details AND tell KMail to store (or not) the password (which it doesn't) each mail I send.

Until last week, KMail would *sometimes* manage to do the migration and work properly after re-starting it after bootup. Now it simply consistently fails :(

It's quite an issue with the 50-100 mails a day I have to send and I would really appreciate a fix. I know this might not be high on the agenda but I'm a bit afraid to try out KMail2, last time I did performance was really not usable on my system and with my amount of mail :(
Comment 18 Elias Probst 2011-06-25 05:15:51 UTC
Happens here, too.

KDE SC 4.6.4
KDE PIM 4.6.0

This message is only shown when having Akonadi + Kontact (incl. KMail) running when suspending the laptop.
After resuming, Kontact shows this message: "There have been repeated failed attempts to gain access to a wallet. An application may be misbehaving."

I have 2 IMAP accounts in KMail.
Comment 19 Joseph Reagle 2011-08-01 13:30:57 UTC
This is a duplicate of https://bugs.kde.org/show_bug.cgi?id=261559
Comment 20 Christophe Giboudeaux 2011-09-30 13:42:39 UTC
Mmh, no new comment since 4.7. Did anyone experience this issue with KDE|kdepim >=4.7.1 ?
Comment 21 Elias Probst 2011-09-30 18:19:29 UTC
Didn't happen a single time on 4.7.1, so I'd assume it is fixed.
Comment 22 Christophe Giboudeaux 2011-10-12 15:50:34 UTC
Will ? can we close ?
Comment 23 Christophe Giboudeaux 2011-10-19 15:20:03 UTC
No feedback, closing.