Bug 266005 - Brightness up key does not work in 4.6
Summary: Brightness up key does not work in 4.6
Status: RESOLVED DUPLICATE of bug 264534
Alias: None
Product: solid
Classification: Frameworks and Libraries
Component: powermanagement-daemon (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Dario Freddi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-10 18:34 UTC by Jonathan Challinger
Modified: 2011-02-10 20:19 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Challinger 2011-02-10 18:34:46 UTC
Version:           4.6 (using KDE 4.6.0) 
OS:                Linux

My netbook's brightness down key works, brightness up doesn't.
The keys are bound correctly and I can reverse them and I have the same problem, so it's not a key issue.
I can adjust the brightness back up using the slider in the battery applet, so it's not a hardware issue.
I've tried making a new home directory, and it did not solve the problem.

Reproducible: Didn't try




I'm using kubuntu 10.10 with kubuntu-ppa backports for kde 4.6. Problem was not present before the updates.
Comment 1 Jonathan Challinger 2011-02-10 20:09:38 UTC
I now know exactly why this issue exists.
Happens only when there are too few brightness levels available, for example, if your screen has 8 brightness levels (/sys/class/backlight/whatever/max_brightness = 7) as mine did, your brightness up key will not work.

--

For Samsung netbook (NF310) users with samsung-backlight:
Add "options samsung_backlight use_sabi=0 force=1 levels=100" to /etc/modprobe.d/modprobe.conf (create file if necessary)
Comment 2 Christoph Feck 2011-02-10 20:15:08 UTC
This is probably a duplicate of bug 264534.
Comment 3 Jonathan Challinger 2011-02-10 20:19:29 UTC

*** This bug has been marked as a duplicate of bug 264534 ***