Bug 265548 - Crash after installation completed
Summary: Crash after installation completed
Status: RESOLVED DUPLICATE of bug 259333
Alias: None
Product: kdelibs
Classification: Unclassified
Component: kdeui (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-05 20:44 UTC by Mirza
Modified: 2011-02-05 22:35 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mirza 2011-02-05 20:44:17 UTC
Application: muon-installer (1.1.0 "Bullish Bandril")
KDE Platform Version: 4.6.00 (4.6.0)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-26-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
Muon application crashed after installation was completed. This happens often but not every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb787b710 (LWP 12521))]

Thread 2 (Thread 0xb48c0b70 (LWP 12522)):
#0  0x0067fe36 in clock_gettime () from /lib/librt.so.1
#1  0x0559b50b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0x056726e5 in QTimerInfoList::updateCurrentTime (this=0x897832c) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0567272a in QTimerInfoList::timerWait (this=0x897832c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x056707a8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb48c00bc) at kernel/qeventdispatcher_glib.cpp:136
#6  0x0567083d in timerSourcePrepare (source=0x0, timeout=0x683ff4) at kernel/qeventdispatcher_glib.cpp:169
#7  0x07f47e6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0x07f48279 in ?? () from /lib/libglib-2.0.so.0
#9  0x07f48848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0x0567059f in QEventDispatcherGlib::processEvents (this=0x8845140, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0x05640609 in QEventLoop::processEvents (this=0xb48c0290, flags=) at kernel/qeventloop.cpp:149
#12 0x05640a8a in QEventLoop::exec (this=0xb48c0290, flags=...) at kernel/qeventloop.cpp:201
#13 0x0553cb7e in QThread::exec (this=0x89775a0) at thread/qthread.cpp:490
#14 0x0561f35b in QInotifyFileSystemWatcherEngine::run (this=0x89775a0) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x0553fdf9 in QThreadPrivate::start (arg=0x89775a0) at thread/qthread_unix.cpp:266
#16 0x00637cc9 in start_thread () from /lib/libpthread.so.0
#17 0x0299469e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb787b710 (LWP 12521)):
[KCrash Handler]
#7  0x00f5f073 in KExtendableItemDelegate::extenderRect (this=0x8e3f2c8, extender=0x8f4ca88, option=..., index=...) at ../../kdeui/itemviews/kextendableitemdelegate.cpp:313
#8  0x00f60ef0 in KExtendableItemDelegate::paint (this=0x8e3f2c8, painter=0xbfe0eb7c, option=..., index=...) at ../../kdeui/itemviews/kextendableitemdelegate.cpp:277
#9  0x0806cebe in ApplicationDelegate::paint (this=0x8e3f2c8, painter=0xbfe0eb7c, option=..., index=...) at /build/buildd/muon-1.1.0/installer/ApplicationModel/ApplicationDelegate.cpp:88
#10 0x0371cda0 in QTreeView::drawRow (this=0x92cb218, painter=0xbfe0eb7c, option=..., index=...) at itemviews/qtreeview.cpp:1678
#11 0x0372246a in QTreeView::drawTree (this=0x92cb218, painter=0xbfe0eb7c, region=...) at itemviews/qtreeview.cpp:1441
#12 0x0372520b in QTreeView::paintEvent (this=0x92cb218, event=0xbfe0f414) at itemviews/qtreeview.cpp:1274
#13 0x03162cc6 in QWidget::event (this=0x92cb218, event=0xbfe0f414) at kernel/qwidget.cpp:8333
#14 0x03584763 in QFrame::event (this=0x92cb218, e=0xbfe0f414) at widgets/qframe.cpp:557
#15 0x03621a82 in QAbstractScrollArea::viewportEvent (this=0xbfe0e0b8, e=0x9392730) at widgets/qabstractscrollarea.cpp:1043
#16 0x036de0f7 in QAbstractItemView::viewportEvent (this=0x92cb218, event=0xbfe0f414) at itemviews/qabstractitemview.cpp:1619
#17 0x03720883 in QTreeView::viewportEvent (this=0x92cb218, event=0xbfe0f414) at itemviews/qtreeview.cpp:1256
#18 0x036244d5 in viewportEvent (this=0x8d206b8, o=0x8ea40b0, e=0xbfe0f414) at widgets/qabstractscrollarea_p.h:100
#19 QAbstractScrollAreaFilter::eventFilter (this=0x8d206b8, o=0x8ea40b0, e=0xbfe0f414) at widgets/qabstractscrollarea_p.h:116
#20 0x0564129a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x87ba728, receiver=0x8ea40b0, event=0xbfe0f414) at kernel/qcoreapplication.cpp:847
#21 0x03104fb9 in QApplicationPrivate::notify_helper (this=0x87ba728, receiver=0x8ea40b0, e=0xbfe0f414) at kernel/qapplication.cpp:4392
#22 0x0310b0e9 in QApplication::notify (this=0xbfe11b04, receiver=0x8ea40b0, e=0xbfe0f414) at kernel/qapplication.cpp:4361
#23 0x00f95f7a in KApplication::notify (this=0xbfe11b04, receiver=0x8ea40b0, event=0xbfe0f414) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x05641b3b in QCoreApplication::notifyInternal (this=0xbfe11b04, receiver=0x8ea40b0, event=0xbfe0f414) at kernel/qcoreapplication.cpp:732
#25 0x03169ee6 in sendSpontaneousEvent (this=0x8bf3d20, pdev=0x885c6ec, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x885fd08) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#26 QWidgetPrivate::drawWidget (this=0x8bf3d20, pdev=0x885c6ec, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x885fd08) at kernel/qwidget.cpp:5420
#27 0x0316acff in QWidgetPrivate::paintSiblingsRecursive (this=0x88c4b80, pdev=0x885c6ec, siblings=..., index=6, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x885fd08) at kernel/qwidget.cpp:5627
#28 0x0316ab38 in QWidgetPrivate::paintSiblingsRecursive (this=0x88c4b80, pdev=0x885c6ec, siblings=..., index=7, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x885fd08) at kernel/qwidget.cpp:5614
#29 0x0316ab38 in QWidgetPrivate::paintSiblingsRecursive (this=0x88c4b80, pdev=0x885c6ec, siblings=..., index=8, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x885fd08) at kernel/qwidget.cpp:5614
#30 0x0316ab38 in QWidgetPrivate::paintSiblingsRecursive (this=0x88c4b80, pdev=0x885c6ec, siblings=..., index=9, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x885fd08) at kernel/qwidget.cpp:5614
#31 0x0316ab38 in QWidgetPrivate::paintSiblingsRecursive (this=0x88c4b80, pdev=0x885c6ec, siblings=..., index=10, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x885fd08) at kernel/qwidget.cpp:5614
#32 0x03169c35 in QWidgetPrivate::drawWidget (this=0x88c4b80, pdev=0x885c6ec, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x885fd08) at kernel/qwidget.cpp:5473
#33 0x0316acff in QWidgetPrivate::paintSiblingsRecursive (this=0x93982f0, pdev=0x885c6ec, siblings=..., index=3, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x885fd08) at kernel/qwidget.cpp:5627
#34 0x03169c35 in QWidgetPrivate::drawWidget (this=0x93982f0, pdev=0x885c6ec, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x885fd08) at kernel/qwidget.cpp:5473
#35 0x0316acff in QWidgetPrivate::paintSiblingsRecursive (this=0x8beb850, pdev=0x885c6ec, siblings=..., index=4, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x885fd08) at kernel/qwidget.cpp:5627
#36 0x03169c35 in QWidgetPrivate::drawWidget (this=0x8beb850, pdev=0x885c6ec, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x885fd08) at kernel/qwidget.cpp:5473
#37 0x0316acff in QWidgetPrivate::paintSiblingsRecursive (this=0x8bf4bb8, pdev=0x885c6ec, siblings=..., index=3, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x885fd08) at kernel/qwidget.cpp:5627
#38 0x03169c35 in QWidgetPrivate::drawWidget (this=0x8bf4bb8, pdev=0x885c6ec, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x885fd08) at kernel/qwidget.cpp:5473
#39 0x0316acff in QWidgetPrivate::paintSiblingsRecursive (this=0x8828c20, pdev=0x885c6ec, siblings=..., index=3, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x885fd08) at kernel/qwidget.cpp:5627
#40 0x03169c35 in QWidgetPrivate::drawWidget (this=0x8828c20, pdev=0x885c6ec, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x885fd08) at kernel/qwidget.cpp:5473
#41 0x0316acff in QWidgetPrivate::paintSiblingsRecursive (this=0x882f6a8, pdev=0x885c6ec, siblings=..., index=4, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x885fd08) at kernel/qwidget.cpp:5627
#42 0x03169c35 in QWidgetPrivate::drawWidget (this=0x882f6a8, pdev=0x885c6ec, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x885fd08) at kernel/qwidget.cpp:5473
#43 0x0316acff in QWidgetPrivate::paintSiblingsRecursive (this=0x882dc78, pdev=0x885c6ec, siblings=..., index=16, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x885fd08) at kernel/qwidget.cpp:5627
#44 0x03169c35 in QWidgetPrivate::drawWidget (this=0x882dc78, pdev=0x885c6ec, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x885fd08) at kernel/qwidget.cpp:5473
#45 0x0335ac74 in QWidgetBackingStore::sync (this=0x885fd08) at painting/qbackingstore.cpp:1328
#46 0x0315c2b3 in QWidgetPrivate::syncBackingStore (this=0x882dc78) at kernel/qwidget.cpp:1805
#47 0x03163466 in QWidget::event (this=0x87b18b0, event=0x88c4930) at kernel/qwidget.cpp:8480
#48 0x035a3917 in QMainWindow::event (this=0x87b18b0, event=0x88c4930) at widgets/qmainwindow.cpp:1417
#49 0x010829c4 in KMainWindow::event (this=0x87b18b0, ev=0x88c4930) at ../../kdeui/widgets/kmainwindow.cpp:1100
#50 0x010ce81f in KXmlGuiWindow::event (this=0x87b18b0, ev=0x88c4930) at ../../kdeui/xmlgui/kxmlguiwindow.cpp:126
#51 0x03104fdc in QApplicationPrivate::notify_helper (this=0x87ba728, receiver=0x87b18b0, e=0x88c4930) at kernel/qapplication.cpp:4396
#52 0x0310b0e9 in QApplication::notify (this=0xbfe11b04, receiver=0x87b18b0, e=0x88c4930) at kernel/qapplication.cpp:4361
#53 0x00f95f7a in KApplication::notify (this=0xbfe11b04, receiver=0x87b18b0, event=0x88c4930) at ../../kdeui/kernel/kapplication.cpp:311
#54 0x05641b3b in QCoreApplication::notifyInternal (this=0xbfe11b04, receiver=0x87b18b0, event=0x88c4930) at kernel/qcoreapplication.cpp:732
#55 0x05644d8b in sendEvent (receiver=0x0, event_type=0, data=0x879bd78) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#56 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x879bd78) at kernel/qcoreapplication.cpp:1373
#57 0x05644f4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#58 0x05670a74 in sendPostedEvents (s=0x87bf370) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#59 postEventSourceDispatch (s=0x87bf370) at kernel/qeventdispatcher_glib.cpp:277
#60 0x07f44855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#61 0x07f48668 in ?? () from /lib/libglib-2.0.so.0
#62 0x07f48848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#63 0x05670565 in QEventDispatcherGlib::processEvents (this=0x879b828, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#64 0x031c6be5 in QGuiEventDispatcherGlib::processEvents (this=0x879b828, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#65 0x05640609 in QEventLoop::processEvents (this=0xbfe11a64, flags=) at kernel/qeventloop.cpp:149
#66 0x05640a8a in QEventLoop::exec (this=0xbfe11a64, flags=...) at kernel/qeventloop.cpp:201
#67 0x0564500f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#68 0x03103e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#69 0x0805d809 in main (argc=5, argv=0xbfe11c34) at /build/buildd/muon-1.1.0/installer/main.cpp:60

This bug may be a duplicate of or related to bug 259333.

Possible duplicates by query: bug 259333.

Reported using DrKonqi
Comment 1 Pino Toscano 2011-02-05 22:35:37 UTC

*** This bug has been marked as a duplicate of bug 259333 ***