Bug 265540 - kate crashes on start (after killing kdeinit4)
Summary: kate crashes on start (after killing kdeinit4)
Status: RESOLVED FIXED
Alias: None
Product: kate
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
: 255705 279783 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-02-05 19:22 UTC by Marcel Partap
Modified: 2011-08-11 08:29 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel Partap 2011-02-05 19:22:48 UTC
Application: kate (3.6.41)
KDE Platform Version: 4.6.41 (4.7 >= 20110106) (Compiled from sources)
Qt Version: 4.7.2
Operating System: Linux 2.6.37-zen0-01983-g988ea18 x86_64
Distribution: "Gentoo Base System release 2.0.1-r1"

-- Information about the crash:
Stupid rogue kdeinit4 processes (f.e. if x server crashes, they all go on cpu frenzy...) ^^
Anyways, *i think* after killing them all (hehe) kate refuses to start, but it might have started before. Tracing reveiled that in KateDocManager::KateDocManager constructor, m_editor is (KTextEditor::Editor *) 0x0 because cg.readPathEntry("editor", QString()) in editor constructor returns NOTHING. Why - mystery. If it goes away after restarting X - well nice, but still. Resilience of this:
  // Constructed the beloved editor ;)
  m_editor = KTextEditor::EditorChooser::editor();
  m_editor->readConfig(KGlobal::config().data());
is a bit poor ^^

The crash can be reproduced every time.

-- Backtrace:
Application: Kate (kate), signal: Segmentation fault
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[KCrash Handler]
#6  0x00007f72f0dea8b4 in KateDocManager::KateDocManager (this=0x708fd0, parent=<value optimized out>) at /usr/src/debug/kde-base/kate-9999/kate-9999/kate/app/katedocmanager.cpp:73
#7  0x00007f72f0de4722 in KateApp::KateApp (this=0x7fff3c4d1730, args=<value optimized out>) at /usr/src/debug/kde-base/kate-9999/kate-9999/kate/app/kateapp.cpp:60
#8  0x00007f72f2541e26 in kdemain (argc=6456576, argv=0x7fff3c4d2c01) at /usr/src/debug/kde-base/kate-9999/kate-9999/kate/app/katemain.cpp:373
#9  0x00007f72f21eecdd in __libc_start_main (main=0x4008a0 <main(int, char**)>, argc=3, ubp_av=0x7fff3c4d2c68, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff3c4d2c58) at libc-start.c:226
#10 0x0000000000400789 in _start ()

Possible duplicates by query: bug 255705.

Reported using DrKonqi
Comment 1 Christoph Cullmann 2011-06-05 17:43:57 UTC
Git commit 0f17aec4c206eb3a676e48eaa299bc0a247080c7 by Christoph Cullmann.
Committed on 05/06/2011 at 17:43.
Pushed by cullmann into branch 'master'.

error check for loading of editor, output nice error message then die
BUG: 265540
thanks for the hint Marcel, better tell the user why we fail!

M  +7    -0    kate/app/katedocmanager.cpp     

http://commits.kde.org/kate/0f17aec4c206eb3a676e48eaa299bc0a247080c7
Comment 2 Dominik Haumann 2011-08-11 08:29:11 UTC
*** Bug 255705 has been marked as a duplicate of this bug. ***
Comment 3 Dominik Haumann 2011-08-11 08:29:43 UTC
*** Bug 279783 has been marked as a duplicate of this bug. ***