Bug 265431 - digikam cmake check for JPEG_LIB_VERSION fails for libjpeg-turbo >= 1.0.90
Summary: digikam cmake check for JPEG_LIB_VERSION fails for libjpeg-turbo >= 1.0.90
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Portability-Cmake (show other bugs)
Version: 1.9.0
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-04 18:52 UTC by Rex Dieter
Modified: 2017-07-28 08:26 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.0.0


Attachments
one attempt to address this, using cmake try_compile instead of regex (1.92 KB, patch)
2011-02-04 18:52 UTC, Rex Dieter
Details
minimalistic approach, simply add content from jconfig.h too (673 bytes, patch)
2011-02-04 19:22 UTC, Rex Dieter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rex Dieter 2011-02-04 18:52:14 UTC
Created attachment 56861 [details]
one attempt to address this, using cmake try_compile instead of regex

Version:           unspecified (using KDE 4.6.0) 
OS:                Linux

In newer versions of libjpeg-turbo (as is used in fedora), starting with 1.0.90, the definition of JPEB_LIB_VERSION has moved from jpeglib.h to jconfig.h , which breaks with the current incarnation of cmake regex'ing coming from bug #228483 and the following commit:
http://websvn.kde.org/?revision=1100511&view=revision

Reproducible: Always
Comment 1 Rex Dieter 2011-02-04 18:55:02 UTC
If this approach is agreeable, a similar implementation could be used elsewhere too (like kdegraphics/gwenview and corresponding bug #227313 ).
Comment 2 Rex Dieter 2011-02-04 19:22:33 UTC
Created attachment 56863 [details]
minimalistic approach, simply add content from jconfig.h too
Comment 3 Rex Dieter 2011-03-03 19:30:11 UTC
Looks like my minimalistic version doesn't work, nvm that one.
Comment 4 Dennis veatch 2011-04-19 10:31:26 UTC
This also causes the kdegraphics-4.6.2 make to fail with libjpeg-turbo-1.1.0 but kdegraphics is fine with 1.0.1.
Comment 5 Riccardo Iaconelli 2011-05-10 11:06:36 UTC
ping! any news on the porting to libjpeg-turbo?
Comment 6 Rex Dieter 2011-05-12 14:56:32 UTC
OK, I've been using the try_compile patch variant for awhile.  that seems safest to me.
Comment 7 Riccardo Iaconelli 2011-05-12 20:00:42 UTC
can we merge it then? I can do it if you want (test included). Gilles?
Comment 8 Rex Dieter 2011-05-12 20:08:07 UTC
Fwiw, there's a similar/copied check in kdegraphics/gwenview too
Comment 9 caulier.gilles 2011-05-12 20:14:24 UTC
If something similar have been done to Gwenview, why to re-invent the wheel. If Gwenview sometion have been test, it must be adapted to digiKam as well...

Gilles Caulier
Comment 10 Rex Dieter 2011-05-12 20:17:29 UTC
Sorry, I meant that gwenview has the same problem here that digikam has.  They are both broken wrt libjpeg-turbo.
Comment 11 Riccardo Iaconelli 2011-05-13 11:05:19 UTC
so... do I have green light?
Comment 12 Rex Dieter 2011-05-13 19:50:25 UTC
fyi, tracking gwenview elsewhere in bug #273217
Comment 13 Riccardo Iaconelli 2011-05-15 16:20:15 UTC
Git commit 1ad9ae102ea1a82a72e31401fe840954a791219f by Riccardo Iaconelli.
Committed on 15/05/2011 at 16:18.
Pushed by ruphy into branch 'master'.

Don't fail CMake check: compile with libjpeg-turbo

Patch by Rex Dieter

BUG: 265431

Signed-off-by: Riccardo Iaconelli <riccardo@kde.org>

M  +17   -11   CMakeLists.txt     

http://commits.kde.org/digikam/1ad9ae102ea1a82a72e31401fe840954a791219f