Bug 265173 - akonadi crashed with kmail in background (issue imap resource)
Summary: akonadi crashed with kmail in background (issue imap resource)
Status: RESOLVED DUPLICATE of bug 242698
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-02 10:35 UTC by omega
Modified: 2011-08-28 17:16 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (10.93 KB, text/plain)
2011-06-05 19:16 UTC, S. Burmeister
Details
New crash information added by DrKonqi (7.18 KB, text/plain)
2011-07-20 15:31 UTC, Joachim Mairböck
Details

Note You need to log in before you can comment on or make changes to this bug.
Description omega 2011-02-02 10:35:15 UTC
Application: akonadi_imap_resource (0.1)
KDE Platform Version: 4.6.00 (4.6.0)
Qt Version: 4.7.1
Operating System: Linux 2.6.38-1-generic x86_64
Distribution: Ubuntu natty (development branch)

-- Information about the crash:
- What I was doing when the application crashed:

I occasionally get this crash (but only very occasionally). akonadi crashed with kmail running in background.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Akonadi Resource (akonadi_imap_resource), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f9dbcc37780 (LWP 2023))]

Thread 4 (Thread 0x7f9da95c4700 (LWP 5598)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f9da95c3af0 in ?? ()
#2  0x00007fff125e77b2 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 3 (Thread 0x7f9da8dc3700 (LWP 5599)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x00007f9dbbd8fffe in wait (this=<value optimized out>, mutex=0x9ac370, time=30000) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x9ac370, time=30000) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f9dbbd86088 in QThreadPoolThread::run (this=0x9abfd0) at concurrent/qthreadpool.cpp:140
#4  0x00007f9dbbd8f9ce in QThreadPrivate::start (arg=0x9abfd0) at thread/qthread_unix.cpp:285
#5  0x00007f9db7bb3d8c in start_thread (arg=0x7f9da8dc3700) at pthread_create.c:304
#6  0x00007f9db850939d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f9da3df7700 (LWP 5600)):
#0  0x00007f9db84fc283 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f9db6c50250 in g_main_context_poll (context=0x9f64c0, block=<value optimized out>, dispatch=1, self=<value optimized out>) at /build/buildd/glib2.0-2.27.93/glib/gmain.c:3404
#2  g_main_context_iterate (context=0x9f64c0, block=<value optimized out>, dispatch=1, self=<value optimized out>) at /build/buildd/glib2.0-2.27.93/glib/gmain.c:3086
#3  0x00007f9db6c50779 in g_main_context_iteration (context=0x9f64c0, may_block=1) at /build/buildd/glib2.0-2.27.93/glib/gmain.c:3154
#4  0x00007f9dbbea1a26 in QEventDispatcherGlib::processEvents (this=0x9bdab0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#5  0x00007f9dbbe75ed2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f9dbbe7610c in QEventLoop::exec (this=0x7f9da3df6de0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f9dbbd8d214 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#8  0x00007f9dbab2b453 in KIMAP::SessionThread::run (this=0xa34920) at ../../kimap/sessionthread.cpp:166
#9  0x00007f9dbbd8f9ce in QThreadPrivate::start (arg=0xa34920) at thread/qthread_unix.cpp:285
#10 0x00007f9db7bb3d8c in start_thread (arg=0x7f9da3df7700) at pthread_create.c:304
#11 0x00007f9db850939d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f9dbcc37780 (LWP 2023)):
[KCrash Handler]
#6  _wordcopy_fwd_aligned (dstp=12611568, srcp=12611584, len=2305843009213681776) at wordcopy.c:97
#7  0x00007f9db84ad662 in memmove (dest=0xbef380, src=<value optimized out>, len=18446744073709551608) at memmove.c:73
#8  0x00007f9dbbdada0d in QListData::remove (this=0x8c8b48, i=<value optimized out>) at /usr/include/bits/string3.h:58
#9  0x00007f9dbbdadcdb in QListData::erase (this=0x8c8b48, xi=<value optimized out>) at tools/qlist.cpp:412
#10 0x000000000045b919 in erase (this=0x8c8b00, session=0x9c5220) at /usr/include/qt4/QtCore/qlist.h:453
#11 removeFirst (this=0x8c8b00, session=0x9c5220) at /usr/include/qt4/QtCore/qlist.h:273
#12 takeFirst (this=0x8c8b00, session=0x9c5220) at /usr/include/qt4/QtCore/qlist.h:477
#13 SessionPool::declareSessionReady (this=0x8c8b00, session=0x9c5220) at ../../../resources/imap/sessionpool.cpp:207
#14 0x000000000045d2a3 in SessionPool::onLoginDone (this=0x8c8b00, job=0x9cb170) at ../../../resources/imap/sessionpool.cpp:348
#15 0x000000000045d5af in SessionPool::qt_metacall (this=0x8c8b00, _c=QMetaObject::InvokeMetaMethod, _id=10, _a=0x7fff125cc870) at ./sessionpool.moc:118
#16 0x00007f9dbbe8bbb8 in QMetaObject::activate (sender=0x9cb170, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff125cc870) at kernel/qobject.cpp:3280
#17 0x00007f9db8dfea72 in KJob::result (this=<value optimized out>, _t1=0x9cb170) at ./kjob.moc:194
#18 0x00007f9db8dfeab0 in KJob::emitResult (this=0x9cb170) at ../../kdecore/jobs/kjob.cpp:312
#19 0x00007f9dbab2a66d in KIMAP::Session::qt_metacall (this=0x9c5220, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x9a3150) at ./session.moc:109
#20 0x00007f9dbbe8aa4a in QObject::event (this=0x9c5220, e=<value optimized out>) at kernel/qobject.cpp:1219
#21 0x00007f9dbb23b024 in QApplicationPrivate::notify_helper (this=0x74d270, receiver=0x9c5220, e=0x9cd1f0) at kernel/qapplication.cpp:4445
#22 0x00007f9dbb23f95a in QApplication::notify (this=<value optimized out>, receiver=0x9c5220, e=0x9cd1f0) at kernel/qapplication.cpp:4324
#23 0x00007f9db93d26b6 in KApplication::notify (this=0x7fff125cd270, receiver=0x9c5220, event=0x9cd1f0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f9dbbe76aec in QCoreApplication::notifyInternal (this=0x7fff125cd270, receiver=0x9c5220, event=0x9cd1f0) at kernel/qcoreapplication.cpp:732
#25 0x00007f9dbbe7a275 in sendEvent (receiver=0x0, event_type=0, data=0x733510) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x733510) at kernel/qcoreapplication.cpp:1373
#27 0x00007f9dbbea1833 in sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#28 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#29 0x00007f9db6c4fcfd in g_main_dispatch (context=0x74fc80) at /build/buildd/glib2.0-2.27.93/glib/gmain.c:2440
#30 g_main_context_dispatch (context=0x74fc80) at /build/buildd/glib2.0-2.27.93/glib/gmain.c:3013
#31 0x00007f9db6c504e8 in g_main_context_iterate (context=0x74fc80, block=<value optimized out>, dispatch=1, self=<value optimized out>) at /build/buildd/glib2.0-2.27.93/glib/gmain.c:3091
#32 0x00007f9db6c50779 in g_main_context_iteration (context=0x74fc80, may_block=1) at /build/buildd/glib2.0-2.27.93/glib/gmain.c:3154
#33 0x00007f9dbbea19cf in QEventDispatcherGlib::processEvents (this=0x732c00, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#34 0x00007f9dbb2e0f9e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#35 0x00007f9dbbe75ed2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#36 0x00007f9dbbe7610c in QEventLoop::exec (this=0x7fff125cd200, flags=...) at kernel/qeventloop.cpp:201
#37 0x00007f9dbbe7a51b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#38 0x00007f9dbc56ea02 in Akonadi::ResourceBase::init (r=0x850d70) at ../../akonadi/resourcebase.cpp:302
#39 0x0000000000420906 in init<ImapResource> (argc=<value optimized out>, argv=<value optimized out>) at /usr/include/akonadi/resourcebase.h:188
#40 main (argc=<value optimized out>, argv=<value optimized out>) at ../../../resources/imap/imapresource.cpp:597

This bug may be a duplicate of or related to bug 242698.

Possible duplicates by query: bug 250163.

Reported using DrKonqi
Comment 1 S. Burmeister 2011-06-05 19:16:49 UTC
Created attachment 60666 [details]
New crash information added by DrKonqi

akonadi_imap_resource (0.1) on KDE Platform 4.6.3 (4.6.3) using Qt 4.7.3

- What I was doing when the application crashed:

Unfortunately I still get crashes while kontact is running in the background with kdepim .96.

-- Backtrace (Reduced):
#7  0x080a3567 in takeFirst (this=0x819d7d0, session=0x835a0d8) at /usr/include/QtCore/qlist.h:477
#8  SessionPool::declareSessionReady (this=0x819d7d0, session=0x835a0d8) at /usr/src/debug/kdepim-runtime-4.5.96/resources/imap/sessionpool.cpp:207
#9  0x080a505c in SessionPool::onLoginDone (this=0x819d7d0, job=0x827ac08) at /usr/src/debug/kdepim-runtime-4.5.96/resources/imap/sessionpool.cpp:348
#10 0x080a53c9 in SessionPool::qt_metacall (this=0x819d7d0, _c=QMetaObject::InvokeMetaMethod, _id=10, _a=0xbfb9b4b8) at /usr/src/debug/kdepim-runtime-4.5.96/build/resources/imap/sessionpool.moc:118
[...]
#13 0xb5c9b645 in KJob::result (this=0x827ac08, _t1=0x827ac08) at /usr/src/debug/kdelibs-4.6.3/build/kdecore/kjob.moc:194
Comment 2 Joachim Mairböck 2011-07-20 15:31:58 UTC
Created attachment 62021 [details]
New crash information added by DrKonqi

akonadi_imap_resource (0.1) on KDE Platform 4.6.5 (4.6.5) using Qt 4.7.3

- What I was doing when the application crashed:
I still get this bug (for the first time now after a few weeks) with KDEPIM 4.6.0 (from openSUSE packages). The IMAP resource that crashed is used for GMail.

-- Backtrace (Reduced):
#7  0x080a38b7 in takeFirst (this=0x81462b0, session=0x852b668) at /usr/include/QtCore/qlist.h:477
#8  SessionPool::declareSessionReady (this=0x81462b0, session=0x852b668) at /usr/src/debug/kdepim-runtime-4.6.0/resources/imap/sessionpool.cpp:207
#9  0x080a53ac in SessionPool::onLoginDone (this=0x81462b0, job=0x84e3b68) at /usr/src/debug/kdepim-runtime-4.6.0/resources/imap/sessionpool.cpp:348
#10 0x080a5719 in SessionPool::qt_metacall (this=0x81462b0, _c=QMetaObject::InvokeMetaMethod, _id=10, _a=0xbfc9f4b8) at /usr/src/debug/kdepim-runtime-4.6.0/build/resources/imap/sessionpool.moc:118
[...]
#13 0xb5c69645 in KJob::result (this=0x84e3b68, _t1=0x84e3b68) at /usr/src/debug/kdelibs-4.6.5/build/kdecore/kjob.moc:194
Comment 3 Christophe Marin 2011-08-28 17:16:57 UTC

*** This bug has been marked as a duplicate of bug 242698 ***