Bug 265098 - Remember size and position does not work
Summary: Remember size and position does not work
Status: RESOLVED DUPLICATE of bug 264981
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR normal
Target Milestone: ---
Assignee: KWin default assignee
Depends on:
Reported: 2011-02-01 16:36 UTC by Pavel Gurevich
Modified: 2011-10-09 17:12 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Gurevich 2011-02-01 16:36:39 UTC
Version:           unspecified (using KDE 4.6.0) 
OS:                Linux

If I set 'Position' and 'Size' properties to 'Remember' in 'Special Window Settings', nothing happens, and the window appears at the arbitrary position next time.

Reproducible: Didn't try

Steps to Reproduce:
On any window. Window Menu -> Advanced -> Special Window Settings... -> Geometry -> set 'Position' and 'Size' to 'Remember'. 

Actual Results:  
Nothing happens when the window is shown next time

Expected Results:  
The window should appear at the same position as when it was closed
Comment 1 Thomas Lübking 2011-02-01 16:40:47 UTC
works for me (tried xterm) - what clients did you try with?
also see bug #264981
Comment 2 Pavel Gurevich 2011-02-01 16:46:27 UTC
Doesn't work for me with xterm, either.

Restarting kwin via kwin -replace did not help. I've checked now, 'Apply initially' does not work in my setting, but 'Force' does work.

Are there other options that can supersede settings in 'Special Window Settings'?
Comment 3 Thomas Lübking 2011-02-01 17:13:49 UTC
(In reply to comment #2)
> Doesn't work for me with xterm, either.
> Restarting kwin via kwin -replace did not help. I've checked now, 'Apply
> initially' does not work in my setting, but 'Force' does work.
For clarification: "force" & "apply initially" will set the size/position in the the window has in the lineedits when you apply the rule, "remember" will remember the position the client had on closing. (+force also fixes this geometry, you cannot alter it)

If you actually wanted to use "apply initially" have a sharp look on the configured value - it's not changed if already present.

Is the entry in the config file after closing the client? Does it look "right"?
In doubt also force to ignore requested geometry (but i'd expect issues on that rather with some "certain special" client candidates.... ;-)
> Are there other options that can supersede settings in 'Special Window
> Settings'?
hardly (you don't use tiling/tabbing on the client, do you?)
Comment 4 Pavel Gurevich 2011-02-01 17:51:48 UTC
The coordinates and sizes do change upon window close! But the window actually appears at a random position. I thought it can be a result of 'smart window placement' in 'destkop effects', but I have the effects disabled.

Bottomline: in my environment kwin fails to initially apply these coordinates but does save them. Can I run it with some parameters in order to get any log that will help?
Comment 5 Pavel Gurevich 2011-02-01 17:52:49 UTC
Even restarted KDE just to be sure this is persistent.

No, I don't use tiling and tabbing, yet.
Comment 6 Thomas Lübking 2011-02-01 18:25:09 UTC
run "kdebugdialog", activate "1212 kwin" and "kwin --replace &" from konsole.
there should be no errors when launching the client, but to knwo for sure you'd have to check the code and add some debug statements? (manage.cpp:375)
Comment 7 Pavel Gurevich 2011-02-01 18:32:22 UTC
kwin(15266) KWin::Client::readUserTimeMapTimestamp: User timestamp, ASN: 4294967295
kwin(15266) KWin::Client::readUserTimeMapTimestamp: User timestamp, final: 'ID: 83886111 ;WMCLASS: "xterm" : "xterm" ;Caption: "xterm" ' : 5957201
kwin(15266) KWin::Workspace::allowClientActivation: Activation, compared: 'ID: 83886111 ;WMCLASS: "xterm" : "xterm" ;Caption: "xterm" ' : 5957201 : 5957200 : true
kwin(15266) KWin::Workspace::updateClientArea: screens:  2 desktops:  6
kwin(15266) KWin::Workspace::updateClientArea: Done.
kwin(15266) KWin::Workspace::createTile: Now tiling  "xterm"

Hmmm... I became a little bit thoughtful about the last line. Why is 'tiling' there?
Comment 8 Thomas Lübking 2011-02-01 18:58:30 UTC
the debug line is just in wrong place. the next line is

if( !tilingEnabled() || !tileable(c) )

so that shouldn't harm
Comment 9 Thomas Lübking 2011-02-02 00:37:12 UTC
errr... just notice: "screens:  2"
does it work if you hook off one of the displays?
Comment 10 Pavel Gurevich 2011-02-03 08:59:29 UTC

Sorry for the delay. Single-monitor option is the first thing I've checked. It does not work, either. I've checked the thing on a different computer, with the same result.
Comment 11 Pavel Gurevich 2011-09-29 19:37:36 UTC
I still have this problem on OpenSuSE 11.3.
Comment 12 Pavel Gurevich 2011-09-29 19:38:13 UTC
I still have this problem on OpenSuSE 11.3 and KDE SC 4.7.
Comment 13 gce.galotta 2011-10-09 09:04:26 UTC
I have the same problem with Kubuntu 11.04 and KDE 4.6.5 and Kubuntu 11.10 KDE 4.7.1 (german)

I can see in the kwinrulesrc the remembered value (and it changes) but the window always appears at 0,0.
Do i set the rule to "force" the windows is locked to the location in the kwinrulesrc.

So i made a new user (and profile) and voila "remember" works.
I probably use my profile since 4.2 (or 4.3).

What could have changed since then that could make "remember" misbehave. Do i need to delete an rc file? I really would like to keep my profile, everything else works.
Comment 14 Thomas Lübking 2011-10-09 12:27:58 UTC
The rules are stored in ~/.kde/share/config/kwinrulesrc

-> please check whether it's activity related:

-> and whether it only affects size and position:
Comment 15 gce.galotta 2011-10-09 16:52:18 UTC
It was the first activity bug for me and affected only size and position and remember (the values get always saved, though). i deleted all activities but one. Now it's working, thanks-
Comment 16 Pavel Gurevich 2011-10-09 17:04:58 UTC
I believe, mine is also activity related. New user without activities has no that odd behavior.
Comment 17 Thomas Lübking 2011-10-09 17:12:41 UTC
Ok, i'll mark this as dupe of bug #264981 - not that i didn't mention it in the very first comment :-P

*** This bug has been marked as a duplicate of bug 264981 ***