Bug 264962 - Muon Package Manager crashes when clicking on linux-headers-2.6.35-25 in the list
Summary: Muon Package Manager crashes when clicking on linux-headers-2.6.35-25 in the ...
Status: RESOLVED DUPLICATE of bug 264001
Alias: None
Product: muon
Classification: Applications
Component: muon (show other bugs)
Version: 1.1.0
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-31 14:59 UTC by Glad Deschrijver
Modified: 2011-01-31 15:26 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Glad Deschrijver 2011-01-31 14:59:22 UTC
Version:           1.1.0 (using KDE 4.5.5) 
OS:                Linux

I started the Muon Package Manager and clicked in the main view and also in the "Preview Changes" view on linux-headers-2.6.35-25 which is going to be installed during the upgrade of the linux kernel (and which is therefore not yet installed). When I click on other items, a panel at the bottom appears with details about the package. But for this package Muon crashed without showing that panel first. I repeated it 6 times with the QtCurve and also with the Oxygen widget style and the crash happened each time. It also happens for linux-headers-2.6.35-24 which is already installed. I use the binary packages from the ppa.

Reproducible: Always




-- Backtrace:
Application: Muon Package Manager (muon), signal: Aborted
[Current thread is 1 (Thread 0x7fb91818e760 (LWP 22513))]

Thread 3 (Thread 0x7fb9030a7700 (LWP 22514)):
#0  QTimerInfoList::timerWait (this=0x159dd30, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#1  0x00007fb914eb63dd in timerSourcePrepareHelper (src=<value optimized out>, timeout=0x7fb9030a6c1c) at kernel/qeventdispatcher_glib.cpp:136
#2  0x00007fb914eb6485 in timerSourcePrepare (source=0x7fb9030a6ae0, timeout=0x7fb9030a6ae0) at kernel/qeventdispatcher_glib.cpp:169
#3  0x00007fb910179a11 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#4  0x00007fb910179e78 in ?? () from /lib/libglib-2.0.so.0
#5  0x00007fb91017a45c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#6  0x00007fb914eb61e6 in QEventDispatcherGlib::processEvents (this=0x14a2100, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#7  0x00007fb914e88a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#8  0x00007fb914e88dec in QEventLoop::exec (this=0x7fb9030a6db0, flags=) at kernel/qeventloop.cpp:201
#9  0x00007fb914d932fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#10 0x00007fb914e685f8 in QInotifyFileSystemWatcherEngine::run (this=0x159d280) at io/qfilesystemwatcher_inotify.cpp:248
#11 0x00007fb914d9627e in QThreadPrivate::start (arg=0x159d280) at thread/qthread_unix.cpp:266
#12 0x00007fb914b0b971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#13 0x00007fb9140c892d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#14 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fb901454700 (LWP 22516)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:212
#1  0x00007fb914d96da2 in wait (this=<value optimized out>, mutex=0x1b65320, time=30000) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1b65320, time=30000) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fb914d8bda2 in QThreadPoolThread::run (this=0x18dabc0) at concurrent/qthreadpool.cpp:140
#4  0x00007fb914d9627e in QThreadPrivate::start (arg=0x18dabc0) at thread/qthread_unix.cpp:266
#5  0x00007fb914b0b971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#6  0x00007fb9140c892d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fb91818e760 (LWP 22513)):
[KCrash Handler]
#6  0x00007fb914015ba5 in raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x00007fb9140196b0 in abort () at abort.c:92
#8  0x00007fb914d8d864 in qt_message_output (msgType=QtFatalMsg, buf=<value optimized out>) at global/qglobal.cpp:2259
#9  0x00007fb914d8da42 in qt_message(QtMsgType, const char *, typedef __va_list_tag __va_list_tag *) (msgType=QtFatalMsg, msg=0x7fb914ef00c8 "ASSERT: \"%s\" in file %s, line %d", ap=0x7ffff3ff03a0) at global/qglobal.cpp:2305
#10 0x00007fb914d8dbf5 in qFatal (msg=0x57f1 <Address 0x57f1 out of bounds>) at global/qglobal.cpp:2488
#11 0x00007fb91741d4ce in QApt::Package::supportedUntil() const () from /usr/lib/libqapt.so.1
#12 0x00007fb917d9d743 in MainTab::refresh (this=0x1c55d50) at /build/buildd/muon-1.1.0/libmuon/DetailsTabs/MainTab.cpp:226
#13 0x00007fb917d89bf1 in DetailsWidget::setPackage (this=0x1c54690, package=0x57f1) at /build/buildd/muon-1.1.0/libmuon/DetailsWidget.cpp:79
#14 0x00007fb917d97ca1 in PackageWidget::qt_metacall (this=0x1befb30, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffff3ff1220) at /build/buildd/muon-1.1.0/obj-x86_64-linux-gnu/libmuon/PackageWidget.moc:82
#15 0x00007fb914ea1b27 in QMetaObject::activate (sender=0x1c47840, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0xffffffffffffffff) at kernel/qobject.cpp:3280
#16 0x00007fb916261765 in QAbstractItemView::clicked (this=0x57f1, _t1=<value optimized out>) at .moc/release-shared/moc_qabstractitemview.cpp:331
#17 0x00007fb916270db4 in QAbstractItemView::mouseReleaseEvent (this=0x1c47840, event=0x7ffff3ff2090) at itemviews/qabstractitemview.cpp:1789
#18 0x00007fb915d6d04e in QWidget::event (this=0x1c47840, event=0x7ffff3ff2090) at kernel/qwidget.cpp:8187
#19 0x00007fb9161385e6 in QFrame::event (this=0x1c47840, e=0x7ffff3ff2090) at widgets/qframe.cpp:557
#20 0x00007fb916271a8b in QAbstractItemView::viewportEvent (this=0x1c47840, event=0x7ffff3ff2090) at itemviews/qabstractitemview.cpp:1619
#21 0x00007fb9162afd65 in QTreeView::viewportEvent (this=0x1c47840, event=0x7ffff3ff2090) at itemviews/qtreeview.cpp:1256
#22 0x00007fb914e89507 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x1c43370, event=0x7ffff3ff2090) at kernel/qcoreapplication.cpp:847
#23 0x00007fb915d16fac in QApplicationPrivate::notify_helper (this=0x11716a0, receiver=0x1c43370, e=0x7ffff3ff2090) at kernel/qapplication.cpp:4392
#24 0x00007fb915d1d30e in QApplication::notify (this=0x7ffff3ff2d90, receiver=0x1c43370, e=0x7ffff3ff2090) at kernel/qapplication.cpp:3959
#25 0x00007fb916a6a586 in KApplication::notify (this=0x7ffff3ff2d90, receiver=0x1c43370, event=0x7ffff3ff2090) at ../../kdeui/kernel/kapplication.cpp:310
#26 0x00007fb914e89cdc in QCoreApplication::notifyInternal (this=0x7ffff3ff2d90, receiver=0x1c43370, event=0x7ffff3ff2090) at kernel/qcoreapplication.cpp:732
#27 0x00007fb915d1bdbe in sendEvent (receiver=0x1c43370, event=0x7ffff3ff2090, alienWidget=0x1c43370, nativeWidget=0x11f67e0, buttonDown=<value optimized out>, lastMouseReceiver=<value optimized out>, spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#28 QApplicationPrivate::sendMouseEvent (receiver=0x1c43370, event=0x7ffff3ff2090, alienWidget=0x1c43370, nativeWidget=0x11f67e0, buttonDown=<value optimized out>, lastMouseReceiver=<value optimized out>, spontaneous=true) at kernel/qapplication.cpp:3058
#29 0x00007fb915d9f345 in QETWidget::translateMouseEvent (this=0x11f67e0, event=<value optimized out>) at kernel/qapplication_x11.cpp:4403
#30 0x00007fb915d9dc5c in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7ffff3ff29b0) at kernel/qapplication_x11.cpp:3536
#31 0x00007fb915dca0e2 in x11EventSourceDispatch (s=0x116f6e0, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#32 0x00007fb910176342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#33 0x00007fb91017a2a8 in ?? () from /lib/libglib-2.0.so.0
#34 0x00007fb91017a45c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#35 0x00007fb914eb6193 in QEventDispatcherGlib::processEvents (this=0x1146570, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#36 0x00007fb915dc9a4e in QGuiEventDispatcherGlib::processEvents (this=0x57f1, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#37 0x00007fb914e88a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#38 0x00007fb914e88dec in QEventLoop::exec (this=0x7ffff3ff2ce0, flags=) at kernel/qeventloop.cpp:201
#39 0x00007fb914e8cebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#40 0x000000000040afe1 in main (argc=<value optimized out>, argv=<value optimized out>) at /build/buildd/muon-1.1.0/muon/main.cpp:55
Comment 1 Jonathan Thomas 2011-01-31 15:26:21 UTC

*** This bug has been marked as a duplicate of bug 264001 ***