Bug 264880 - Marble crashes when searching for a place
Summary: Marble crashes when searching for a place
Status: RESOLVED DUPLICATE of bug 193824
Alias: None
Product: marble
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: 1.1.0
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-30 19:51 UTC by Joao Pedro
Modified: 2011-07-19 19:15 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (11.06 KB, text/plain)
2011-02-05 12:47 UTC, Arek Guzinski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joao Pedro 2011-01-30 19:51:29 UTC
Application: marble (1.0.0 (Stable Release))
KDE Platform Version: 4.6.00 (4.6.0)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-25-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
I'm searching for a place in the search box and after press Enter the application closes.

- Unusual behavior I noticed:
Marble crashes and closes.

-- Backtrace:
Application: Globo Virtual Marble (marble), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f307f847760 (LWP 21797))]

Thread 6 (Thread 0x7f306af8d700 (LWP 21799)):
#0  0x00007f30773c20c0 in g_main_context_release () from /lib/libglib-2.0.so.0
#1  0x00007f30773c403b in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f30773c445c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f307d9631e6 in QEventDispatcherGlib::processEvents (this=0xafcbe0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#4  0x00007f307d935a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f307d935dec in QEventLoop::exec (this=0x7f306af8cdb0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f307d8402fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007f307d9155f8 in QInotifyFileSystemWatcherEngine::run (this=0xafc540) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f307d84327e in QThreadPrivate::start (arg=0xafc540) at thread/qthread_unix.cpp:266
#9  0x00007f3077c7a971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#10 0x00007f307c21492d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f3062d7a700 (LWP 21800)):
#0  0x00007f307d9631e8 in QEventDispatcherGlib::processEvents (this=0xd1d710, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:416
#1  0x00007f307d935a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#2  0x00007f307d935dec in QEventLoop::exec (this=0x7f3062d79db0, flags=) at kernel/qeventloop.cpp:201
#3  0x00007f307d8402fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#4  0x00007f307d9155f8 in QInotifyFileSystemWatcherEngine::run (this=0xd1ea20) at io/qfilesystemwatcher_inotify.cpp:248
#5  0x00007f307d84327e in QThreadPrivate::start (arg=0xd1ea20) at thread/qthread_unix.cpp:266
#6  0x00007f3077c7a971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#7  0x00007f307c21492d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#8  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f3062579700 (LWP 21801)):
#0  0x00007f3077c7c66f in __pthread_mutex_lock (mutex=0xe3dc98) at pthread_mutex_lock.c:62
#1  0x00007f30773c4444 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#2  0x00007f307d9631e6 in QEventDispatcherGlib::processEvents (this=0x8da660, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#3  0x00007f307d935a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#4  0x00007f307d935dec in QEventLoop::exec (this=0x7f3062578db0, flags=) at kernel/qeventloop.cpp:201
#5  0x00007f307d8402fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#6  0x00007f307d9155f8 in QInotifyFileSystemWatcherEngine::run (this=0xd2ce30) at io/qfilesystemwatcher_inotify.cpp:248
#7  0x00007f307d84327e in QThreadPrivate::start (arg=0xd2ce30) at thread/qthread_unix.cpp:266
#8  0x00007f3077c7a971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#9  0x00007f307c21492d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f305fd74700 (LWP 21808)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f305fd73a80 in ?? ()
#2  0x00007fff2eb91852 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 2 (Thread 0x7f305f573700 (LWP 21820)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f305f572a90 in ?? ()
#2  0x00007fff2eb91852 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7f307f847760 (LWP 21797)):
[KCrash Handler]
#6  Marble::GeoDataFeature::style (this=0x0) at ../../../../marble/src/lib/geodata/data/GeoDataFeature.cpp:452
#7  0x00007f307ee6b3e0 in Marble::VisiblePlacemark::symbolPixmap (this=0x18eb630) at ../../../../marble/src/lib/VisiblePlacemark.cpp:42
#8  0x00007f307ee70280 in Marble::PlacemarkLayout::whichPlacemarkAt (this=<value optimized out>, curpos=...) at ../../../../marble/src/lib/PlacemarkLayout.cpp:141
#9  0x00007f307edf35c1 in Marble::MarbleMap::whichFeatureAt (this=<value optimized out>, curpos=...) at ../../../../marble/src/lib/MarbleMap.cpp:494
#10 0x00007f307ede8b11 in Marble::MarbleWidget::whichFeatureAt (this=<value optimized out>, curpos=...) at ../../../../marble/src/lib/MarbleWidget.cpp:400
#11 0x00007f307ee12dcc in Marble::MarbleWidgetDefaultInputHandler::eventFilter (this=0xc02f00, o=<value optimized out>, e=0x7fff2eb287a0) at ../../../../marble/src/lib/MarbleWidgetInputHandler.cpp:701
#12 0x00007f307d936507 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0xa8bc10, event=0x7fff2eb287a0) at kernel/qcoreapplication.cpp:847
#13 0x00007f307cc9dfac in QApplicationPrivate::notify_helper (this=0x765260, receiver=0xa8bc10, e=0x7fff2eb287a0) at kernel/qapplication.cpp:4392
#14 0x00007f307cca430e in QApplication::notify (this=0x7fff2eb294a0, receiver=0xa8bc10, e=0x7fff2eb287a0) at kernel/qapplication.cpp:3959
#15 0x00007f307e3c0a36 in KApplication::notify (this=0x7fff2eb294a0, receiver=0xa8bc10, event=0x7fff2eb287a0) at ../../kdeui/kernel/kapplication.cpp:311
#16 0x00007f307d936cdc in QCoreApplication::notifyInternal (this=0x7fff2eb294a0, receiver=0xa8bc10, event=0x7fff2eb287a0) at kernel/qcoreapplication.cpp:732
#17 0x00007f307cca2dbe in sendEvent (receiver=0xa8bc10, event=0x7fff2eb287a0, alienWidget=0xa8bc10, nativeWidget=0x8ed3b0, buttonDown=<value optimized out>, lastMouseReceiver=<value optimized out>, spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#18 QApplicationPrivate::sendMouseEvent (receiver=0xa8bc10, event=0x7fff2eb287a0, alienWidget=0xa8bc10, nativeWidget=0x8ed3b0, buttonDown=<value optimized out>, lastMouseReceiver=<value optimized out>, spontaneous=true) at kernel/qapplication.cpp:3058
#19 0x00007f307cd26345 in QETWidget::translateMouseEvent (this=0x8ed3b0, event=<value optimized out>) at kernel/qapplication_x11.cpp:4403
#20 0x00007f307cd24c5c in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fff2eb290c0) at kernel/qapplication_x11.cpp:3536
#21 0x00007f307cd510e2 in x11EventSourceDispatch (s=0x75a420, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#22 0x00007f30773c0342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#23 0x00007f30773c42a8 in ?? () from /lib/libglib-2.0.so.0
#24 0x00007f30773c445c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#25 0x00007f307d963193 in QEventDispatcherGlib::processEvents (this=0x73ff70, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#26 0x00007f307cd50a4e in QGuiEventDispatcherGlib::processEvents (this=0x0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#27 0x00007f307d935a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#28 0x00007f307d935dec in QEventLoop::exec (this=0x7fff2eb293f0, flags=) at kernel/qeventloop.cpp:201
#29 0x00007f307d939ebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#30 0x00000000004210a5 in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../marble/src/kdemain.cpp:351

Reported using DrKonqi
Comment 1 Arek Guzinski 2011-02-05 12:47:56 UTC
Created attachment 56888 [details]
New crash information added by DrKonqi

marble (1.0.0 (Stable Release)) on KDE Platform 4.6.00 (4.6.0) using Qt 4.7.1

- What I was doing when the application crashed:

I searched for a Street in the Search Box (text: "Oldenburg, bümmersteder tredde").

-- Backtrace (Reduced):
#6  Marble::GeoDataFeature::style (this=0x0) at /var/tmp/paludis/kde-base-marble-4.6.0/work/marble-4.6.0/marble/src/lib/geodata/data/GeoDataFeature.cpp:452
#7  0x00007f89c57ed170 in Marble::VisiblePlacemark::symbolPixmap (this=0x2738b00) at /var/tmp/paludis/kde-base-marble-4.6.0/work/marble-4.6.0/marble/src/lib/VisiblePlacemark.cpp:42
#8  0x00007f89c57f1fae in Marble::PlacemarkLayout::whichPlacemarkAt (this=<value optimized out>, curpos=...) at /var/tmp/paludis/kde-base-marble-4.6.0/work/marble-4.6.0/marble/src/lib/PlacemarkLayout.cpp:141
#9  0x00007f89c57755b1 in Marble::MarbleMap::whichFeatureAt (this=<value optimized out>, curpos=...) at /var/tmp/paludis/kde-base-marble-4.6.0/work/marble-4.6.0/marble/src/lib/MarbleMap.cpp:494
#10 0x00007f89c576aae1 in Marble::MarbleWidget::whichFeatureAt (this=<value optimized out>, curpos=...) at /var/tmp/paludis/kde-base-marble-4.6.0/work/marble-4.6.0/marble/src/lib/MarbleWidget.cpp:400
Comment 2 Rolf Eike Beer 2011-03-28 19:05:47 UTC
Same here (openSUSE 11.4 x86_64)

Thread 1 (Thread 0x7f1839ac5760 (LWP 6901)):
[KCrash Handler]
#6  Marble::GeoDataFeature::style (this=0x0) at 
/usr/src/debug/kdeedu-4.6.1/marble/src/lib/geodata/data/GeoDataFeature.cpp:452
#7  0x00007f18390f5107 in Marble::VisiblePlacemark::symbolPixmap 
(this=0x40d8d80) at 
/usr/src/debug/kdeedu-4.6.1/marble/src/lib/VisiblePlacemark.cpp:42
#8  0x00007f18390fac0d in Marble::PlacemarkLayout::whichPlacemarkAt 
(this=<value optimized out>, curpos=...) at 
/usr/src/debug/kdeedu-4.6.1/marble/src/lib/PlacemarkLayout.cpp:142
#9  0x00007f1839088f31 in Marble::MarbleMap::whichFeatureAt (this=<value 
optimized out>, curpos=<value optimized out>) at 
/usr/src/debug/kdeedu-4.6.1/marble/src/lib/MarbleMap.cpp:494
#10 0x00007f183907f431 in Marble::MarbleWidget::whichFeatureAt (this=<value 
optimized out>, curpos=<value optimized out>) at 
/usr/src/debug/kdeedu-4.6.1/marble/src/lib/MarbleWidget.cpp:400
#11 0x00007f18390a632c in Marble::MarbleWidgetDefaultInputHandler::eventFilter 
(this=0xa152f0, o=<value optimized out>, e=0x7fff96819820) at 
/usr/src/debug/kdeedu-4.6.1/marble/src/lib/MarbleWidgetInputHandler.cpp:701
#12 0x00007f1837cd3607 in 
QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized 
out>, receiver=0x87a970, event=0x7fff96819820) at 
kernel/qcoreapplication.cpp:846
#13 0x00007f183709b111 in QApplicationPrivate::notify_helper (this=0x6bd180, 
receiver=0x87a970, e=0x7fff96819820) at kernel/qapplication.cpp:4458
#14 0x00007f18370a3f7c in QApplication::notify (this=<value optimized out>, 
receiver=0x87a970, e=0x7fff96819820) at kernel/qapplication.cpp:4023
#15 0x00007f1838635d46 in KApplication::notify (this=0x7fff9681a550, 
receiver=0x87a970, event=0x7fff96819820) at 
/usr/src/debug/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#16 0x00007f1837cd347c in QCoreApplication::notifyInternal 
(this=0x7fff9681a550, receiver=0x87a970, event=0x7fff96819820) at 
kernel/qcoreapplication.cpp:731
#17 0x00007f183709c155 in sendEvent (receiver=0x87a970, event=0x7fff96819820, 
alienWidget=0x87a970, nativeWidget=0x833ae0, buttonDown=0x7f1837b6d198, 
lastMouseReceiver=..., spontaneous=true) at 
../../src/corelib/kernel/qcoreapplication.h:215
#18 QApplicationPrivate::sendMouseEvent (receiver=0x87a970, 
event=0x7fff96819820, alienWidget=0x87a970, nativeWidget=0x833ae0, 
buttonDown=0x7f1837b6d198, lastMouseReceiver=..., spontaneous=true) at 
kernel/qapplication.cpp:3122
#19 0x00007f183711ab48 in QETWidget::translateMouseEvent (this=0x833ae0, 
event=<value optimized out>) at kernel/qapplication_x11.cpp:4461
#20 0x00007f1837119209 in QApplication::x11ProcessEvent (this=0x7fff9681a550, 
event=0x7fff9681a180) at kernel/qapplication_x11.cpp:3587
#21 0x00007f1837140f12 in x11EventSourceDispatch (s=0x6b5830, callback=0, 
user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#22 0x00007f1830c33bd3 in g_main_context_dispatch () from 
/lib64/libglib-2.0.so.0
#23 0x00007f1830c343b0 in ?? () from /lib64/libglib-2.0.so.0
#24 0x00007f1830c34650 in g_main_context_iteration () from 
/lib64/libglib-2.0.so.0
#25 0x00007f1837cfe22f in QEventDispatcherGlib::processEvents (this=0x69cc40, 
flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#26 0x00007f1837140bae in QGuiEventDispatcherGlib::processEvents (this=<value 
optimized out>, flags=<value optimized out>) at 
kernel/qguieventdispatcher_glib.cpp:204
#27 0x00007f1837cd28d2 in QEventLoop::processEvents (this=<value optimized 
out>, flags=...) at kernel/qeventloop.cpp:149
#28 0x00007f1837cd2ae5 in QEventLoop::exec (this=0x7fff9681a4a0, flags=...) at 
kernel/qeventloop.cpp:201
#29 0x00007f1837cd6f2b in QCoreApplication::exec () at 
kernel/qcoreapplication.cpp:1008
#30 0x0000000000421725 in main (argc=1, argv=0x7fff9681bb58) at 
/usr/src/debug/kdeedu-4.6.1/marble/src/kdemain.cpp:351
Comment 3 Dennis Nienhüser 2011-07-19 19:15:30 UTC

*** This bug has been marked as a duplicate of bug 193824 ***