Bug 264836 - Switching Windows with Alt+Tab by 3D effect Flipswitch - kde gets very slow and freezes for a short while
Summary: Switching Windows with Alt+Tab by 3D effect Flipswitch - kde gets very slow a...
Status: RESOLVED DUPLICATE of bug 261323
Alias: None
Product: kwin
Classification: Plasma
Component: compositing (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-30 12:30 UTC by nils
Modified: 2011-01-30 12:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nils 2011-01-30 12:30:12 UTC
Version:           unspecified (using KDE 4.6.0) 
OS:                Linux

When I use the flipswitch 3D effect for switching windows with Alt+Tab and I switch to another window, the 3D view disapperas normaly and I'm looking at the window I want to, but then the mouse pointer is freezing for a while and the whole desktop is reacting very slow. After some time kwin disables 3D effects itself because of few resources and too slow reactions. When I'm using other 3D effects like the cupe or windows switching with the coverswitch effect everything works well. I suppose there's a bug in the flipswitch effect.

Reproducible: Always

Steps to Reproduce:
→ activate 3D destkop effects globally
→ use flipswitch for windows switching (Alt+Tab)



→ kernel: 2.6.36.3
→ Xserver: 1.9.2
→ KDE: 4.6.0
→ nvidia propritary driver 260.19.36 (card: nVIDIA Quadro NVS 3100M with 256MB)
Comment 1 Martin Flöser 2011-01-30 12:32:11 UTC

*** This bug has been marked as a duplicate of bug 261323 ***