Bug 264719 - Amarok crashes when clicking tray icon
Summary: Amarok crashes when clicking tray icon
Status: RESOLVED DUPLICATE of bug 258741
Alias: None
Product: amarok
Classification: Applications
Component: Context View (show other bugs)
Version: 2.4.0
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: 2.4.1
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-29 10:22 UTC by Alexey Rusetsky
Modified: 2011-01-29 16:16 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Rusetsky 2011-01-29 10:22:33 UTC
Application: amarok (2.4.0)
KDE Platform Version: 4.6.00 (4.6.0) (Compiled from sources)
Qt Version: 4.7.1
Operating System: Linux 2.6.37-gentoo-nuks x86_64
Distribution: "Gentoo Base System release 2.0.1-r1"

-- Information about the crash:
- What I was doing when the application crashed:
Amarok 2.4.0 on KDE SC 4.6.0.
When I start amarok it shows up in tray. Crashes instantly when I leftclick that icon to bring the main window up, but if I first start playback (via keyboard or rightclick context menu) then leftclick it in tray, everything's fine.

Steps to reproduce:
Start Amarok
Leftlick tray icon

The crash can be reproduced every time.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0x7ff0032307a0 (LWP 19243))]

Thread 9 (Thread 0x7fefbfb55700 (LWP 19292)):
#0  0x00007feffdc9262c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007fefe8d3be30 in ?? () from /usr/lib/libvlccore.so.4
#2  0x00007feffdc8dd4c in start_thread () from /lib/libpthread.so.0
#3  0x00007fefffe15a7d in clone () from /lib/libc.so.6

Thread 8 (Thread 0x7fefb902d700 (LWP 19313)):
#0  0x00007feffdc929ab in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007fefba4c0749 in ma_checkpoint_background () from /usr/lib/libmysqld.so.0
#2  0x00007feffdc8dd4c in start_thread () from /lib/libpthread.so.0
#3  0x00007fefffe15a7d in clone () from /lib/libc.so.6

Thread 7 (Thread 0x7fefaf2bd700 (LWP 19327)):
#0  0x00007feffa65dac0 in ?? () from /usr/lib/libglib-2.0.so.0
#1  0x00007feffa65df4d in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#2  0x00007ff00077a106 in QEventDispatcherGlib::processEvents (this=0x2b324a0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#3  0x00007ff00074a912 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#4  0x00007ff00074ab5c in QEventLoop::exec (this=0x7fefaf2bcce0, flags=...) at kernel/qeventloop.cpp:201
#5  0x00007ff0006474a8 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#6  0x00007ff00072ab80 in QInotifyFileSystemWatcherEngine::run (this=0x2bb3dc0) at io/qfilesystemwatcher_inotify.cpp:248
#7  0x00007ff00064a087 in QThreadPrivate::start (arg=0x2bb3dc0) at thread/qthread_unix.cpp:285
#8  0x00007feff4becae3 in ?? () from /usr/lib/libGL.so.1
#9  0x00007feffdc8dd4c in start_thread () from /lib/libpthread.so.0
#10 0x00007fefffe15a7d in clone () from /lib/libc.so.6

Thread 6 (Thread 0x7fefaba94700 (LWP 19414)):
#0  0x00007feffdc9262c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007feffb8ccaf4 in ?? () from /usr/lib64/qt4/libQtScript.so.4
#2  0x00007feffb8ccb29 in ?? () from /usr/lib64/qt4/libQtScript.so.4
#3  0x00007feff4becae3 in ?? () from /usr/lib/libGL.so.1
#4  0x00007feffdc8dd4c in start_thread () from /lib/libpthread.so.0
#5  0x00007fefffe15a7d in clone () from /lib/libc.so.6

Thread 5 (Thread 0x7fefa7a3f700 (LWP 19447)):
#0  0x00007feffdc9262c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007ff00064a8bb in wait (this=<value optimized out>, mutex=0x34db170, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x34db170, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007feffd034061 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x35e0080, th=0x35e0700) at /mnt/mirror/portage/portage/kde-base/kdelibs-4.6.0/work/kdelibs-4.6.0/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007feffd037a20 in ThreadWeaver::WorkingHardState::applyForWork (this=0x35df1a0, th=0x35e0700) at /mnt/mirror/portage/portage/kde-base/kdelibs-4.6.0/work/kdelibs-4.6.0/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007feffd037a39 in ThreadWeaver::WorkingHardState::applyForWork (this=0x35df1a0, th=0x35e0700) at /mnt/mirror/portage/portage/kde-base/kdelibs-4.6.0/work/kdelibs-4.6.0/threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007feffd036104 in ThreadWeaver::ThreadRunHelper::run (this=0x7fefa7a3ed30, parent=0x35e0080, th=0x35e0700) at /mnt/mirror/portage/portage/kde-base/kdelibs-4.6.0/work/kdelibs-4.6.0/threadweaver/Weaver/Thread.cpp:87
#7  0x00007feffd0361e4 in ThreadWeaver::Thread::run (this=0x35e0700) at /mnt/mirror/portage/portage/kde-base/kdelibs-4.6.0/work/kdelibs-4.6.0/threadweaver/Weaver/Thread.cpp:142
#8  0x00007ff00064a087 in QThreadPrivate::start (arg=0x35e0700) at thread/qthread_unix.cpp:285
#9  0x00007feff4becae3 in ?? () from /usr/lib/libGL.so.1
#10 0x00007feffdc8dd4c in start_thread () from /lib/libpthread.so.0
#11 0x00007fefffe15a7d in clone () from /lib/libc.so.6

Thread 4 (Thread 0x7fefa723e700 (LWP 19448)):
#0  0x00007feffdc9262c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007ff00064a8bb in wait (this=<value optimized out>, mutex=0x34db170, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x34db170, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007feffd034061 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x35e0080, th=0x35e42b0) at /mnt/mirror/portage/portage/kde-base/kdelibs-4.6.0/work/kdelibs-4.6.0/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007feffd037a20 in ThreadWeaver::WorkingHardState::applyForWork (this=0x35df1a0, th=0x35e42b0) at /mnt/mirror/portage/portage/kde-base/kdelibs-4.6.0/work/kdelibs-4.6.0/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007feffd036104 in ThreadWeaver::ThreadRunHelper::run (this=0x7fefa723dd30, parent=0x35e0080, th=0x35e42b0) at /mnt/mirror/portage/portage/kde-base/kdelibs-4.6.0/work/kdelibs-4.6.0/threadweaver/Weaver/Thread.cpp:87
#6  0x00007feffd0361e4 in ThreadWeaver::Thread::run (this=0x35e42b0) at /mnt/mirror/portage/portage/kde-base/kdelibs-4.6.0/work/kdelibs-4.6.0/threadweaver/Weaver/Thread.cpp:142
#7  0x00007ff00064a087 in QThreadPrivate::start (arg=0x35e42b0) at thread/qthread_unix.cpp:285
#8  0x00007feff4becae3 in ?? () from /usr/lib/libGL.so.1
#9  0x00007feffdc8dd4c in start_thread () from /lib/libpthread.so.0
#10 0x00007fefffe15a7d in clone () from /lib/libc.so.6

Thread 3 (Thread 0x7fefa6a3d700 (LWP 19449)):
#0  0x00007feffdc9262c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007ff00064a8bb in wait (this=<value optimized out>, mutex=0x34db170, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x34db170, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007feffd034061 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x35e0080, th=0x35e5b00) at /mnt/mirror/portage/portage/kde-base/kdelibs-4.6.0/work/kdelibs-4.6.0/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007feffd037a20 in ThreadWeaver::WorkingHardState::applyForWork (this=0x35df1a0, th=0x35e5b00) at /mnt/mirror/portage/portage/kde-base/kdelibs-4.6.0/work/kdelibs-4.6.0/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007feffd037a39 in ThreadWeaver::WorkingHardState::applyForWork (this=0x35df1a0, th=0x35e5b00) at /mnt/mirror/portage/portage/kde-base/kdelibs-4.6.0/work/kdelibs-4.6.0/threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007feffd036104 in ThreadWeaver::ThreadRunHelper::run (this=0x7fefa6a3cd30, parent=0x35e0080, th=0x35e5b00) at /mnt/mirror/portage/portage/kde-base/kdelibs-4.6.0/work/kdelibs-4.6.0/threadweaver/Weaver/Thread.cpp:87
#7  0x00007feffd0361e4 in ThreadWeaver::Thread::run (this=0x35e5b00) at /mnt/mirror/portage/portage/kde-base/kdelibs-4.6.0/work/kdelibs-4.6.0/threadweaver/Weaver/Thread.cpp:142
#8  0x00007ff00064a087 in QThreadPrivate::start (arg=0x35e5b00) at thread/qthread_unix.cpp:285
#9  0x00007feff4becae3 in ?? () from /usr/lib/libGL.so.1
#10 0x00007feffdc8dd4c in start_thread () from /lib/libpthread.so.0
#11 0x00007fefffe15a7d in clone () from /lib/libc.so.6

Thread 2 (Thread 0x7fefa5b24700 (LWP 19462)):
#0  0x00007feffdc9262c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007ff00064a8bb in wait (this=<value optimized out>, mutex=0x34db170, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x34db170, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007feffd034061 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x35e0080, th=0x3725b60) at /mnt/mirror/portage/portage/kde-base/kdelibs-4.6.0/work/kdelibs-4.6.0/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007feffd037a20 in ThreadWeaver::WorkingHardState::applyForWork (this=0x35df1a0, th=0x3725b60) at /mnt/mirror/portage/portage/kde-base/kdelibs-4.6.0/work/kdelibs-4.6.0/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007feffd036104 in ThreadWeaver::ThreadRunHelper::run (this=0x7fefa5b23d30, parent=0x35e0080, th=0x3725b60) at /mnt/mirror/portage/portage/kde-base/kdelibs-4.6.0/work/kdelibs-4.6.0/threadweaver/Weaver/Thread.cpp:87
#6  0x00007feffd0361e4 in ThreadWeaver::Thread::run (this=0x3725b60) at /mnt/mirror/portage/portage/kde-base/kdelibs-4.6.0/work/kdelibs-4.6.0/threadweaver/Weaver/Thread.cpp:142
#7  0x00007ff00064a087 in QThreadPrivate::start (arg=0x3725b60) at thread/qthread_unix.cpp:285
#8  0x00007feff4becae3 in ?? () from /usr/lib/libGL.so.1
#9  0x00007feffdc8dd4c in start_thread () from /lib/libpthread.so.0
#10 0x00007fefffe15a7d in clone () from /lib/libc.so.6

Thread 1 (Thread 0x7ff0032307a0 (LWP 19243)):
[KCrash Handler]
#6  QBasicAtomicInt::operator== (this=0x5c, value=0) at /usr/include/qt4/QtCore/qbasicatomic.h:70
#7  0x00007ff001e61377 in QWeakPointer<QTimer>::isNull (this=0x36c0b88) at /usr/include/qt4/QtCore/qsharedpointer_impl.h:550
#8  0x00007ff001e613a5 in QWeakPointer<QTimer>::operator QTimer* QWeakPointer<QTimer>::* (this=<value optimized out>) at /usr/include/qt4/QtCore/qsharedpointer_impl.h:552
#9  0x00007ff001e5f761 in Context::ContextView::addCollapseAnimation (this=0x36c0b10, anim=0x378aca0) at /mnt/mirror/portage/portage/media-sound/amarok-2.4.0/work/amarok-2.4.0/src/context/ContextView.cpp:247
#10 0x00007ff001e5b878 in Context::Applet::collapse (this=0x37b1900, on=<value optimized out>) at /mnt/mirror/portage/portage/media-sound/amarok-2.4.0/work/amarok-2.4.0/src/context/Applet.cpp:315
#11 0x00007fefa5d465aa in Albums::dataUpdated (this=0x37b1900, name=<value optimized out>, data=<value optimized out>) at /mnt/mirror/portage/portage/media-sound/amarok-2.4.0/work/amarok-2.4.0/src/context/applets/albums/Albums.cpp:117
#12 0x00007fefa5d4726e in Albums::qt_metacall (this=0x37b1900, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffb98a8b20) at /mnt/mirror/portage/portage/media-sound/amarok-2.4.0/work/amarok-2.4.0_build/src/context/applets/albums/Albums.moc:84
#13 0x00007ff00076352f in QMetaObject::activate (sender=0x37d4790, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffb98a8b20) at kernel/qobject.cpp:3272
#14 0x00007feffc1de367 in Plasma::DataContainer::dataUpdated (this=<value optimized out>, _t1=<value optimized out>, _t2=<value optimized out>) at /mnt/mirror/portage/portage/kde-base/kdelibs-4.6.0/work/kdelibs-4.6.0_build/plasma/datacontainer.moc:112
#15 0x00007feffc1def90 in Plasma::DataContainer::checkForUpdate (this=0x37d4790) at /mnt/mirror/portage/portage/kde-base/kdelibs-4.6.0/work/kdelibs-4.6.0/plasma/datacontainer.cpp:327
#16 0x00007feffc1e23f8 in Plasma::DataEngine::timerEvent (this=0x3731500, event=0x7fffb98a9300) at /mnt/mirror/portage/portage/kde-base/kdelibs-4.6.0/work/kdelibs-4.6.0/plasma/dataengine.cpp:386
#17 0x00007ff000762019 in QObject::event (this=0x3731500, e=<value optimized out>) at kernel/qobject.cpp:1175
#18 0x00007ff00113a6d4 in QApplicationPrivate::notify_helper (this=0x26d27d0, receiver=0x3731500, e=0x7fffb98a9300) at kernel/qapplication.cpp:4445
#19 0x00007ff00113f991 in QApplication::notify (this=<value optimized out>, receiver=0x3731500, e=0x7fffb98a9300) at kernel/qapplication.cpp:4324
#20 0x00007ff002bdd9a2 in KApplication::notify (this=0x7fffb98a9600, receiver=0x3731500, event=0x7fffb98a9300) at /mnt/mirror/portage/portage/kde-base/kdelibs-4.6.0/work/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#21 0x00007ff00074be5c in QCoreApplication::notifyInternal (this=0x7fffb98a9600, receiver=0x3731500, event=0x7fffb98a9300) at kernel/qcoreapplication.cpp:732
#22 0x00007ff00077d326 in sendEvent (this=0x26d4560) at kernel/qcoreapplication.h:215
#23 QTimerInfoList::activateTimers (this=0x26d4560) at kernel/qeventdispatcher_unix.cpp:603
#24 0x00007ff000779994 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#25 0x00007feffa65d4d3 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#26 0x00007feffa65dcb0 in ?? () from /usr/lib/libglib-2.0.so.0
#27 0x00007feffa65df4d in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#28 0x00007ff00077a0af in QEventDispatcherGlib::processEvents (this=0x25452b0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#29 0x00007ff0011ea83e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#30 0x00007ff00074a912 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#31 0x00007ff00074ab5c in QEventLoop::exec (this=0x7fffb98a9590, flags=...) at kernel/qeventloop.cpp:201
#32 0x00007ff0007500ab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#33 0x0000000000407074 in main (argc=1, argv=0x7fffb98aba88) at /mnt/mirror/portage/portage/media-sound/amarok-2.4.0/work/amarok-2.4.0/src/main.cpp:268

Reported using DrKonqi
Comment 1 Dario Andres 2011-01-29 13:42:37 UTC
[Comment from a bug triager]
Related to bug 258741. Read bug 258741 comment 6
Comment 2 Myriam Schweingruber 2011-01-29 16:16:24 UTC

*** This bug has been marked as a duplicate of bug 258741 ***