Bug 264704 - KWin becomes VERY slow when changing tabs with the Box Switch effect
Summary: KWin becomes VERY slow when changing tabs with the Box Switch effect
Status: RESOLVED DUPLICATE of bug 261323
Alias: None
Product: kwin
Classification: Plasma
Component: compositing (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-29 03:13 UTC by Oscar Pereira
Modified: 2011-01-30 00:54 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oscar Pereira 2011-01-29 03:13:20 UTC
Version:           unspecified (using KDE 4.6.0) 
OS:                Linux

After upgrading to KDE4.6.0, everything went smoothly until I tried to switch windows using Alt-Tab (Box Switch). KWin became very slow, to the point it automatically disabled desktop effects. And without effects, everything was smooth. Eventually noticed this happens with Box Switch, but NOT with Cover Switch (which I am using now, and so far without problems). Haven't tried any other effects besides these two. This problem was seen in two systems running ArchLinux, one with an nvidia (binary driver) and another with an Intel graphics board (don't have more specific info). 


Reproducible: Always

Steps to Reproduce:
Upgrade to KDE 4.6.0, with desktop effects enabled and working. Choose as window switching animation (System Settings -> Desktop Effects -> Effect for Window Switching) the Box Switch animation. Try to change windows using Alt-Tab. 

Actual Results:  
System will become unresponsive, with possible "interference" (lacking a better description) appearing on the screen. Sometimes this is so severe that the only recourse is to log into a console and kill the X server. 

Expected Results:  
Changed window without any further hassle.

I'm marking the severity as a Crash, because, although it has a pretty straightforward workaround (use another effect to switch windows, or none at all), the fact is it, more often that not, will cause the system to crash.
Comment 1 Martin Flöser 2011-01-29 08:37:07 UTC
This is not a crash, even if it is annoying for you. Please go to advanced effect settings and change "Scale method" from "Accurate" to "Smooth" and try again.

Please also provide more information about your setups.
Comment 2 Oscar Pereira 2011-01-30 00:09:36 UTC
First and foremost, I must make a rather embarrassing correction: when I above wrote "Box Switch", what I had in mind was actually "Flip Switch". The hanging/crash ONLY happens with this one method of switching, and with none of the others (I tested it just now, nvidia gpu). 

"Scale method" was already set to "Smooth"; I changed it to "Accurate", and together with "Flip Switch", it crashed my system (as in, reboot needed). With the other switch methods, the scale method seems to have no influence.

What further information do you require?
Comment 3 Thomas Lübking 2011-01-30 00:54:37 UTC

*** This bug has been marked as a duplicate of bug 261323 ***