Bug 264535 - Plasma battery applet needs a double click to launch settings
Summary: Plasma battery applet needs a double click to launch settings
Status: RESOLVED DUPLICATE of bug 259470
Alias: None
Product: plasma4
Classification: Plasma
Component: widget-battery (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-27 21:52 UTC by Benni Hill
Modified: 2011-01-27 22:21 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
replace signal activated() with clicked() (623 bytes, patch)
2011-01-27 21:52 UTC, Benni Hill
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Benni Hill 2011-01-27 21:52:25 UTC
Created attachment 56537 [details]
replace signal activated() with clicked()

Version:           unspecified (using KDE 4.6.0) 
OS:                Linux

In battery.cpp line 613 the clicked() signal should be connected to openConfig() instead of the activated() signal. (This is already the case with the hibernateButton and the suspendButton.)
See attached patch.

Reproducible: Always
Comment 1 Pino Toscano 2011-01-27 22:21:26 UTC

*** This bug has been marked as a duplicate of bug 259470 ***