Bug 264460 - Amarok 2.4.0 cannot delete tracks from or transfer tracks & artwork to iPod
Summary: Amarok 2.4.0 cannot delete tracks from or transfer tracks & artwork to iPod
Status: RESOLVED DUPLICATE of bug 263288
Alias: None
Product: amarok
Classification: Applications
Component: Collections/iPod iPhone (show other bugs)
Version: 2.4.0
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: 2.4.1
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-27 12:38 UTC by Ian
Modified: 2011-12-20 11:37 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ian 2011-01-27 12:38:51 UTC
Version:           2.4.0 (using KDE 4.5.5) 
OS:                Linux

Since I upgraded from 2.3.x to 2.4.0, I can't delete tracks from my iPod (a Nano 2nd gen) - I click delete track & nothing happens.
If I try to copy tracks to the iPod, sometimes they will copy, more often they won't. I get the option to copy or transcode the files (which is odd - 2.4.0 doesn't support yet transcoding to a media device yet!?!), I click the Copy option & usually I get an error message:
Tracks not copied: the device already has these tracks.

The tracks may or may not copy across, some do, some don't - there doesn't seem to be a pattern to it.

Running the search for stale tracks also does nothing.

Both the few new tracks I have managed top copy across & all the ones that were already on there (which I can't delete now) have no artwork anymore.

I get the same thing happening on both my desktop & laptop, both running openSUSE 11.3 with KDE 4.5.5.

Note, Amarok doesn't crash, there are several bug reports about iPods not deleting/copying tracks where Amarok crashes, but that's not the case for me.

Reproducible: Always

Steps to Reproduce:
connect ipod & mount it, open the iPod collection, right click, choose delete track. Right click a track/album/artist in the local collection & choose copy to collection, iPod

Actual Results:  
As described in the details section above...

Expected Results:  
The tracks should have been deleted or copied to the device (with artwork).

OS: Linux (x86_64) release 2.6.34.7-0.7-desktop
Compiler: gcc
Comment 1 Myriam Schweingruber 2011-02-25 09:37:44 UTC

*** This bug has been marked as a duplicate of bug 263288 ***
Comment 2 Edney Matias 2011-04-06 01:20:38 UTC
Hi there.

I know it's closed and it's solved but I will add my experience. I'm running kde sc 4.6.1 with amarok 2.4.0 on top of an updated Fedora 15 Alpha. I have libimobiledevice-1.1.0-2.fc15.i686 and libmtp-1.0.5-2.fc15.i686. I can't copy or remove files to and from my iPod Shuffle 2nd generation. If I connect and mount it before firing up amarok it won't show up on collection panel. I have to unmount and mount again. I'm using gtkpod for now but it's unable to keep the musics in the order they are organized. I could not test this case with amarok.

Thank you.
Comment 3 Edney Matias 2011-04-06 02:30:02 UTC
One more thing, when i use amarok or gtkpod to write files to the ipod (when they work) i can't play music on random mode only continuous mode. I have to plug it on windows and reset to fresh state and copy musics from there if i want them randomly played.
Comment 4 Edney Matias 2011-04-06 02:30:43 UTC
Should i report a new bug?
Comment 5 Myriam Schweingruber 2011-04-06 12:55:21 UTC
Could you please add your comments to the original bug 263288? This one is closed as a duplicate of that bug, it doesn't make sense to comment here.