Bug 264213 - wireshark background colors ignored
Summary: wireshark background colors ignored
Status: RESOLVED FIXED
Alias: None
Product: Oxygen
Classification: Plasma
Component: gtk3-engine (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Hugo Pereira Da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-25 01:07 UTC by nucleo
Modified: 2012-07-09 15:04 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nucleo 2011-01-25 01:07:51 UTC
Version:           unspecified
OS:                Linux

Background colors are ignored in wireshark.

Reproducible: Always


Actual Results:  
Wireshark window with oxygen-gtk-1.0.1:
http://nucleo.fedorapeople.org/wireshark-oxygen-gtk.png

Expected Results:  
With QtCurve wireshark looks as it should:
http://nucleo.fedorapeople.org/wireshark-qtcurve.png
Comment 1 Ruslan Kabatsayev 2011-01-25 01:46:03 UTC
Git commit 41eceb4fb2a9b28c8152454bcc75237c343470a4 by Ruslan Kabatsayev.
Pushed by kabatsayev into branch '1.0'.

Don't draw bg gradient on d.isBase() if it's modified by app
CCBUG: 264213

M  +6    -3    src/oxygenstylewrapper.cpp     

http://commits.kde.org/d1a86b4e/41eceb4fb2a9b28c8152454bcc75237c343470a4
Comment 2 Ruslan Kabatsayev 2011-01-25 01:49:16 UTC
This bug should be fixed by the commit above. Please confirm and close this bug if it's resolved.
Comment 3 nucleo 2011-01-25 02:29:08 UTC
I applied slightly modified patch to oxygen-1.0.1
http://paste.kde.org/3272/raw/
(committed patch can't be applied to 1.0.1)
It fixes bug:
http://img440.imageshack.us/img440/514/wiresharkfixed.png
Comment 4 Ruslan Kabatsayev 2011-01-25 02:33:44 UTC
You'd better do this to download latest 1.0 version (with all fixes since 1.0.1):
git clone git://anongit.kde.org/oxygen-gtk -b 1.0
Comment 5 nucleo 2011-01-25 02:44:15 UTC
(In reply to comment #4)
> You'd better do this to download latest 1.0 version (with all fixes since
> 1.0.1):
> git clone git://anongit.kde.org/oxygen-gtk -b 1.0

Bug fixed in 1.0 version from git.
Comment 6 nucleo 2012-06-27 22:15:18 UTC
Similar problem now with wireshark-1.8.0 built --with-gtk3 and oxygen-gtk3-1.0.5
http://img838.imageshack.us/img838/3161/wiresharkoxygen.png
http://img405.imageshack.us/img405/3817/wiresharkraleigh.png
Comment 7 Hugo Pereira Da Costa 2012-06-28 13:54:07 UTC
... So, reopening and assigning to gtk3 engine
(no big surprise that the bug shows up in gtk3, we did not port all tweaks from gtk2 yet, because of not being able to test).

I'll have to get a hand on the latest wireshark to debug.
Will keep you posted.

Thanks for reporting.
Comment 8 Hugo Pereira Da Costa 2012-06-28 16:41:44 UTC
Git commit 43b57e9f72afe21623c34886acf8ad28a4566d52 by Hugo Pereira Da Costa.
Committed on 28/06/2012 at 18:40.
Pushed by hpereiradacosta into branch 'gtk3'.

get color from theming engine before rendering background.
need to make sure that it does not introduce regressions in other applications.

M  +8    -1    src/oxygenthemingengine.cpp

http://commits.kde.org/oxygen-gtk/43b57e9f72afe21623c34886acf8ad28a4566d52
Comment 9 Hugo Pereira Da Costa 2012-07-09 15:04:33 UTC
So. Fixed in master (gtk3 branch)
no regression observed so far. 
Closing.

This will land in oxygen-gtk3-1.1.0 release, in a week or so.