Bug 263872 - Kio fail to download large files
Summary: Kio fail to download large files
Status: RESOLVED DUPLICATE of bug 244215
Alias: None
Product: kio
Classification: Frameworks and Libraries
Component: http (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
: 257767 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-01-21 14:51 UTC by Cédric Bellegarde
Modified: 2011-01-23 07:58 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cédric Bellegarde 2011-01-21 14:51:18 UTC
Version:           unspecified (using KDE 4.5.5) 
OS:                Linux

When downloading large files with konqueror/rekonq, most of the time, kio fail to download file and hang.

It's a really annoying bug.

Duplicated:
https://bugs.kde.org/show_bug.cgi?id=257767

Reproducible: Sometimes

Steps to Reproduce:
Download iso files (good way to reproduce)

Actual Results:  
Hang while downloading

Expected Results:  
Download the file

rekonq(17990)/kdewebkit KWebPage::acceptNavigationRequest: url:   QUrl( "http://releases.ubuntu.com/lucid/ubuntu-10.04-netbook-i386.iso" )  , type:  0 , frame:  QWebFrame(0x22c31b0)
rekonq(17990) ProtocolHandler::postHandling: URL PROTOCOL:  KUrl("http://releases.ubuntu.com/lucid/ubuntu-10.04-netbook-i386.iso")
rekonq(17990)/kio (KIOJob) KIO::SlaveInterface::dispatch: error  111   "/home/gnumdk/ubuntu-10.04-netbook-i386.iso"
Comment 1 Panagiotis Papadopoulos 2011-01-21 14:59:27 UTC
*** Bug 257767 has been marked as a duplicate of this bug. ***
Comment 2 niburu1 2011-01-21 17:57:02 UTC
I can confirm. KDE 4.6 RC2, Kubuntu 10.10.
Comment 3 Andrea Diamantini 2011-01-22 10:23:40 UTC
To fix this, I need some informations more before:
1) a testing url where this surely happens for you.
2) your tests results about that url with rekonq, konqueror/KHTML and konqueror/WebKit
Comment 4 Dawit Alemayehu 2011-01-23 07:58:18 UTC

*** This bug has been marked as a duplicate of bug 244215 ***