Bug 263262 - Symlink loop results in never ending search with dolphin
Summary: Symlink loop results in never ending search with dolphin
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Unclassified
Component: search (show other bugs)
Version: 16.12.2
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-15 22:32 UTC by paul
Modified: 2011-01-16 13:40 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 4.6.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description paul 2011-01-15 22:32:43 UTC
Version:           unspecified (using KDE 4.5.95) 
OS:                Linux

For some reasons I had to create a "symlink loop" in my home directory:

~/progs/linux links to ~/progs

This causes dolphin to search in an endless loop.

Reproducible: Always

Steps to Reproduce:
Create a looping symlink like the one above.



I think there has to be an additional control step to check whether the given directory was already visited.

The cause of this bug is definitely annoying - who ever assumes something like that!?
Comment 1 Peter Penz 2011-01-16 13:39:40 UTC
SVN commit 1214805 by ppenz:

Assure that no endless searching is done if a link points to a parent directory

BUG: 263262
FIXED-IN: 4.6.0


 M  +12 -1     filenamesearchprotocol.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1214805
Comment 2 Peter Penz 2011-01-16 13:40:08 UTC
SVN commit 1214807 by ppenz:

Assure that no endless searching is done if a link points to a parent directory

CCBUG: 263262
FIXED-IN: 4.6.0


 M  +12 -1     filenamesearchprotocol.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1214807