Bug 263131 - Status indicator icon not showing correct status
Summary: Status indicator icon not showing correct status
Status: VERIFIED FIXED
Alias: None
Product: KDE PIM Mobile
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Windows CE Microsoft Windows CE
: NOR normal
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: komo3
Depends on:
Blocks:
 
Reported: 2011-01-14 12:00 UTC by Andre Heinecke
Modified: 2011-02-15 17:19 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andre Heinecke 2011-01-14 12:00:04 UTC
Sometimes the status indicator shows grey although the akonadi ressources are online and the device is online.

Othertimes it shows downloading although the device is offline.
Same goes for sending.
Comment 1 Bjoern Ricks 2011-01-14 12:11:22 UTC
It's also confusing that sometimes the status of a local resource is online, imap is offline and the main status indicator shows online. I always have to take a look at the account menu to get the "real" status of my resources.

Maybe it would also be possible to show the status of the current selected resource/account if one is selected in the breadcrumb navigation.
Comment 2 Tobias Koenig 2011-01-19 13:58:15 UTC
For the record: The problem seems to be that the Solid::Networking::statusChanged() signal is not emitted correctly on network status changes on WinCE. This might also be the cause for bug 258271.
Comment 3 Andre Heinecke 2011-01-21 18:49:40 UTC
SVN commit 1216169 by aheinecke:

- Remove the use of private qt api. This did not work as intended
  so the status was never updated. When there was no instance of
  networkingcontrolmgr. (The minimalnetworkingclient used to test
  before does that)
- Instanciate WinCE Networking Control Manager because it handles
  the Window Messages notifing about a Network status change.
- Create the Networking control manager as a child window
  of the correct qt main window. So Messages are recive correctly
  even in multithreaded applications with multiple windows.
- Cleanup debug output a bit.

CCBUG: 258271
CCBUG: 263626
BUG: 263131



 M  +12 -23    networking_wince.cpp  
 M  +4 -0      networking_wince_p.h  
 M  +43 -7     networkingcontrolmanager_wince.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1216169