Bug 263104 - Newlines are stripped when creating a note through drag'n'drop
Summary: Newlines are stripped when creating a note through drag'n'drop
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-notes (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-14 06:55 UTC by Elias Probst
Modified: 2011-12-11 08:40 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Elias Probst 2011-01-14 06:55:18 UTC
Version:           unspecified (using KDE 4.5.95) 
OS:                Linux

When creating a new note on the desktop containment through drag'n'drop, the newlines of the text are stripped.

Reproducible: Always

Steps to Reproduce:
1. Select some multiline text in a terminal
2. Drag it to the desktop containment and drop it

Actual Results:  
When creating a new note from dropped multiline text, there are no newlines preserved.
When dropping multiline text into an already existing note applet, everything works as expected.

Expected Results:  
I'd expect the newlines to be preserved correctly when creating a new note through drag'n'drop.

The issue might also be caused by the desktop containment itself to which the text is dragged to and then handed over to the new applet-notes instance.

I'm using the grid desktop containment here.
Comment 1 Aaron J. Seigo 2011-01-14 20:17:06 UTC
SVN commit 1214473 by aseigo:

let QTextEdit decide what sort of content it is
BUG:263104


 M  +1 -1      notes.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1214473
Comment 2 Aaron J. Seigo 2011-01-14 20:18:14 UTC
SVN commit 1214474 by aseigo:

let QTextEdit decide what sort of content it is
CCBUG:263104


 M  +1 -1      notes.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1214474
Comment 3 Elias Probst 2011-10-07 06:06:57 UTC
Sorry, have to re-open this bug.

This problem does still exist in 4.7.2.

→ Select some multiline text in kwrite
→ Drag it to the grid-desktop and drop it
→ Created note doesn't contain the newlines
Comment 4 Anne-Marie Mahfouf 2011-12-11 08:40:53 UTC
Git commit 76fde4fb8a67cf6663a76015ce48d09799447699 by Anne-Marie Mahfouf.
Committed on 11/12/2011 at 09:34.
Pushed by annma into branch 'master'.

fix dropping formatted text

Thanks to rshah for the patch

BUG:272495

M  +2    -1    applets/notes/notes.cpp

http://commits.kde.org/kdeplasma-addons/76fde4fb8a67cf6663a76015ce48d09799447699