Bug 262945 - Bug with schedules moved to next processing day
Summary: Bug with schedules moved to next processing day
Status: RESOLVED FIXED
Alias: None
Product: kmymoney
Classification: Unclassified
Component: general (show other bugs)
Version: SVN
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KMyMoney Devel Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-12 13:42 UTC by David Houlden
Modified: 2011-08-13 22:23 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Houlden 2011-01-12 13:42:07 UTC
Version:           SVN trunk (using KDE 4.5.5) 
OS:                Linux

I noticed this today (12th Jan) on version 1.0.5 and it also applies to 4.5 latest SVN.

I have a monthly schedule set up for a payment on the 15th of each month. This schedule is coming to an end and the last payment is due on 15th Jan. The first thing I noticed was that the payment was not appearing in the home page list of future payments. I opened the schedule editor and it is set up like this.
Frequency: 1 month
Type: Withdrawal
Next Due Date: 15/01/2011
If schedule falls on a non processing day change to next processing day.
Amount is an estimate: Not selected.
Enter schedule automatically: Selected.
Schedule will end at some time: Selected.
Number of transactions remaining: 0.  (This doesn't look right)
Date of final transaction: 15/01/2011.

In the schedule editor I changed the option for a non processing day to be "Do nothing" and saved the schedule. Now, the payment appears on the home page future payments. The schedule editor now shows 1 transaction remaining with a final transaction date of 15/01/2011 which is all correct. Setting the option back to move to next processing day shows the bug again, it no longer appears on the home page and shows zero transactions remaining.

Reproducible: Always
Comment 1 David Houlden 2011-01-17 16:43:01 UTC
A bit more information. This schedule is now showing as complete and has been entered into the ledger as expected on 17th Jan. There just seems to be a problem before the schedule due date as described above.
Comment 2 Cristian Oneț 2011-08-13 10:48:59 UTC
SVN commit 1246857 by conet:

BUG: 262945
Consider the adjusted dates (both start and end) of a schedule when computing the payment dates in a given period.

 M  +8 -5      mymoneyscheduled.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1246857
Comment 3 Cristian Oneț 2011-08-13 10:52:05 UTC
SVN commit 1246858 by conet:

BUG: 262945
Consider the adjusted dates (both start and end) of a schedule when computing the payment dates in a given period.
Backported to the stable branch.

 M  +8 -5      mymoneyscheduled.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1246858
Comment 4 Cristian Oneț 2011-08-13 22:22:48 UTC
SVN commit 1246974 by conet:

BUG: 262945
Added a testcase for this scenario.

 M  +15 -0     mymoneyscheduletest.cpp  
 M  +1 -0      mymoneyscheduletest.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1246974
Comment 5 Cristian Oneț 2011-08-13 22:23:56 UTC
SVN commit 1246975 by conet:

BUG: 262945
Added a testcase for this scenario.
Backported to the stable branch.

 M  +15 -0     mymoneyscheduletest.cpp  
 M  +1 -0      mymoneyscheduletest.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1246975