Bug 262906 - kio_http cache can fill up whole disk space in /var
Summary: kio_http cache can fill up whole disk space in /var
Status: RESOLVED DUPLICATE of bug 244215
Alias: None
Product: kio
Classification: Frameworks and Libraries
Component: http (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-11 23:23 UTC by Lukáš Karas
Modified: 2011-01-14 18:12 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lukáš Karas 2011-01-11 23:23:23 UTC
Version:           unspecified (using KDE 4.5.95) 
OS:                Linux

kio_http cache downloaded files into directory /var/tmp/kdecache-$USER/http. This cached file is trashed when kio process ended. But sometimes (always when downloading is started from kmail) kio process lives long time after moment when downloading ended. When you download many huge files, kio cache can fill up the whole disk space for /var directory. This situation product random crashes of others applications.

Reproducible: Always

Steps to Reproduce:
Create huge file on your http server (disk image for example). This file should be greater than your disk space in /var directory.

Try download it 

/usr/bin/kioclient cp "http://myserver/disk.img" "/somewhere/disk.img"

Actual Results:  
Free disk space is zero. KDE desktop go to the hell.

Expected Results:  
kio_http should not fill whole disk space. Maybe it may exists limit of cache for each kio process in % of free space? 

Please, I don't want download huge files via wget anymore! I want use kio instead.
Comment 1 Dawit Alemayehu 2011-01-14 18:12:30 UTC

*** This bug has been marked as a duplicate of bug 244215 ***