Bug 262879 - Can't add new tab when I remove all tabs
Summary: Can't add new tab when I remove all tabs
Status: RESOLVED FIXED
Alias: None
Product: kmix
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Christian Esken
URL:
Keywords:
: 261326 263523 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-01-11 18:58 UTC by Błażej Szczygieł
Modified: 2011-04-03 14:51 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Błażej Szczygieł 2011-01-11 18:58:45 UTC
Version:           unspecified (using KDE 4.5.95) 
OS:                Linux

When I close all tabs I can't add a new tab. The new tab button is disappearing!

Reproducible: Always




OS: Linux (x86_64) release 2.6.37-desktop
Compiler: gcc
Comment 1 Christian Esken 2011-01-15 00:37:40 UTC
How do you close the last tab?
The "close tab" button should disappear if you only have one Tab left.
Comment 2 Błażej Szczygieł 2011-01-15 12:52:29 UTC
Ok, the bug does not occur always. If KMix is opened with one tab, then I can close the tab and KMix is empty.
I think the new tab button should be added into "File" menu.
Comment 3 Christian Esken 2011-02-12 01:24:14 UTC
Oh, you are right. It shouldn't be hard to fix.
Comment 4 Christian Esken 2011-03-11 00:53:54 UTC
*** Bug 263523 has been marked as a duplicate of this bug. ***
Comment 5 Christian Esken 2011-03-11 00:58:32 UTC
*** Bug 261326 has been marked as a duplicate of this bug. ***
Comment 6 Christian Esken 2011-03-11 01:00:52 UTC
SVN commit 1224440 by esken:

Disable View management (close-tab and new-tab) when using PulseAudio
Fix "Can't add new tab when I remove all tabs"
BUGS: 262879

 M  +22 -15    kmix.cpp  
 M  +0 -1      kmix.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1224440
Comment 7 H.H. 2011-03-23 18:08:31 UTC
I suffered also from this problem, and tried this svn revision. But it does not solve the problem for me: after boot, the device-tabs are gone.

see also bug 264835
Comment 8 Colin Guthrie 2011-04-03 13:55:07 UTC
SVN commit 1226956 by cguthrie:

Disable View management (close-tab and new-tab) when using PulseAudio.

Fix 'Can't add new tab when I remove all tabs'
CCBUG: 262879
(merges r1224440 from trunk)

 M  +22 -15    kmix.cpp  
 M  +0 -1      kmix.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1226956
Comment 9 Martin Koller 2011-04-03 14:51:26 UTC
"Disable View management .. when using PulseAudio"

I have the same problem (KDE 4.6.1) but do not use PulseAudio