Bug 262574 - Add a face tag does not do anything
Summary: Add a face tag does not do anything
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Faces-Workflow (show other bugs)
Version: 2.0.0
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-08 20:22 UTC by Milan Knížek
Modified: 2017-08-15 21:49 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Milan Knížek 2011-01-08 20:22:07 UTC
Version:           2.0.0 (using KDE 4.5.4) 
OS:                Linux

It is impossible to add a face tag on faces not recognised during scan.

Reproducible: Always

Steps to Reproduce:
In preview mode click on "add a face tag".

Actual Results:  
Nothing happens.

Expected Results:  
It should allow the user to draw a rectangle around a face on the image.

SVN as of today.
Comment 1 Johann-Nikolaus Andreae 2011-01-19 09:19:43 UTC
I can confirm this bug
Comment 2 Adam Spiers 2011-02-01 00:17:01 UTC
Me too.  I have also submitted bug 265025 for issues with tagging unknown faces.
Comment 3 LoneStar 2011-02-06 16:43:20 UTC
I've read on a previous bug comment for beta1 (which I can't remember and can't find anymore) that the code for this is just not present. The button is there but there's no code to handle it.

Well, I expected some code would have been promptly inserted in beta2, being this a rather obviously important function in the whole face recognition process. But also in beta2 the button still does nothing.

Hoping in beta3 :-)
Comment 4 Roland Wolters 2011-02-07 22:00:35 UTC
I just tested Beta2, the problem is still valid. There is no way of tagging a face which has not been recognized in a previous scan.

I think that is a release critical bug.
Comment 5 Marcel Wiesweg 2011-03-05 13:42:09 UTC
Git commit 1f9a1bbb4e1e64b73f52e1f42260a5c9b05c4e53 by Marcel Wiesweg.
Committed on 05/03/2011 at 13:39.
Pushed by mwiesweg into branch 'development/2.0'.

Implement manually adding a face

BUG: 262574

M  +3    -1    NEWS     
M  +88   -22   utilities/facedetection/facegroup.cpp     
M  +4    -0    utilities/facedetection/facegroup.h     

http://commits.kde.org/digikam/1f9a1bbb4e1e64b73f52e1f42260a5c9b05c4e53
Comment 6 Milan Knížek 2011-03-06 19:33:55 UTC
Nice, after a brief testing: works for me.