Bug 262560 - Ktorrent 4.1beta1 crash when selecting or deselecting superseeding whilst seeding
Summary: Ktorrent 4.1beta1 crash when selecting or deselecting superseeding whilst see...
Status: RESOLVED DUPLICATE of bug 261529
Alias: None
Product: ktorrent
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-08 18:51 UTC by Dave Plater
Modified: 2011-01-09 14:51 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Plater 2011-01-08 18:51:31 UTC
Application: ktorrent (4.1beta1)
KDE Platform Version: 4.5.95 (4.6 RC2)
Qt Version: 4.7.1
Operating System: Linux 2.6.34.7-0.7-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I selected a torrent that was in the process of seeding and then selected settings from the context menu after checking or unchecking the superseeding check box and clicking ok ktorrent crashes.

The crash can be reproduced every time.

-- Backtrace:
Application: KTorrent (ktorrent), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f5fd9116760 (LWP 13764))]

Thread 6 (Thread 0x7f5fc59c8710 (LWP 13766)):
#0  0x00007f5fd4fac6b3 in poll () from /lib64/libc.so.6
#1  0x00007f5fd030bfd4 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f5fd030c510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f5fd6a0fae6 in QEventDispatcherGlib::processEvents (this=0x81b8a0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f5fd69e4262 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f5fd69e4475 in QEventLoop::exec (this=0x7f5fc59c7e20, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f5fd68f71a4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007f5fd68f9a1e in QThreadPrivate::start (arg=0x81d380) at thread/qthread_unix.cpp:285
#8  0x00007f5fd666aa4f in start_thread () from /lib64/libpthread.so.0
#9  0x00007f5fd4fb582d in clone () from /lib64/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f5fc51c7710 (LWP 13767)):
#0  0x00007f5fd4fac6b3 in poll () from /lib64/libc.so.6
#1  0x00007f5fd8c4ef4c in net::Poll::poll (this=0x7f5fc51c6cf0, timeout=<value optimized out>) at /usr/src/debug/libktorrent-1.1beta1/src/net/poll.cpp:99
#2  0x00007f5fd8cb0b53 in dht::RPCServer::Private::run (this=0x745170) at /usr/src/debug/libktorrent-1.1beta1/src/dht/rpcserver.cpp:95
#3  0x00007f5fd68f9a1e in QThreadPrivate::start (arg=0x745170) at thread/qthread_unix.cpp:285
#4  0x00007f5fd666aa4f in start_thread () from /lib64/libpthread.so.0
#5  0x00007f5fd4fb582d in clone () from /lib64/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f5fbd240710 (LWP 13770)):
#0  0x00007f5fd666f709 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f5fd68f97d5 in thread_sleep (ti=0x7f5fbd23fdb0) at thread/qthread_unix.cpp:435
#2  0x00007f5fd68f9940 in QThread::msleep (msecs=<value optimized out>) at thread/qthread_unix.cpp:461
#3  0x00007f5fd8c4be98 in net::DownloadThread::update (this=0x6e9af0) at /usr/src/debug/libktorrent-1.1beta1/src/net/downloadthread.cpp:91
#4  0x00007f5fd8c4bef9 in net::NetworkThread::run (this=0x6e9af0) at /usr/src/debug/libktorrent-1.1beta1/src/net/networkthread.cpp:48
#5  0x00007f5fd68f9a1e in QThreadPrivate::start (arg=0x6e9af0) at thread/qthread_unix.cpp:285
#6  0x00007f5fd666aa4f in start_thread () from /lib64/libpthread.so.0
#7  0x00007f5fd4fb582d in clone () from /lib64/libc.so.6
#8  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f5fbca3f710 (LWP 13771)):
#0  0x00007f5fd666f709 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f5fd68f97d5 in thread_sleep (ti=0x7f5fbca3edb0) at thread/qthread_unix.cpp:435
#2  0x00007f5fd68f9940 in QThread::msleep (msecs=<value optimized out>) at thread/qthread_unix.cpp:461
#3  0x00007f5fd8c4b6e8 in net::UploadThread::update (this=0x6ea040) at /usr/src/debug/libktorrent-1.1beta1/src/net/uploadthread.cpp:89
#4  0x00007f5fd8c4bef9 in net::NetworkThread::run (this=0x6ea040) at /usr/src/debug/libktorrent-1.1beta1/src/net/networkthread.cpp:48
#5  0x00007f5fd68f9a1e in QThreadPrivate::start (arg=0x6ea040) at thread/qthread_unix.cpp:285
#6  0x00007f5fd666aa4f in start_thread () from /lib64/libpthread.so.0
#7  0x00007f5fd4fb582d in clone () from /lib64/libc.so.6
#8  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f5fbc23e710 (LWP 13772)):
#0  0x00007f5fd666f39c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f5fd68fa10b in wait (this=<value optimized out>, mutex=0x12db000, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x12db000, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f5fd8c4eab2 in net::ReverseResolverThread::run (this=0x12daff0) at /usr/src/debug/libktorrent-1.1beta1/src/net/reverseresolver.cpp:123
#4  0x00007f5fd68f9a1e in QThreadPrivate::start (arg=0x12daff0) at thread/qthread_unix.cpp:285
#5  0x00007f5fd666aa4f in start_thread () from /lib64/libpthread.so.0
#6  0x00007f5fd4fb582d in clone () from /lib64/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f5fd9116760 (LWP 13764)):
[KCrash Handler]
#6  0x00007f5fd8c79063 in bt::Downloader::downloadRate (this=0xcee250) at /usr/src/debug/libktorrent-1.1beta1/src/download/downloader.cpp:524
#7  0x00007f5fd8c9343d in bt::TorrentControl::updateStats (this=0xc55120) at /usr/src/debug/libktorrent-1.1beta1/src/torrent/torrentcontrol.cpp:1237
#8  0x00007f5fd8c951ed in bt::TorrentControl::update (this=0xc55120) at /usr/src/debug/libktorrent-1.1beta1/src/torrent/torrentcontrol.cpp:259
#9  0x000000000042e473 in kt::Core::update (this=0x7f4a40) at /usr/src/debug/ktorrent-4.1beta1/ktorrent/core.cpp:1043
#10 0x0000000000435821 in kt::Core::qt_metacall (this=0x7f4a40, _c=QMetaObject::InvokeMetaMethod, _id=10, _a=0x7fffc1ea71d0) at /usr/src/debug/ktorrent-4.1beta1/build/ktorrent/core.moc:159
#11 0x00007f5fd69f9fef in QMetaObject::activate (sender=0x7f4a68, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3272
#12 0x00007f5fd69f8999 in QObject::event (this=0x7f4a68, e=<value optimized out>) at kernel/qobject.cpp:1175
#13 0x00007f5fd5b85cd4 in QApplicationPrivate::notify_helper (this=0x744c70, receiver=0x7f4a68, e=0x7fffc1ea7950) at kernel/qapplication.cpp:4445
#14 0x00007f5fd5b8e1ca in QApplication::notify (this=<value optimized out>, receiver=0x7f4a68, e=0x7fffc1ea7950) at kernel/qapplication.cpp:4324
#15 0x000000000043c0b1 in kt::App::notify (this=<value optimized out>, receiver=<value optimized out>, event=<value optimized out>) at /usr/src/debug/ktorrent-4.1beta1/ktorrent/app.cpp:97
#16 0x00007f5fd69e4e2c in QCoreApplication::notifyInternal (this=0x7fffc1ea7d00, receiver=0x7f4a68, event=0x7fffc1ea7950) at kernel/qcoreapplication.cpp:732
#17 0x00007f5fd6a12658 in sendEvent (this=0x744220) at kernel/qcoreapplication.h:215
#18 QTimerInfoList::activateTimers (this=0x744220) at kernel/qeventdispatcher_unix.cpp:618
#19 0x00007f5fd6a0f3d8 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#20 idleTimerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#21 0x00007f5fd030ba93 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#22 0x00007f5fd030c270 in ?? () from /usr/lib64/libglib-2.0.so.0
#23 0x00007f5fd030c510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#24 0x00007f5fd6a0fa8f in QEventDispatcherGlib::processEvents (this=0x6e7820, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#25 0x00007f5fd5c2aeae in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#26 0x00007f5fd69e4262 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#27 0x00007f5fd69e4475 in QEventLoop::exec (this=0x7fffc1ea7c60, flags=...) at kernel/qeventloop.cpp:201
#28 0x00007f5fd69e88db in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#29 0x000000000042bce4 in main (argc=5, argv=0x7fffc1ea8b38) at /usr/src/debug/ktorrent-4.1beta1/ktorrent/main.cpp:176

Possible duplicates by query: bug 261529.

Reported using DrKonqi
Comment 1 Joris Guisson 2011-01-09 14:51:29 UTC

*** This bug has been marked as a duplicate of bug 261529 ***