Bug 262396 - xml dump does not work because of non existent timezone
Summary: xml dump does not work because of non existent timezone
Status: RESOLVED WORKSFORME
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: akonadiconsole (show other bugs)
Version: 4.6
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: triaged
Depends on:
Blocks:
 
Reported: 2011-01-07 12:21 UTC by Florian Reinhard
Modified: 2018-10-27 02:54 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Reinhard 2011-01-07 12:21:24 UTC
Version:           4.6 (using KDE 4.5.90) 
OS:                Linux



Reproducible: Didn't try

Steps to Reproduce:
have a ical file which containts this timezone info:

TZID:(GMT+01.00) Sarajevo/Warsaw/Zagreb

use akonadiconsole->browser->some-ics->dump-to-xml


Actual Results:  
* akonadiconsole(586): Cannot open  "/usr/share/zoneinfo/(GMT+01.00) Sarajevo/Warsaw/Zagreb" 
* no xml file

Expected Results:  
have a xml dump!

does not exist:
/usr/share/zoneinfo/(GMT+01.00) Sarajevo/Warsaw/Zagreb

do exist:
/usr/share/zoneinfo/Europe/Zagreb
/usr/share/zoneinfo/posix/Europe/Zagreb
/usr/share/zoneinfo/right/Europe/Zagreb
Comment 1 Denis Kurz 2016-09-24 20:31:48 UTC
This bug has only been reported for versions older than KDEPIM 4.14 (at most akonadi-1.3). Can anyone tell if this bug still present?

If noone confirms this bug for a recent version of akonadi (part of KDE Applications 15.08 or later), it gets closed in about three months.
Comment 2 jacob.becker 2016-11-23 08:21:20 UTC
I can confirm this isue is still present with OpenSUSU 42.2 
akonadiconsole 0.99
KDE Framework 5.26.0
akonadi 5.3.2
Comment 3 Daniel Vrátil 2017-01-07 12:08:26 UTC
The code was actually disabled in Akonadi Console for a long time, so the export did nothing.

I re-enabled that and it seems to work for me. I can't see any code in Akonadi that would directly interact with /usr/share/zoneinfo", so I suspect this might be a bug in libical when parsing the event. Allen, do you interact with /usr/share/timezones in libical directly?
Comment 4 Andrew Crouthamel 2018-09-26 22:25:05 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 5 Andrew Crouthamel 2018-10-27 02:54:11 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 30 days. The bug is now closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!