Bug 262349 - powerdevil plasma widget eats a lot of cpu when displayed
Summary: powerdevil plasma widget eats a lot of cpu when displayed
Status: RESOLVED FIXED
Alias: None
Product: solid
Classification: Frameworks and Libraries
Component: powermanagement (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Dario Freddi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-06 23:46 UTC by Lukas Tines
Modified: 2011-01-26 22:29 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
xsession-errors file (10.84 KB, text/plain)
2011-01-06 23:46 UTC, Lukas Tines
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Tines 2011-01-06 23:46:08 UTC
Created attachment 55661 [details]
xsession-errors file

Version:           unspecified (using KDE 4.5.85) 
OS:                Linux

When I click on battery icon and widget is displayed, immediately plasma-desktop eats 70-80% cpu and xorg process takes another 50%. i have to click 3-4 times on button (sleep, hibernate, settings) to actualy do something. And the brigtness slider doesnt work but that is imho related to bug 261341.

Reproducible: Always

Steps to Reproduce:
1. Click on the battery icon
Comment 1 Dario Freddi 2011-01-15 20:57:26 UTC
It would be extremely helpful if you attached your kded4 output when the issue occurs
Comment 2 Benni Hill 2011-01-26 15:28:01 UTC
The CPU usage issue seems to be fixed in 4.6 fianl, but going into settings still needs a double click.
Comment 3 Dario Freddi 2011-01-26 22:29:34 UTC
Marking as Fixed then. For the other issue, please open a separate BR against the widget.