Bug 262139 - [Flip Switch] KWin hangs and crashes when choosing Desktop
Summary: [Flip Switch] KWin hangs and crashes when choosing Desktop
Status: RESOLVED DUPLICATE of bug 261323
Alias: None
Product: kwin
Classification: Unclassified
Component: compositing (show other bugs)
Version: git master
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-05 00:42 UTC by Kai Uwe Broulik
Modified: 2011-04-30 10:46 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kai Uwe Broulik 2011-01-05 00:42:53 UTC
Version:           SVN (using KDE 4.5.90) 
OS:                Linux

I have a two monitor configuration and as I already pointed out in Bug 262137 it is a bit weird. In the present Window staple, beside the fact that I also cannot find a pattern in the choosing of the Desktop shown. When I tested it, it chose the desktop of the second screen and when choosing it, the windows began to re-position themselves to their original position and just before the desktop was completely restored it hang for many seconds, then the desktop was finally moved and it still hang and then it either crashed (without Konqui evolved, thus no backtrace!) or plasma effects being suspended.
I tried it trice and always got the same result. Pressing and holding Alt-Tab to quickly navigate to the Desktop and then leave the keys and have it hang.

Reproducible: Always
Comment 1 Martin Flöser 2011-01-13 19:38:47 UTC
Also here I have to ask what is the "Present Windows staple" effect? Feel free to post the German name.
Comment 2 Kai Uwe Broulik 2011-01-13 19:40:28 UTC
3D-Fensterstapel :D
Comment 3 Martin Flöser 2011-01-13 19:52:18 UTC
please have a look if it is a duplicate of bug #261323?
Comment 4 Martin Flöser 2011-01-13 21:37:42 UTC
SVN commit 1214264 by graesslin:

Include the desktop window from active screen in alt+tab.

For the tabbox mode to include the desktop window a random desktop
window was picked in a multi screen setup. Now the desktop window
of the current active screen is picked.
CCBUG: 262139

 M  +1 -1      tabbox.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1214264
Comment 5 Martin Flöser 2011-01-13 21:41:48 UTC
SVN commit 1214265 by graesslin:

Backport rev 1214264: Include the desktop window from active screen in alt+tab.

For the tabbox mode to include the desktop window a random desktop
window was picked in a multi screen setup. Now the desktop window
of the current active screen is picked.
CCBUG: 262139



 M  +1 -1      tabbox.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1214265
Comment 6 Martin Flöser 2011-04-30 10:46:47 UTC
I assume it is a duplicate of bug 261323. If not fixed in 4.6.3 please reopen.

*** This bug has been marked as a duplicate of bug 261323 ***