Bug 261698 - Zoom to 100% does not map 1 picture pixel to 1 screen pixel
Summary: Zoom to 100% does not map 1 picture pixel to 1 screen pixel
Status: RESOLVED WORKSFORME
Alias: None
Product: digikam
Classification: Unclassified
Component: Preview-Image (show other bugs)
Version: 1.4.0
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-31 10:57 UTC by Marvin Raaijmakers
Modified: 2012-09-12 21:25 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 3.0.0


Attachments
1:1 zoom in EOG vs 1:1 zoom in Digikam (118.04 KB, image/jpeg)
2010-12-31 11:00 UTC, Marvin Raaijmakers
Details
Comparison between Gimp and Digikam when previewing an image (407.28 KB, image/jpeg)
2012-09-12 21:02 UTC, Thomas Bleher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marvin Raaijmakers 2010-12-31 10:57:53 UTC
Version:           1.4.0 (using KDE 4.5.1) 
OS:                Linux

When I in digikam view a photo and click the "zoom to 100%" button, then the picture is scaled to an unexpected size. A user would expect one pixel of the picture to be mapped to exactly one pixel on the screen. However this is not the case and it seems that digikam zooms less than 100%.
When I try to zoom further to come close to what should be the correct 1:1 zoom level, then the image looks blurred (probably because it is downscaled by digikam and then upscaled again). I have added a screenshot to illustrate this. On the left you see the picture opened in "Eye of GNOME", where the picture is zoomed 1:1. On the right you see the same picture opened in Digikam, where I tried to zoom that much such that the picture appears almost as big as in EOG. Here you clearly see that in Digikam the picture is blurred.

Maybe there is some good reason that the developers chose to internally scale down the picture, but when a user wants to see the photo 1:1 then he should be able do this. Also the button the effect of clicking the "zoom to 100%" button should be as expected, which is now not the case (what does now 100% mean?).

Reproducible: Always

Steps to Reproduce:
See my description of the attachment above.

Actual Results:  
See attachment.

Expected Results:  
See my description of the attachment above: a sharp image.
Comment 1 Marvin Raaijmakers 2010-12-31 11:00:01 UTC
Created attachment 55406 [details]
1:1 zoom in EOG vs 1:1 zoom in Digikam
Comment 2 Vlado Plaga 2010-12-31 11:56:10 UTC
Probably you just selected to not load full-size images in the initial setup - a common problem I also had when I did not know DigiKam very well yet.

Go to Settings / Configure Digikam... / Album View /

Tick "Embedded preview loads full size images."

Otherwise 100% means 100% of the screen width.

Maybe the user interface could give a hint? Like a pop-up over the pull-down menu saying "Note: Digikam is currently configured to only load reduced images." Or instead of "100%" that entry could be termed "display width"?
Comment 3 caulier.gilles 2010-12-31 11:57:52 UTC
Can you give a comparison with other photo tools as gimp, krita, f-spot, gwenview, xnview, etc...

It will be fine also to see how photoshop display this image in 100%.

Gilles Caulier
Comment 4 caulier.gilles 2010-12-31 11:59:29 UTC
There is a hint to preview view on the top right corner of preview canvas. It's indicate that a reduced JPEG preview is displayed.

Gilles Caulier
Comment 5 Marvin Raaijmakers 2010-12-31 12:42:07 UTC
Indeed your suggestions did the trick, but I still think there is something wrong in terms of user interface design.
First of all what does 100% mean when that configuration option is not checked? You say that 100% means 100% of the screen width, but is that also the case for portrait photo's. Anyway we need another name for this.
Secondly there is another confusing thing. I was looking for configuration option you pointed me add, but I could not find it. Why? Because the subtitle of the "Album View" configuration page is: "Customize the look of the album lists". So the problem is that I did not expect this option on this page because in my opinion it has nothing to do with the looks of the album list.
Another thing that I find wrong is that it says "Embedded preview loads full-sized images.". What is a "preview"? When I double-click on a image in the album i would say "digikam views the image" instead of "digikam previews the image" (I would call a thumbnail something that is a preview). So use the word "view" instead of "preview". That would also be consistent with the "View" button in the toolbar.
 

(In reply to comment #2)
> Probably you just selected to not load full-size images in the initial setup -
> a common problem I also had when I did not know DigiKam very well yet.
> 
> Go to Settings / Configure Digikam... / Album View /
> 
> Tick "Embedded preview loads full size images."
> 
> Otherwise 100% means 100% of the screen width.
> 
> Maybe the user interface could give a hint? Like a pop-up over the pull-down
> menu saying "Note: Digikam is currently configured to only load reduced
> images." Or instead of "100%" that entry could be termed "display width"?
Comment 6 Marcel Wiesweg 2010-12-31 14:13:31 UTC
- the 1:1 zoom = 100% should be fixed in 2.0, which has a rewritten implementation of the preview canvas
- the word "preview" is an important for RAW images, where "viewing" is not straightforward
- yes, the wording of the setup option can be improved
Comment 7 caulier.gilles 2010-12-31 14:38:29 UTC
Preview is a way to load image quickly.

For JPEG, a reduced decoded image is processed. It's a feature provided by
libjpeg.

For RAW, these formats are container. RAW data, JPEG preview, metadata, etc...
In this case JPEG preview is a reduced version of RAW already processed by the
camera when you shot. It's used to display image on device screen or on a tv. 

For other format, as PNG, TIFF, PGF, we load a preview JPEG image from IPTC or
XMP metadata. there is a tag dedicated for that.

Gilles Caulier
Comment 8 caulier.gilles 2011-12-16 11:14:21 UTC
Marvin,

This file still valid using digiKam 2.4 ?

Gilles Caulier
Comment 9 Thomas Bleher 2012-09-12 21:02:47 UTC
Created attachment 73871 [details]
Comparison between Gimp and Digikam when previewing an image

The attached image was created on Ubuntu 12.10beta1 with digikam 4:2.8.0-0ubuntu1. As you can see, the bug is still present. Setting the size to 100% shows the image at the correct size, but the image quality is very bad. Changing the setting as described in the bug report fixes the display, but I think this is an important usability concern. I didn't find the option myself and had to look through bugzilla to find the correct setting. IMHO digikam should automatically load the original file if the user requests a higher zoom level.
Comment 10 caulier.gilles 2012-09-12 21:07:11 UTC
To compare with Gimp, you need to use Image Editor, not Preview.

Preview use a reduced version of image. With JPEG, we use a dedicated API for libjpeg to do it.

In Image Editor, quality is always the best.

Anyway, If you you want to use preview to compare with Gimp, force preview to load full image size. Go to Setup/Album View Settings/Preview options....

Gilles Caulier
Comment 11 caulier.gilles 2012-09-12 21:24:04 UTC
This file is invalid. Look my screenshot comparison between digiKam and Gimp :

* Zoom to 100 percents between gimp and digiKam image editor :

http://www.flickr.com/photos/digikam/7980697101/sizes/o/in/photostream/

==> no difference !

*  Zoom to 100 percents between gimp and digiKam preview in full size mode :

http://www.flickr.com/photos/digikam/7980695825/sizes/o/in/photostream/

==> no difference !

*  Zoom to 100 percents between gimp and digiKam preview in reduced size mode :

http://www.flickr.com/photos/digikam/7980696890/sizes/o/in/photostream/

=> It's different, but it's normal. It's not the size image dimension to compare !

Gilles Caulier