Bug 261629 - "Delete Tracks" should also delete .mood file
Summary: "Delete Tracks" should also delete .mood file
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Moodbar (show other bugs)
Version: 2.4-GIT
Platform: Gentoo Packages Linux
: NOR wishlist (vote)
Target Milestone: 2.4.0
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-30 14:00 UTC by Marius
Modified: 2011-02-09 14:21 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 2.4.1


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marius 2010-12-30 14:00:18 UTC
Version:           2.4-GIT (using KDE 4.5.4) 
OS:                Linux

When deleting tracks from the collection via right-click in the collection view and selecting "Delete Tracks" the media files are correctly removed from the disk, but the .mood-files belonging to them stay in the directory. They should also be removed because they are useless without the tracks.

Reproducible: Always
Comment 1 Marius 2010-12-30 14:12:15 UTC
Also when "organizing files", the mood files should be moved to the new location and their names be adjusted.
Comment 2 Sergey Ivanov 2011-02-09 13:37:52 UTC
Git commit 9488efdb99dac06acde3acb6dd4ec3c2f786a7fb by Sergey Ivanov.
Committed on 09/02/11 at 11:35.
Pushed by ivanov into branch 'master'.

Delete .mood files when tracks got removed from collection via Collection view context menu, and move them to new destination during Organize Collection process.
BUG: 261629

M  +4    -1    ChangeLog     
M  +35   -1    src/core-impl/collections/db/sql/SqlCollectionLocation.cpp     
M  +1    -0    src/core-impl/collections/db/sql/SqlCollectionLocation.h     

http://commits.kde.org/amarok/9488efdb99dac06acde3acb6dd4ec3c2f786a7fb