Bug 261624 - Moving an album from one collection to another doesn't update the source collection
Summary: Moving an album from one collection to another doesn't update the source coll...
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Database-Scan (show other bugs)
Version: 1.6.0
Platform: Fedora RPMs Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-30 12:49 UTC by Vincent Tassy
Modified: 2019-12-25 17:24 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 7.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vincent Tassy 2010-12-30 12:49:25 UTC
+++ This bug was initially created as a clone of Bug #258775 +++

Version:           1.5.0 (using KDE 4.5.3) 
OS:                Linux

I have two collections defined:
- 1 on my local HDD
- 1 on my NAS (Collection on Network Share)

Here's the problem:

- Move one folder from one collection to another collection
- Folder and content are now visible in the destination collection
- Folder and content thumbnails still visible in the original collection !
- Physically, the files have been moved (they're in the destination collection
and no longer in the original one)

- Pressing F5 doesn't fix it
- Rescanning the collections doesn't fix it

- Closing digikam, relaunching it still shows the folder and thumbnails in the
original collection
- Rescaning the collections now makes the folder disappear from the original
collection

Reproducible: Always

Steps to Reproduce:
- Move one folder from one collection to another collection

Actual Results:  
- Folder and content are now visible in the destination collection
- Folder and content thumbnails still visible in the original collection !
- Physically, the files have been moved (they're in the destination collection
and no longer in the original one)

Expected Results:  
Folder and content should be visible only in the destination collection

It was working fine in 1.2.0
It started happening when Fedora upgraded digikam from 1.2.0 to 1.5.0

It's DANGEROUS because you might think the files are still in the source collection ! and if you happen to delete the ones visible in the destination collection then you actually lose your files !!!!!!
Comment 1 Vincent Tassy 2011-01-07 23:38:07 UTC
Tested 2.0.0beta1
Same problem :-(
Comment 2 Marcel Wiesweg 2011-01-28 13:19:32 UTC
why the duplicate?

*** This bug has been marked as a duplicate of bug 258775 ***
Comment 3 Vincent Tassy 2011-01-28 20:51:00 UTC
Didn't know whether the version number matered ...
Comment 4 caulier.gilles 2019-12-25 17:24:54 UTC
Not reproducible using digiKam 7.0.0 beta1.