Bug 261555 - Dragging file onto taskbar entry to open up a window does no longer work
Summary: Dragging file onto taskbar entry to open up a window does no longer work
Status: RESOLVED WORKSFORME
Alias: None
Product: plasma4
Classification: Plasma
Component: widget-taskbar (show other bugs)
Version: 4.6.0
Platform: Ubuntu Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-29 20:18 UTC by Kai Uwe Broulik
Modified: 2012-05-22 13:24 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kai Uwe Broulik 2010-12-29 20:18:55 UTC
Version:           unspecified (using KDE 4.5.90) 
OS:                Linux

Since in KDE 4.6 you can add “Windows 7 like launchers” (which isn‘t even close to Windows 7‘s feature) you can no longer drag folders/files onto the taskbar and wait and have the target folder restored.
This renders dragging files COMPLETELY unusable since as soon as you click a folder its window is focussed no matter if you simply want to drag a file. (This has been reported years ago but likely will never be fixed)

Reproducible: Always
Comment 1 Dario Andres 2010-12-30 18:26:23 UTC
[Comment from a bug triager]
Related to bug 261443. 
- Is your Dolphin navigation setting set a "double-click to
open file/folder" ?
Regards
Comment 2 Kai Uwe Broulik 2010-12-30 18:36:57 UTC
Nope, it is set to open using single-click
Comment 3 Kai Uwe Broulik 2011-02-10 13:37:18 UTC
Definitly more a bug in the widget itself than in kdelibs since dragging files onto Smooth Tasks widget which uses kdelibs still brings up the respective window. Definitly caused by this new launcher feature.
Comment 4 Myriam Schweingruber 2012-05-21 22:32:11 UTC
Is this still valid with KDE 4.8.3 or later?
Comment 5 Kai Uwe Broulik 2012-05-22 08:21:56 UTC
Just tried. Works in 4.8.3 :)
Comment 6 Myriam Schweingruber 2012-05-22 13:24:05 UTC
Wow, great :)
You might not know but as a reporter you can close your own bugs.