Bug 261530 - [knewstuff3] ASSERT: "rating <= 100" in file provider.cpp:601
Summary: [knewstuff3] ASSERT: "rating <= 100" in file provider.cpp:601
Status: RESOLVED FIXED
Alias: None
Product: frameworks-attica
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Jeremy Whiting
URL:
Keywords:
: 262277 264511 264790 265458 265788 266019 266348 267452 268392 268676 269062 269521 270070 270488 270619 271033 271881 272113 272478 274366 274810 277849 277851 280492 280917 281639 283110 285136 285446 286154 290821 292809 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-12-29 13:32 UTC by JR
Modified: 2012-01-29 16:40 UTC (History)
43 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.7.1


Attachments
New crash information added by DrKonqi (12.89 KB, text/plain)
2010-12-30 22:47 UTC, Andrew Stromme
Details
New crash information added by DrKonqi (12.10 KB, text/plain)
2011-01-09 10:36 UTC, mossad
Details
New crash information added by DrKonqi (9.37 KB, text/plain)
2011-01-27 00:08 UTC, Chaos A.D.
Details
New crash information added by DrKonqi (11.10 KB, text/plain)
2011-02-08 19:54 UTC, HarrisP
Details
New crash information added by DrKonqi (11.97 KB, text/plain)
2011-02-23 22:06 UTC, Sal Colon
Details
New crash information added by DrKonqi (11.42 KB, text/plain)
2011-03-14 00:00 UTC, linuxg33k4life
Details
New crash information added by DrKonqi (7.66 KB, text/plain)
2011-04-05 01:14 UTC, Alexandr
Details
New crash information added by DrKonqi (26.67 KB, text/plain)
2011-07-07 19:15 UTC, Sebadamus
Details
Patch to fix the voting problem (942 bytes, patch)
2011-08-23 16:37 UTC, Oldřich Jedlička
Details
New crash information added by DrKonqi (12.50 KB, text/plain)
2011-09-21 20:26 UTC, tauraniaakant
Details

Note You need to log in before you can comment on or make changes to this bug.
Description JR 2010-12-29 13:32:45 UTC
Application: systemsettings (1.0)
KDE Platform Version: 4.5.90 (4.6 RC1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-24-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
Kubuntu 10.10, running KDE 4.5.90 packages from kubuntu ppas.

- What I was doing when the application crashed:
I was browsing for new splash screens, and when I clicked Details on one of the entries listed it crashed System Settings with this error.

It seems the culprit entry is "KStarboard Splash". I view the details of any other theme and then that one in succession, it always crashes.

(As soon as I open up the details of any entry it also says "Your vote was recorded" after loading previews, if that helps diagnosis in any way.)

-- Backtrace:
Application: System Settings (systemsettings), signal: Aborted
[KCrash Handler]
#7  0x0039b416 in __kernel_vsyscall ()
#8  0x006a5941 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#9  0x006a8e42 in abort () at abort.c:92
#10 0x078602dc in qt_message_output (msgType=QtFatalMsg, buf=0x9987710 "ASSERT: \"rating <= 100\" in file /build/buildd/attica-0.2.0/lib/provider.cpp, line 601") at global/qglobal.cpp:2259
#11 0x078604aa in qt_message (msgType=<value optimized out>, msg=0x79d8a7c "ASSERT: \"%s\" in file %s, line %d", ap=0xbfe0ad14 "\037\017\064") at global/qglobal.cpp:2305
#12 0x078605b9 in qFatal (msg=0x79d8a7c "ASSERT: \"%s\" in file %s, line %d") at global/qglobal.cpp:2488
#13 0x07860645 in qt_assert (assertion=0x340f1f "rating <= 100", file=0x340bdc "/build/buildd/attica-0.2.0/lib/provider.cpp", line=601) at global/qglobal.cpp:2004
#14 0x00333908 in Attica::Provider::voteForContent(QString const&, unsigned int) () from /usr/lib/libattica.so.0
#15 0x020e4e98 in KNS3::AtticaProvider::vote (this=0x8fb4580, entry=..., rating=110) at ../../../knewstuff/knewstuff3/attica/atticaprovider.cpp:330
#16 0x020bd6be in KNS3::Engine::vote (this=0x98189b8, entry=..., rating=110) at ../../../knewstuff/knewstuff3/core/engine.cpp:481
#17 0x020d6bd3 in KNS3::EntryDetails::ratingChanged (this=0x9979e50, rating=11) at ../../../knewstuff/knewstuff3/ui/entrydetailsdialog.cpp:300
#18 0x020d9ae7 in KNS3::EntryDetails::qt_metacall (this=0x9979e50, _c=QMetaObject::InvokeMetaMethod, _id=9, _a=0xbfe0b008) at ./entrydetailsdialog.moc:98
#19 0x079718ca in QMetaObject::metacall (object=0x9979e50, cl=15249, idx=9, argv=0xbfe0b008) at kernel/qmetaobject.cpp:237
#20 0x079846ad in QMetaObject::activate (sender=0x8fca920, m=0xc5f8bc, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3280
#21 0x00b7f723 in KRatingWidget::ratingChanged (this=0x8fca920, _t1=11) at ./kratingwidget.moc:171
#22 0x00b7f954 in KRatingWidget::setRating (this=0x8fca920, rating=11) at ../../kdeui/widgets/kratingwidget.cpp:173
#23 0x020d8692 in KNS3::EntryDetails::entryChanged (this=0x9979e50, entry=...) at ../../../knewstuff/knewstuff3/ui/entrydetailsdialog.cpp:126
#24 0x020d996b in KNS3::EntryDetails::setEntry (this=0x9979e50, entry=...) at ../../../knewstuff/knewstuff3/ui/entrydetailsdialog.cpp:72
#25 0x020aeab9 in KNS3::DownloadWidgetPrivate::slotShowDetails (this=0x941b5c8, entry=...) at ../../../knewstuff/knewstuff3/downloadwidget.cpp:377
#26 0x020af5d8 in KNS3::DownloadWidget::qt_metacall (this=0x946d560, _c=QMetaObject::InvokeMetaMethod, _id=32, _a=0xbfe0b498) at ./downloadwidget.moc:107
#27 0x079718ca in QMetaObject::metacall (object=0x946d560, cl=15249, idx=32, argv=0xbfe0b498) at kernel/qmetaobject.cpp:237
#28 0x079846ad in QMetaObject::activate (sender=0x9991670, m=0x2104df0, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3280
#29 0x020ac1e3 in KNS3::ItemsViewBaseDelegate::signalShowDetails (this=0x9991670, _t1=...) at moc_itemsviewbasedelegate.cpp:106
#30 0x020e3e73 in KNS3::ItemsViewBaseDelegate::slotDetailsClicked (this=0x9991670, index=...) at ../../../knewstuff/knewstuff3/ui/itemsviewbasedelegate.cpp:111
#31 0x020e4015 in KNS3::ItemsViewBaseDelegate::slotDetailsClicked (this=0x9991670) at ../../../knewstuff/knewstuff3/ui/itemsviewbasedelegate.cpp:101
#32 0x020ac35b in KNS3::ItemsViewBaseDelegate::qt_metacall (this=0x9991670, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xbfe0b6a8) at moc_itemsviewbasedelegate.cpp:94
#33 0x020dba52 in KNS3::ItemsViewDelegate::qt_metacall (this=0x9991670, _c=QMetaObject::InvokeMetaMethod, _id=20, _a=0xbfe0b6a8) at ./itemsviewdelegate.moc:64
#34 0x079718ca in QMetaObject::metacall (object=0x9991670, cl=15249, idx=20, argv=0xbfe0b6a8) at kernel/qmetaobject.cpp:237
#35 0x079846ad in QMetaObject::activate (sender=0x99b91e0, m=0x19b8704, local_signal_index=2, argv=0x0) at kernel/qobject.cpp:3280
#36 0x01795019 in QAbstractButton::clicked (this=0x99b91e0, _t1=false) at .moc/release-shared/moc_qabstractbutton.cpp:206
#37 0x01454ff9 in QAbstractButtonPrivate::emitClicked (this=0x99ac090) at widgets/qabstractbutton.cpp:546
#38 0x014566f4 in QAbstractButtonPrivate::click (this=0x99ac090) at widgets/qabstractbutton.cpp:539
#39 0x014569ae in QAbstractButton::mouseReleaseEvent (this=0x99b91e0, e=0xbfe0be00) at widgets/qabstractbutton.cpp:1121
#40 0x0153d54c in QToolButton::mouseReleaseEvent (this=0x99b91e0, e=0xbfe0be00) at widgets/qtoolbutton.cpp:721
#41 0x01084e08 in QWidget::event (this=0x99b91e0, event=0xbfe0be00) at kernel/qwidget.cpp:8187
#42 0x01454e9e in QAbstractButton::event (this=0x99b91e0, e=0x6) at widgets/qabstractbutton.cpp:1080
#43 0x015400ca in QToolButton::event (this=0x99b91e0, event=0xbfe0be00) at widgets/qtoolbutton.cpp:1163
#44 0x01026fdc in QApplicationPrivate::notify_helper (this=0x8be1268, receiver=0x99b91e0, e=0xbfe0be00) at kernel/qapplication.cpp:4396
#45 0x0102dc2e in QApplication::notify (this=0xbfe0d7ec, receiver=0x99b91e0, e=0xbfe0be00) at kernel/qapplication.cpp:3959
#46 0x00a7d2ca in KApplication::notify (this=0xbfe0d7ec, receiver=0x99b91e0, event=0xbfe0be00) at ../../kdeui/kernel/kapplication.cpp:311
#47 0x0796bb3b in QCoreApplication::notifyInternal (this=0xbfe0d7ec, receiver=0x99b91e0, event=0xbfe0be00) at kernel/qcoreapplication.cpp:732
#48 0x0102c094 in sendEvent (receiver=0x99b91e0, event=0xbfe0be00, alienWidget=0x99b91e0, nativeWidget=0xbfe0c67c, buttonDown=0x19c13c0, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#49 QApplicationPrivate::sendMouseEvent (receiver=0x99b91e0, event=0xbfe0be00, alienWidget=0x99b91e0, nativeWidget=0xbfe0c67c, buttonDown=0x19c13c0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3058
#50 0x010bad10 in QETWidget::translateMouseEvent (this=0xbfe0c67c, event=0xbfe0c31c) at kernel/qapplication_x11.cpp:4403
#51 0x010ba151 in QApplication::x11ProcessEvent (this=0xbfe0d7ec, event=0xbfe0c31c) at kernel/qapplication_x11.cpp:3414
#52 0x010e936a in x11EventSourceDispatch (s=0x8bd9cb0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#53 0x031dc855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#54 0x031e0668 in ?? () from /lib/libglib-2.0.so.0
#55 0x031e0848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#56 0x0799a565 in QEventDispatcherGlib::processEvents (this=0x8bcbf88, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#57 0x010e8be5 in QGuiEventDispatcherGlib::processEvents (this=0x8bcbf88, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#58 0x0796a609 in QEventLoop::processEvents (this=0xbfe0c610, flags=) at kernel/qeventloop.cpp:149
#59 0x0796aa8a in QEventLoop::exec (this=0xbfe0c610, flags=...) at kernel/qeventloop.cpp:201
#60 0x01591873 in QDialog::exec (this=0xbfe0c67c) at dialogs/qdialog.cpp:552
#61 0x0538e4e6 in SplashInstaller::slotNew (this=0x91e3978) at ../../../ksplash/kcm/installer.cpp:481
#62 0x05395836 in SplashInstaller::qt_metacall (this=0x91e3978, _c=QMetaObject::InvokeMetaMethod, _id=28, _a=0xbfe0c7e8) at ./installer.moc:84
#63 0x079718ca in QMetaObject::metacall (object=0x91e3978, cl=15249, idx=28, argv=0xbfe0c7e8) at kernel/qmetaobject.cpp:237
#64 0x079846ad in QMetaObject::activate (sender=0x9347e70, m=0x19b8704, local_signal_index=2, argv=0x0) at kernel/qobject.cpp:3280
#65 0x01795019 in QAbstractButton::clicked (this=0x9347e70, _t1=false) at .moc/release-shared/moc_qabstractbutton.cpp:206
#66 0x01454ff9 in QAbstractButtonPrivate::emitClicked (this=0x9393728) at widgets/qabstractbutton.cpp:546
#67 0x014566f4 in QAbstractButtonPrivate::click (this=0x9393728) at widgets/qabstractbutton.cpp:539
#68 0x014569ae in QAbstractButton::mouseReleaseEvent (this=0x9347e70, e=0xbfe0cf30) at widgets/qabstractbutton.cpp:1121
#69 0x01084e08 in QWidget::event (this=0x9347e70, event=0xbfe0cf30) at kernel/qwidget.cpp:8187
#70 0x01454e9e in QAbstractButton::event (this=0x9347e70, e=0x6) at widgets/qabstractbutton.cpp:1080
#71 0x01502c22 in QPushButton::event (this=0x9347e70, e=0xbfe0cf30) at widgets/qpushbutton.cpp:683
#72 0x01026fdc in QApplicationPrivate::notify_helper (this=0x8be1268, receiver=0x9347e70, e=0xbfe0cf30) at kernel/qapplication.cpp:4396
#73 0x0102dc2e in QApplication::notify (this=0xbfe0d7ec, receiver=0x9347e70, e=0xbfe0cf30) at kernel/qapplication.cpp:3959
#74 0x00a7d2ca in KApplication::notify (this=0xbfe0d7ec, receiver=0x9347e70, event=0xbfe0cf30) at ../../kdeui/kernel/kapplication.cpp:311
#75 0x0796bb3b in QCoreApplication::notifyInternal (this=0xbfe0d7ec, receiver=0x9347e70, event=0xbfe0cf30) at kernel/qcoreapplication.cpp:732
#76 0x0102c094 in sendEvent (receiver=0x9347e70, event=0xbfe0cf30, alienWidget=0x0, nativeWidget=0x9347e70, buttonDown=0x19c13c0, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#77 QApplicationPrivate::sendMouseEvent (receiver=0x9347e70, event=0xbfe0cf30, alienWidget=0x0, nativeWidget=0x9347e70, buttonDown=0x19c13c0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3058
#78 0x010bad10 in QETWidget::translateMouseEvent (this=0x9347e70, event=0xbfe0d44c) at kernel/qapplication_x11.cpp:4403
#79 0x010ba151 in QApplication::x11ProcessEvent (this=0xbfe0d7ec, event=0xbfe0d44c) at kernel/qapplication_x11.cpp:3414
#80 0x010e936a in x11EventSourceDispatch (s=0x8bd9cb0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#81 0x031dc855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#82 0x031e0668 in ?? () from /lib/libglib-2.0.so.0
#83 0x031e0848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#84 0x0799a565 in QEventDispatcherGlib::processEvents (this=0x8bcbf88, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#85 0x010e8be5 in QGuiEventDispatcherGlib::processEvents (this=0x8bcbf88, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#86 0x0796a609 in QEventLoop::processEvents (this=0xbfe0d744, flags=) at kernel/qeventloop.cpp:149
#87 0x0796aa8a in QEventLoop::exec (this=0xbfe0d744, flags=...) at kernel/qeventloop.cpp:201
#88 0x0796f00f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#89 0x01025e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#90 0x0805747e in main (argc=5, argv=0xbfe0d934) at ../../../systemsettings/app/main.cpp:49

Reported using DrKonqi
Comment 1 Andrew Stromme 2010-12-30 22:47:44 UTC
Created attachment 55393 [details]
New crash information added by DrKonqi

systemsettings (1.0) on KDE Platform 4.5.90 (4.6 RC1) using Qt 4.7.0

- What I was doing when the application crashed:

Browsing the KDM GHNS widget. It crashes 100% of the time if I click 'details' on the KStarboard KDM

I am also using Kubuntu 10.10 with the 4.4.90 packages.

-- Backtrace (Reduced):
#13 0x0783a645 in qt_assert (assertion=0x69ff1f "rating <= 100", file=0x69fbdc "/build/buildd/attica-0.2.0/lib/provider.cpp", line=601) at global/qglobal.cpp:2004
#14 0x00692908 in Attica::Provider::voteForContent(QString const&, unsigned int) () from /usr/lib/libattica.so.0
#15 0x01de1e98 in KNS3::AtticaProvider::vote (this=0x9613ad8, entry=..., rating=110) at ../../../knewstuff/knewstuff3/attica/atticaprovider.cpp:330
#16 0x01dba6be in KNS3::Engine::vote (this=0x9639490, entry=..., rating=110) at ../../../knewstuff/knewstuff3/core/engine.cpp:481
#17 0x01dd3bd3 in KNS3::EntryDetails::ratingChanged (this=0x96689a0, rating=11) at ../../../knewstuff/knewstuff3/ui/entrydetailsdialog.cpp:300
Comment 2 Nicolas L. 2011-01-02 00:14:10 UTC
for this bug that i can't reproduce because i can't see anything with more than 100% of rating. 

What about displaying at 100% ?


diff --git a/lib/provider.cpp b/lib/provider.cpp
index d9298a7..51e5f41 100644
--- a/lib/provider.cpp
+++ b/lib/provider.cpp
@@ -1100,7 +1100,10 @@ PostJob* Provider::voteForContent(const QString& contentId, uint rating)
     }
 
     // according to OCS API, the rating is 0..100
-    Q_ASSERT(rating <= 100);
+    if (rating > 100) {
+      rating = 100 ;
+    }
+
     StringMap postParameters;
     postParameters.insert(QLatin1String( "vote" ), QString::number(rating));
     qDebug() << "vote: " << QString::number(rating);
Comment 3 Nicolas L. 2011-01-03 23:57:44 UTC
commit fc00143ae0e57194eb2a3a58c87263d6969e36e3
branch master
Author: Nicolas Lécureuil <neoclust.kde@free.fr>
Date:   Mon Jan 3 23:58:09 2011 +0100

    Fix crash when the rating is superior to 100
    BUG: 261530

diff --git a/lib/provider.cpp b/lib/provider.cpp
index d9298a7..24994cf 100644
--- a/lib/provider.cpp
+++ b/lib/provider.cpp
@@ -1100,7 +1100,11 @@ PostJob* Provider::voteForContent(const QString& contentId, uint rating)
     }
 
     // according to OCS API, the rating is 0..100
-    Q_ASSERT(rating <= 100);
+    if (rating > 100) {
+      qWarning() << "Rating cannot be superior to 100, fallback to 100." ;
+      rating = 100 ;
+    }
+
     StringMap postParameters;
     postParameters.insert(QLatin1String( "vote" ), QString::number(rating));
     qDebug() << "vote: " << QString::number(rating);
Comment 4 Nicolas L. 2011-01-06 18:04:32 UTC
*** Bug 262277 has been marked as a duplicate of this bug. ***
Comment 5 mossad 2011-01-09 10:36:14 UTC
Created attachment 55760 [details]
New crash information added by DrKonqi

systemsettings (1.0) on KDE Platform 4.5.95 (4.6 RC2) using Qt 4.7.0

- What I was doing when the application crashed:
I tried to install new themes and splash screens. System settings crashed 4 times.

-- Backtrace (Reduced):
#13 0x0408e645 in qt_assert (assertion=0x342f1f "rating <= 100", file=0x342bdc "/build/buildd/attica-0.2.0/lib/provider.cpp", line=601) at global/qglobal.cpp:2004
#14 0x00335908 in Attica::Provider::voteForContent(QString const&, unsigned int) () from /usr/lib/libattica.so.0
#15 0x02ea4e98 in KNS3::AtticaProvider::vote (this=0xaa6d230, entry=..., rating=110) at ../../../knewstuff/knewstuff3/attica/atticaprovider.cpp:330
#16 0x02e7d6be in KNS3::Engine::vote (this=0xa144578, entry=..., rating=110) at ../../../knewstuff/knewstuff3/core/engine.cpp:481
#17 0x02e96bd3 in KNS3::EntryDetails::ratingChanged (this=0xaa8b2e0, rating=11) at ../../../knewstuff/knewstuff3/ui/entrydetailsdialog.cpp:300
Comment 6 Chaos A.D. 2011-01-27 00:08:35 UTC
Created attachment 56454 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.00 (4.6.0) using Qt 4.7.0

Same crash in KDE 4.6 released yesterday.
Shouldn't this fix be there?

-- Backtrace (Reduced):
#13 0xb645e645 in qt_assert (assertion=0xb373df1f "rating <= 100", file=0xb373dbdc "/build/buildd/attica-0.2.0/lib/provider.cpp", line=601) at global/qglobal.cpp:2004
#14 0xb3730908 in Attica::Provider::voteForContent(QString const&, unsigned int) () from /usr/lib/libattica.so.0
#15 0xb6e05eb8 in KNS3::AtticaProvider::vote (this=0xaa06570, entry=..., rating=120) at ../../../knewstuff/knewstuff3/attica/atticaprovider.cpp:330
#16 0xb6dde6be in KNS3::Engine::vote (this=0xacc4a80, entry=..., rating=120) at ../../../knewstuff/knewstuff3/core/engine.cpp:481
#17 0xb6df7bf3 in KNS3::EntryDetails::ratingChanged (this=0xaecc8c8, rating=12) at ../../../knewstuff/knewstuff3/ui/entrydetailsdialog.cpp:300
Comment 7 Dario Andres 2011-01-27 00:10:53 UTC
[Comment from a bug triager]
The bug and the fix are in "libattica", may be your version of that library is not the latest. (or there wasn't a release including the fix)
Comment 8 Dario Andres 2011-01-29 14:00:30 UTC
*** Bug 264511 has been marked as a duplicate of this bug. ***
Comment 9 Dario Andres 2011-01-30 02:52:45 UTC
*** Bug 264790 has been marked as a duplicate of this bug. ***
Comment 10 Dario Andres 2011-02-05 00:32:46 UTC
*** Bug 265458 has been marked as a duplicate of this bug. ***
Comment 11 Christoph Feck 2011-02-08 17:29:05 UTC
*** Bug 265788 has been marked as a duplicate of this bug. ***
Comment 12 HarrisP 2011-02-08 19:54:18 UTC
Created attachment 56996 [details]
New crash information added by DrKonqi

systemsettings (1.0) on KDE Platform 4.6.00 (4.6.0) "release 381" using Qt 4.7.1

- What I was doing when the application crashed:

just previewing some icons sets and suddenly the preview crashed

-- Backtrace (Reduced):
#11 0x00007f06ebbaec0a in qt_assert (assertion=0x2ae3 <Address 0x2ae3 out of bounds>, file=0x6 <Address 0x6 out of bounds>, line=-1) at global/qglobal.cpp:2027
#12 0x00007f06ea8fa288 in Attica::Provider::voteForContent(QString const&, unsigned int) () from /usr/lib64/libattica.so.0
#13 0x00007f06d9f58603 in KNS3::AtticaProvider::vote (this=0xe09a80, entry=<value optimized out>, rating=<value optimized out>)
    at /usr/src/debug/kdelibs-4.6.0/knewstuff/knewstuff3/attica/atticaprovider.cpp:330
#14 0x00007f06d9f6673d in KNS3::Engine::vote (this=<value optimized out>, entry=..., rating=110) at /usr/src/debug/kdelibs-4.6.0/knewstuff/knewstuff3/core/engine.cpp:481
#15 0x00007f06d9f667d2 in KNS3::EntryDetails::ratingChanged (this=0xb905d0, rating=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/knewstuff/knewstuff3/ui/entrydetailsdialog.cpp:300
Comment 13 Christoph Feck 2011-02-10 21:01:22 UTC
*** Bug 266019 has been marked as a duplicate of this bug. ***
Comment 14 Dario Andres 2011-02-18 14:57:18 UTC
*** Bug 266348 has been marked as a duplicate of this bug. ***
Comment 15 Sal Colon 2011-02-23 22:06:57 UTC
Created attachment 57484 [details]
New crash information added by DrKonqi

systemsettings (1.0) on KDE Platform 4.6.00 (4.6.0) using Qt 4.7.0

- What I was doing when the application crashed: I was looking through the different themes, i clicked to preview the slimglow, then it crashed. I had just enabled desktop effects which had crashed a little while earlier. It seems like there is a memory leak somewhere.

-- Backtrace (Reduced):
#11 0x00007f78ac4dc0a8 in Attica::Provider::voteForContent(QString const&, unsigned int) () from /usr/lib/libattica.so.0
#12 0x00007f7895284c20 in KNS3::AtticaProvider::vote (this=0x202a780, entry=<value optimized out>, rating=110) at ../../../knewstuff/knewstuff3/attica/atticaprovider.cpp:330
#13 0x00007f7895260ae6 in KNS3::Engine::vote (this=<value optimized out>, entry=..., rating=110) at ../../../knewstuff/knewstuff3/core/engine.cpp:481
#14 0x00007f7895277f1b in KNS3::EntryDetails::ratingChanged (this=0x231d0f0, rating=55) at ../../../knewstuff/knewstuff3/ui/entrydetailsdialog.cpp:300
#15 0x00007f789527a74b in KNS3::EntryDetails::qt_metacall (this=0x231d0f0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffdd36d310) at ./entrydetailsdialog.moc:98
Comment 16 Dario Andres 2011-03-05 12:03:17 UTC
*** Bug 267452 has been marked as a duplicate of this bug. ***
Comment 17 Dario Andres 2011-03-13 18:39:52 UTC
*** Bug 268392 has been marked as a duplicate of this bug. ***
Comment 18 linuxg33k4life 2011-03-14 00:00:59 UTC
Created attachment 57944 [details]
New crash information added by DrKonqi

systemsettings (1.0) on KDE Platform 4.6.00 (4.6.0) "release 6" using Qt 4.7.1

- What I was doing when the application crashed:
Browsing for a new icon theme, and when I selected details on the Crystal Project, System Settings crashed.

-- Backtrace (Reduced):
#11 0x00007fbf40d62c4a in qt_assert (assertion=0x49e0 <Address 0x49e0 out of bounds>, file=0x6 <Address 0x6 out of bounds>, line=-1) at global/qglobal.cpp:2027
#12 0x00007fbf3faa2618 in Attica::Provider::voteForContent(QString const&, unsigned int) () from /usr/lib64/libattica.so.0
#13 0x00007fbf2ef95603 in KNS3::AtticaProvider::vote (this=0x8fd330, entry=<value optimized out>, rating=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/knewstuff/knewstuff3/attica/atticaprovider.cpp:330
#14 0x00007fbf2efa34cd in KNS3::Engine::vote (this=<value optimized out>, entry=..., rating=110) at /usr/src/debug/kdelibs-4.6.0/knewstuff/knewstuff3/core/engine.cpp:481
#15 0x00007fbf2efa3562 in KNS3::EntryDetails::ratingChanged (this=0xaf6100, rating=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/knewstuff/knewstuff3/ui/entrydetailsdialog.cpp:300
Comment 19 Christoph Feck 2011-03-16 22:15:56 UTC
*** Bug 268676 has been marked as a duplicate of this bug. ***
Comment 20 Christoph Feck 2011-03-30 19:34:52 UTC
*** Bug 269521 has been marked as a duplicate of this bug. ***
Comment 21 Christoph Feck 2011-03-31 23:13:11 UTC
*** Bug 269062 has been marked as a duplicate of this bug. ***
Comment 22 Christoph Feck 2011-04-04 21:00:15 UTC
*** Bug 270070 has been marked as a duplicate of this bug. ***
Comment 23 Alexandr 2011-04-05 01:14:32 UTC
Created attachment 58583 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.1 (4.6.1) using Qt 4.7.2

- What I was doing when the application crashed:

plasma-workspace crashed when i browsing new widgets and looked into details of one of sensors widgets

-- Backtrace (Reduced):
#11 0x00007f7ce349cac0 in Attica::Provider::voteForContent(QString const&, unsigned int) () from /usr/lib64/libattica.so.0
#12 0x00007f7cd7d27c50 in KNS3::AtticaProvider::vote(KNS3::EntryInternal const&, unsigned int) () from /usr/lib64/libknewstuff3.so.4
#13 0x00007f7cd7d03c92 in KNS3::Engine::vote(KNS3::EntryInternal const&, unsigned int) () from /usr/lib64/libknewstuff3.so.4
#14 0x00007f7cd7d1bbb2 in KNS3::EntryDetails::ratingChanged(unsigned int) () from /usr/lib64/libknewstuff3.so.4
#15 0x00007f7cd7d1e1fb in KNS3::EntryDetails::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libknewstuff3.so.4
Comment 24 Dario Andres 2011-04-09 13:54:12 UTC
*** Bug 270488 has been marked as a duplicate of this bug. ***
Comment 25 Dario Andres 2011-04-10 22:48:06 UTC
*** Bug 270619 has been marked as a duplicate of this bug. ***
Comment 26 Dario Andres 2011-04-16 00:13:26 UTC
*** Bug 271033 has been marked as a duplicate of this bug. ***
Comment 27 Dario Andres 2011-05-01 14:32:30 UTC
*** Bug 272113 has been marked as a duplicate of this bug. ***
Comment 28 Dario Andres 2011-05-01 14:32:33 UTC
*** Bug 271881 has been marked as a duplicate of this bug. ***
Comment 29 Dario Andres 2011-05-07 14:07:28 UTC
*** Bug 272478 has been marked as a duplicate of this bug. ***
Comment 30 Dario Andres 2011-05-29 15:20:40 UTC
*** Bug 274366 has been marked as a duplicate of this bug. ***
Comment 31 Beat Wolf 2011-06-03 15:36:43 UTC
*** Bug 274810 has been marked as a duplicate of this bug. ***
Comment 32 Beat Wolf 2011-06-03 15:37:23 UTC
The last duplicate suggests that this bug is still present in 4.6.2
Comment 33 Alexey Shildyakov 2011-06-06 13:12:09 UTC
To Beat Wolf: No. The problem is in libattica. Update libattica. I test it now with the latest dev libattica. And it works. So, this bug is really resolved.
Comment 34 Sebadamus 2011-07-07 19:15:15 UTC
Created attachment 61692 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.00 (4.6.0) "release 6" using Qt 4.7.1

- What I was doing when the application crashed: searching to add a widget, I found one, then I clicked "details" button and it crashed.   Usually happens... but not always.

-- Backtrace (Reduced):
#11 0x00007f95ca04fc4a in qt_assert (assertion=0xfa9 <Address 0xfa9 out of bounds>, file=0x6 <Address 0x6 out of bounds>, line=-1) at global/qglobal.cpp:2027
#12 0x00007f95c8219618 in Attica::Provider::voteForContent (this=0x1b72f78, contentId=..., rating=110) at /usr/src/debug/attica-0.2.0/lib/provider.cpp:601
#13 0x00007f95be108603 in KNS3::AtticaProvider::vote (this=0x1b72f30, entry=<value optimized out>, rating=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/knewstuff/knewstuff3/attica/atticaprovider.cpp:330
#14 0x00007f95be1164cd in KNS3::Engine::vote (this=<value optimized out>, entry=..., rating=110) at /usr/src/debug/kdelibs-4.6.0/knewstuff/knewstuff3/core/engine.cpp:481
#15 0x00007f95be116562 in KNS3::EntryDetails::ratingChanged (this=0x1bc0210, rating=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/knewstuff/knewstuff3/ui/entrydetailsdialog.cpp:300
Comment 35 Christoph Feck 2011-07-16 03:33:06 UTC
*** Bug 277851 has been marked as a duplicate of this bug. ***
Comment 36 507laird 2011-07-18 17:11:54 UTC
Hello Christoph Feck:

                                      I want to say thank you for your 
responding to my bug-control request.. with a working solution no less.

John Ellis




On 07/15/2011 11:34 PM, Christoph Feck wrote:
> https://bugs.kde.org/show_bug.cgi?id=261530
>
>
> Christoph Feck<christoph@maxiom.de>  changed:
>
>             What    |Removed                     |Added
> ----------------------------------------------------------------------------
>            Component|knewstuff                   |general
>              Version|SVN                         |unspecified
>              Product|kdelibs                     |attica
>
>
>
>
Comment 37 Christoph Feck 2011-07-18 19:43:04 UTC
*** Bug 277849 has been marked as a duplicate of this bug. ***
Comment 38 Oldřich Jedlička 2011-08-13 15:08:01 UTC
I don't think the problem is in libattica. The first problem is that there is a voting while I haven't given any vote. I've updated the libattica to latest dev, the browsing doesn't crash, but there is still a message, which thanks me for my vote. I haven't made any vode, I've clicked the "Details" button.
Comment 39 Christoph Feck 2011-08-21 02:29:59 UTC
*** Bug 280492 has been marked as a duplicate of this bug. ***
Comment 40 Oldřich Jedlička 2011-08-21 19:16:45 UTC
I've tracked the problem down. Everything is in the backtrace (see below for explanation). Please note that normally the EntryInternal.rating() has rating from web - 0-100.

1. KNS3::DownloadWidgetPrivate::slotShowDetails() - Details button has been selected
2. KNS3::EntryDetails::setEntry() calls entryChanged()
3. KNS3::EntryDetails::entryChanged() gets the rating from EntryInternal (0-100), subtracts 20 and divides it by 6 and sends it to KRatingWidget.
4. KNS3::EntryDetails::ratingChanged() is called with the magic rating number, which is sent to libattica.

So the libattica isn't wrong, it does great job (and doesn't need updated). KNewStuff3 is wrong - it makes voting from some magic number, but it should just show it only on KRatingWidget.
Comment 41 Oldřich Jedlička 2011-08-23 16:36:47 UTC
I've created review #102416 with patch that fixes the problem on the place where it really happened. Can anybody change the "Product" field to kdelibs? The problem is in knewstuff3.
Comment 42 Oldřich Jedlička 2011-08-23 16:37:54 UTC
Created attachment 63076 [details]
Patch to fix the voting problem
Comment 43 Jeremy Whiting 2011-08-24 02:42:08 UTC
Git commit d2dd87af8b6bd2146b4e7434625738687a2130f8 by Jeremy Whiting.
Committed on 24/08/2011 at 04:36.
Pushed by whiting into branch 'frameworks'.

Fix rating in knewstuff3
BUG: 261530
REVIEW: 102416
(cherry picked from commit 4da76baa3261ca2d98a495eeecc1d1c386f2e8f2)

M  +4    -2    knewstuff/knewstuff3/ui/entrydetailsdialog.cpp

http://commits.kde.org/kdelibs/d2dd87af8b6bd2146b4e7434625738687a2130f8
Comment 44 Jeremy Whiting 2011-08-26 15:03:43 UTC
Git commit 37a5ca1ec9565f6b45de7c5b12bea4bcec8d7281 by Jeremy Whiting.
Committed on 24/08/2011 at 04:36.
Pushed by whiting into branch 'KDE/4.7'.

Fix rating in knewstuff3
BUG: 261530
REVIEW: 102416

M  +4    -2    knewstuff/knewstuff3/ui/entrydetailsdialog.cpp

http://commits.kde.org/kdelibs/37a5ca1ec9565f6b45de7c5b12bea4bcec8d7281
Comment 45 Dario Andres 2011-08-28 13:11:35 UTC
*** Bug 280917 has been marked as a duplicate of this bug. ***
Comment 46 Christoph Feck 2011-09-08 19:36:57 UTC
*** Bug 281639 has been marked as a duplicate of this bug. ***
Comment 47 tauraniaakant 2011-09-21 20:26:55 UTC
Created attachment 63831 [details]
New crash information added by DrKonqi

systemsettings (1.0) on KDE Platform 4.6.00 (4.6.0) "release 6" using Qt 4.7.1

- What I was doing when the application crashed:
Browsing the Get More Themes with the KStarBoard recently installed. I clicked "Details" or "Install" for a theme and the crash occured.

-- Backtrace (Reduced):
#11 0x00007f7a22a24c4a in qt_assert (assertion=0x5464 <Address 0x5464 out of bounds>, file=0x6 <Address 0x6 out of bounds>, line=-1) at global/qglobal.cpp:2027
#12 0x00007f7a21764618 in Attica::Provider::voteForContent (this=0x12258f8, contentId=..., rating=110) at /usr/src/debug/attica-0.2.0/lib/provider.cpp:601
#13 0x00007f7a0dcb0603 in KNS3::AtticaProvider::vote (this=0x12258b0, entry=<value optimized out>, rating=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/knewstuff/knewstuff3/attica/atticaprovider.cpp:330
#14 0x00007f7a0dcbe4cd in KNS3::Engine::vote (this=<value optimized out>, entry=..., rating=110) at /usr/src/debug/kdelibs-4.6.0/knewstuff/knewstuff3/core/engine.cpp:481
#15 0x00007f7a0dcbe562 in KNS3::EntryDetails::ratingChanged (this=0xe014f0, rating=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/knewstuff/knewstuff3/ui/entrydetailsdialog.cpp:300
Comment 48 Dario Andres 2011-10-01 13:23:08 UTC
*** Bug 283110 has been marked as a duplicate of this bug. ***
Comment 49 Christoph Feck 2011-10-27 21:12:53 UTC
*** Bug 285136 has been marked as a duplicate of this bug. ***
Comment 50 Beat Wolf 2011-11-22 21:01:27 UTC
*** Bug 285446 has been marked as a duplicate of this bug. ***
Comment 51 Christoph Feck 2011-11-29 00:48:08 UTC
*** Bug 286154 has been marked as a duplicate of this bug. ***
Comment 52 Christoph Feck 2012-01-07 02:13:28 UTC
*** Bug 290821 has been marked as a duplicate of this bug. ***
Comment 53 Jekyll Wu 2012-01-29 16:40:17 UTC
*** Bug 292809 has been marked as a duplicate of this bug. ***