Bug 261389 - Crash on start of application
Summary: Crash on start of application
Status: RESOLVED DUPLICATE of bug 232068
Alias: None
Product: phonon-backend-gstreamer
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Harald Sitter
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-27 16:29 UTC by Dieter Roemer
Modified: 2011-04-27 21:18 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dieter Roemer 2010-12-27 16:29:09 UTC
Application: digikam (1.2.0)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-27-generic x86_64
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
Application crashed during start up configuration, when I used the software first time

 -- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f24f46927e0 (LWP 13304))]

Thread 9 (Thread 0x7f24dac38700 (LWP 13306)):
#0  0x00007fffc3fff904 in clock_gettime ()
#1  0x00007f24e5de609f in *__GI_clock_gettime (clock_id=1, tp=0x7f24dac37a80) at ../sysdeps/unix/clock_gettime.c:100
#2  0x00007f24ede5699f in qt_gettime () at kernel/qcore_unix.cpp:111
#3  0x00007f24ede5b6ad in QTimerInfoList::updateCurrentTime (this=0x1) at kernel/qeventdispatcher_unix.cpp:340
#4  0x00007f24ede5b6d5 in QTimerInfoList::timerWait (this=0x1, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#5  0x00007f24ede5975d in timerSourcePrepareHelper (src=<value optimized out>, timeout=0x7f24dac37b9c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x00007f24ede59805 in timerSourcePrepare (source=0x1, timeout=0x7f24dac37a80) at kernel/qeventdispatcher_glib.cpp:169
#7  0x00007f24ea0cfeb1 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0x00007f24ea0d0318 in ?? () from /lib/libglib-2.0.so.0
#9  0x00007f24ea0d08fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0x00007f24ede59566 in QEventDispatcherGlib::processEvents (this=0x1de5e30, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#11 0x00007f24ede2e992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#12 0x00007f24ede2ed6c in QEventLoop::exec (this=0x7f24dac37d30, flags=) at kernel/qeventloop.cpp:201
#13 0x00007f24edd38d59 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#14 0x00007f24ede0f178 in QInotifyFileSystemWatcherEngine::run (this=0x1e08d30) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x00007f24edd3b775 in QThreadPrivate::start (arg=0x1e08d30) at thread/qthread_unix.cpp:248
#16 0x00007f24edaab9ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#17 0x00007f24ecde170d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#18 0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f24da08e700 (LWP 18207)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f24edd3c72b in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x1c51540, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1c51540, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00000000006e1d9b in Digikam::ScanController::run (this=0x1c83520) at /build/buildd/digikam-1.2.0/digikam/scancontroller.cpp:516
#4  0x00007f24edd3b775 in QThreadPrivate::start (arg=0x1c83520) at thread/qthread_unix.cpp:248
#5  0x00007f24edaab9ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#6  0x00007f24ecde170d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f24d9680700 (LWP 18209)):
#0  0x00007fffc3fff904 in clock_gettime ()
#1  0x00007f24e5de609f in *__GI_clock_gettime (clock_id=1, tp=0x7f24d967fac0) at ../sysdeps/unix/clock_gettime.c:100
#2  0x00007f24ede5699f in qt_gettime () at kernel/qcore_unix.cpp:111
#3  0x00007f24ede5b6ad in QTimerInfoList::updateCurrentTime (this=0x1) at kernel/qeventdispatcher_unix.cpp:340
#4  0x00007f24ede5b6d5 in QTimerInfoList::timerWait (this=0x1, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#5  0x00007f24ede5975d in timerSourcePrepareHelper (src=<value optimized out>, timeout=0x7f24d967fbdc) at kernel/qeventdispatcher_glib.cpp:136
#6  0x00007f24ede59805 in timerSourcePrepare (source=0x1, timeout=0x7f24d967fac0) at kernel/qeventdispatcher_glib.cpp:169
#7  0x00007f24ea0cfeb1 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0x00007f24ea0d0318 in ?? () from /lib/libglib-2.0.so.0
#9  0x00007f24ea0d08fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0x00007f24ede59566 in QEventDispatcherGlib::processEvents (this=0x1c56060, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#11 0x00007f24ede2e992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#12 0x00007f24ede2ed6c in QEventLoop::exec (this=0x7f24d967fd70, flags=) at kernel/qeventloop.cpp:201
#13 0x00007f24edd38d59 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#14 0x00007f24edd3b775 in QThreadPrivate::start (arg=0x1a1a000) at thread/qthread_unix.cpp:248
#15 0x00007f24edaab9ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#16 0x00007f24ecde170d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#17 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f24d8e7f700 (LWP 18210)):
#0  0x00007fffc3fff904 in clock_gettime ()
#1  0x00007f24e5de609f in *__GI_clock_gettime (clock_id=1, tp=0x7f24d8e7eac0) at ../sysdeps/unix/clock_gettime.c:100
#2  0x00007f24ede5699f in qt_gettime () at kernel/qcore_unix.cpp:111
#3  0x00007f24ede5b6ad in QTimerInfoList::updateCurrentTime (this=0x1) at kernel/qeventdispatcher_unix.cpp:340
#4  0x00007f24ede5b6d5 in QTimerInfoList::timerWait (this=0x1, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#5  0x00007f24ede5975d in timerSourcePrepareHelper (src=<value optimized out>, timeout=0x7f24d8e7ebdc) at kernel/qeventdispatcher_glib.cpp:136
#6  0x00007f24ede59805 in timerSourcePrepare (source=0x1, timeout=0x7f24d8e7eac0) at kernel/qeventdispatcher_glib.cpp:169
#7  0x00007f24ea0cfeb1 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0x00007f24ea0d0318 in ?? () from /lib/libglib-2.0.so.0
#9  0x00007f24ea0d08fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0x00007f24ede59566 in QEventDispatcherGlib::processEvents (this=0x1cb0370, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#11 0x00007f24ede2e992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#12 0x00007f24ede2ed6c in QEventLoop::exec (this=0x7f24d8e7ed70, flags=) at kernel/qeventloop.cpp:201
#13 0x00007f24edd38d59 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#14 0x00007f24edd3b775 in QThreadPrivate::start (arg=0x1c117b0) at thread/qthread_unix.cpp:248
#15 0x00007f24edaab9ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#16 0x00007f24ecde170d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#17 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f24d3fff700 (LWP 18211)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f24edd3c72b in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x1cb2c48, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1cb2c48, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f24f1695532 in Digikam::LoadSaveThread::run (this=0x1cb2c30) at /build/buildd/digikam-1.2.0/libs/threadimageio/loadsavethread.cpp:131
#4  0x00007f24edd3b775 in QThreadPrivate::start (arg=0x1cb2c30) at thread/qthread_unix.cpp:248
#5  0x00007f24edaab9ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#6  0x00007f24ecde170d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f24d37fe700 (LWP 18212)):
#0  0x00007fffc3fff904 in clock_gettime ()
#1  0x00007f24e5de609f in *__GI_clock_gettime (clock_id=1, tp=0x7f24d37fdac0) at ../sysdeps/unix/clock_gettime.c:100
#2  0x00007f24ede5699f in qt_gettime () at kernel/qcore_unix.cpp:111
#3  0x00007f24ede5b6ad in QTimerInfoList::updateCurrentTime (this=0x1) at kernel/qeventdispatcher_unix.cpp:340
#4  0x00007f24ede5b6d5 in QTimerInfoList::timerWait (this=0x1, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#5  0x00007f24ede5975d in timerSourcePrepareHelper (src=<value optimized out>, timeout=0x7f24d37fdbdc) at kernel/qeventdispatcher_glib.cpp:136
#6  0x00007f24ede59805 in timerSourcePrepare (source=0x1, timeout=0x7f24d37fdac0) at kernel/qeventdispatcher_glib.cpp:169
#7  0x00007f24ea0cfeb1 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0x00007f24ea0d0318 in ?? () from /lib/libglib-2.0.so.0
#9  0x00007f24ea0d08fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0x00007f24ede59566 in QEventDispatcherGlib::processEvents (this=0x1c46160, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#11 0x00007f24ede2e992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#12 0x00007f24ede2ed6c in QEventLoop::exec (this=0x7f24d37fdd70, flags=) at kernel/qeventloop.cpp:201
#13 0x00007f24edd38d59 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#14 0x00007f24edd3b775 in QThreadPrivate::start (arg=0x1c470a0) at thread/qthread_unix.cpp:248
#15 0x00007f24edaab9ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#16 0x00007f24ecde170d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#17 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f24d2ffd700 (LWP 18213)):
#0  0x00007fffc3fff904 in clock_gettime ()
#1  0x00007f24e5de609f in *__GI_clock_gettime (clock_id=1, tp=0x7f24d2ffcac0) at ../sysdeps/unix/clock_gettime.c:100
#2  0x00007f24ede5699f in qt_gettime () at kernel/qcore_unix.cpp:111
#3  0x00007f24ede5b6ad in QTimerInfoList::updateCurrentTime (this=0x1) at kernel/qeventdispatcher_unix.cpp:340
#4  0x00007f24ede5b6d5 in QTimerInfoList::timerWait (this=0x1, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#5  0x00007f24ede5975d in timerSourcePrepareHelper (src=<value optimized out>, timeout=0x7f24d2ffcbdc) at kernel/qeventdispatcher_glib.cpp:136
#6  0x00007f24ede59805 in timerSourcePrepare (source=0x1, timeout=0x7f24d2ffcac0) at kernel/qeventdispatcher_glib.cpp:169
#7  0x00007f24ea0cfeb1 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0x00007f24ea0d0318 in ?? () from /lib/libglib-2.0.so.0
#9  0x00007f24ea0d08fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0x00007f24ede59566 in QEventDispatcherGlib::processEvents (this=0x1a13d90, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#11 0x00007f24ede2e992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#12 0x00007f24ede2ed6c in QEventLoop::exec (this=0x7f24d2ffcd70, flags=) at kernel/qeventloop.cpp:201
#13 0x00007f24edd38d59 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#14 0x00007f24edd3b775 in QThreadPrivate::start (arg=0x1c346c0) at thread/qthread_unix.cpp:248
#15 0x00007f24edaab9ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#16 0x00007f24ecde170d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#17 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f24ca6f4700 (LWP 18218)):
#0  0x00007f24ecdd4f93 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f24cfa3f41f in ?? () from /usr/lib/libpulse.so.0
#2  0x00007f24cfa2ed86 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#3  0x00007f24cfa30809 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#4  0x00007f24cfa308c0 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#5  0x00007f24cfa3f21b in ?? () from /usr/lib/libpulse.so.0
#6  0x00007f24cf7fe0e8 in ?? () from /usr/lib/libpulsecommon-0.9.21.so
#7  0x00007f24edaab9ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#8  0x00007f24ecde170d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f24f46927e0 (LWP 13304)):
[KCrash Handler]
#5  0x00007f24d162de49 in ?? () from /usr/lib/libasound.so.2
#6  0x00007f24d15f0b15 in snd_pcm_close () from /usr/lib/libasound.so.2
#7  0x00007f24cfe616ff in ?? () from /usr/lib/gstreamer-0.10/libgstalsa.so
#8  0x00007f24d03933c6 in ?? () from /usr/lib/libgstaudio-0.10.so.0
#9  0x00007f24d0386ecb in gst_ring_buffer_close_device () from /usr/lib/libgstaudio-0.10.so.0
#10 0x00007f24d038eca6 in ?? () from /usr/lib/libgstaudio-0.10.so.0
#11 0x00007f24d0c3218c in gst_element_change_state (element=0x236f790, transition=0) at gstelement.c:2548
#12 0x00007f24d0c351bb in gst_element_set_state_func (element=0x236d600, state=GST_STATE_NULL) at gstelement.c:2504
#13 0x00007f24d13759aa in Phonon::Gstreamer::AudioOutput::setOutputDevice (this=0x2366a30, newDevice=<value optimized out>) at ../../gstreamer/audiooutput.cpp:217
#14 0x00007f24f403f010 in callSetOutputDevice (this=0x23608c0) at ../3rdparty/phonon/phonon/audiooutput.cpp:67
#15 Phonon::AudioOutputPrivate::setupBackendObject (this=0x23608c0) at ../3rdparty/phonon/phonon/audiooutput.cpp:281
#16 0x00007f24f403f6f0 in Phonon::AudioOutputPrivate::createBackendObject (this=0x23608c0) at ../3rdparty/phonon/phonon/audiooutput.cpp:124
#17 0x00007f24f403beea in Phonon::AudioOutputPrivate::init (this=0x23608c0, c=<value optimized out>) at ../3rdparty/phonon/phonon/audiooutput.cpp:106
#18 0x00007f24f403c59d in AudioOutput (this=0x2360890, category=Phonon::VideoCategory, parent=0x2360350) at ../3rdparty/phonon/phonon/audiooutput.cpp:76
#19 0x00007f24f405e862 in Phonon::VideoPlayerPrivate::init (this=0x235fa30, q=0x2360350, category=Phonon::VideoCategory) at ../3rdparty/phonon/phonon/videoplayer.cpp:59
#20 0x00007f24f405eb73 in VideoPlayer (this=0x2360350, category=Phonon::VideoCategory, parent=<value optimized out>) at ../3rdparty/phonon/phonon/videoplayer.cpp:75
#21 0x00000000006d106c in MediaPlayerView (this=0x235d4d0, parent=<value optimized out>) at /build/buildd/digikam-1.2.0/digikam/mediaplayerview.cpp:124
#22 0x0000000000667ae3 in AlbumWidgetStack (this=0x1c359c0, parent=<value optimized out>) at /build/buildd/digikam-1.2.0/digikam/albumwidgetstack.cpp:105
#23 0x000000000069c6e5 in DigikamView (this=0x1d68760, parent=0x1c95fd0, modelCollection=0x1846730) at /build/buildd/digikam-1.2.0/digikam/digikamview.cpp:169
#24 0x00000000006827bd in Digikam::DigikamApp::setupView (this=0x1c95fd0) at /build/buildd/digikam-1.2.0/digikam/digikamapp.cpp:478
#25 0x0000000000690980 in DigikamApp (this=0x1c95fd0, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /build/buildd/digikam-1.2.0/digikam/digikamapp.cpp:230
#26 0x000000000077f817 in main (argc=<value optimized out>, argv=<value optimized out>) at /build/buildd/digikam-1.2.0/digikam/main.cpp:170

Possible duplicates by query: bug 261363, bug 259818, bug 257346, bug 255462, bug 255320.

Reported using DrKonqi
Comment 1 Pino Toscano 2010-12-27 18:43:06 UTC

*** This bug has been marked as a duplicate of bug 232068 ***
Comment 2 Myriam Schweingruber 2011-04-27 21:18:48 UTC
reassigning to the new bugzilla product for better bug tracing of the various backends. Sorry for the noise.