Bug 261278 - Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
Summary: Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
Status: RESOLVED DUPLICATE of bug 253795
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kshareddatacache (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-26 10:16 UTC by Jorma Hytonen
Modified: 2010-12-27 01:00 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jorma Hytonen 2010-12-26 10:16:52 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-23-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
Try open KMenu -> Applications -> Multimedia
- Unusual behavior I noticed:
Plasma Workspace crash and all plasmoids missing

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7751720 (LWP 1912))]

Thread 2 (Thread 0xaf434b70 (LWP 1916)):
#0  0x00ec7416 in __kernel_vsyscall ()
#1  0x00274df6 in poll () from /lib/libc.so.6
#2  0x04e08a1b in g_poll () from /lib/libglib-2.0.so.0
#3  0x04dfb43c in ?? () from /lib/libglib-2.0.so.0
#4  0x04dfb848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x042dc59f in QEventDispatcherGlib::processEvents (this=0x9d325a0, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#6  0x042ac609 in QEventLoop::processEvents (this=0xaf434280, flags=) at kernel/qeventloop.cpp:149
#7  0x042aca8a in QEventLoop::exec (this=0xaf434280, flags=...) at kernel/qeventloop.cpp:201
#8  0x041a8b7e in QThread::exec (this=0x9d9bf90) at thread/qthread.cpp:490
#9  0x0428b35b in QInotifyFileSystemWatcherEngine::run (this=0x9d9bf90) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x041abdf9 in QThreadPrivate::start (arg=0x9d9bf90) at thread/qthread_unix.cpp:266
#11 0x00721cc9 in start_thread () from /lib/libpthread.so.0
#12 0x0028369e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb7751720 (LWP 1912)):
[KCrash Handler]
#7  0x009ff728 in SharedMemory::removeEntry (this=0xb69f3000, index=623) at ../../kdecore/util/kshareddatacache.cpp:1151
#8  0x00a00b34 in KSharedDataCache::insert (this=0x9745770, key=..., data=...) at ../../kdecore/util/kshareddatacache.cpp:1273
#9  0x011563f3 in KIconLoaderPrivate::insertCachedPixmapWithPath (this=0x9742a28, key=..., data=..., path=...) at ../../kdeui/icons/kiconloader.cpp:835
#10 0x0115e177 in KIconLoader::loadIcon (this=0x9741b70, _name=..., group=KIconLoader::Desktop, size=32, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1306
#11 0x011544d6 in KIconEngine::paint (this=0xa3e8658, painter=0xbff0904c, rect=..., mode=QIcon::Normal, state=QIcon::Off) at ../../kdeui/icons/kiconengine.cpp:83
#12 0x01f74be4 in QIcon::paint (this=0xbff08c1c, painter=0xbff0904c, rect=..., alignment=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:722
#13 0x00b76fdc in Plasma::Delegate::paint (this=0xa19fdd0, painter=0xbff0904c, option=..., index=...) at ../../plasma/delegate.cpp:261
#14 0x01c93dd7 in Kickoff::ItemDelegate::paint (this=0xa19fdd0, painter=0xbff0904c, option=..., index=...) at ../../../../../plasma/desktop/applets/kickoff/ui/itemdelegate.cpp:47
#15 0x01c8eb60 in Kickoff::FlipScrollView::paintItems (this=0xa19f048, painter=..., event=0xbff09884, root=...) at ../../../../../plasma/desktop/applets/kickoff/ui/flipscrollview.cpp:578
#16 0x01c8f50e in Kickoff::FlipScrollView::paintEvent (this=0xa19f048, event=0xbff09884) at ../../../../../plasma/desktop/applets/kickoff/ui/flipscrollview.cpp:631
#17 0x01f0dcc6 in QWidget::event (this=0xa19f048, event=0xbff09884) at kernel/qwidget.cpp:8333
#18 0x0232f763 in QFrame::event (this=0xa19f048, e=0xbff09884) at widgets/qframe.cpp:557
#19 0x023cca82 in QAbstractScrollArea::viewportEvent (this=0x1000, e=0xba9fb4b0) at widgets/qabstractscrollarea.cpp:1043
#20 0x024890f7 in QAbstractItemView::viewportEvent (this=0xa19f048, event=0xbff09884) at itemviews/qabstractitemview.cpp:1619
#21 0x023cf4d5 in viewportEvent (this=0xa1a0d58, o=0xa1a3fe0, e=0xbff09884) at widgets/qabstractscrollarea_p.h:100
#22 QAbstractScrollAreaFilter::eventFilter (this=0xa1a0d58, o=0xa1a3fe0, e=0xbff09884) at widgets/qabstractscrollarea_p.h:116
#23 0x042ad29a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x96ddea8, receiver=0xa1a3fe0, event=0xbff09884) at kernel/qcoreapplication.cpp:847
#24 0x01eaffb9 in QApplicationPrivate::notify_helper (this=0x96ddea8, receiver=0xa1a3fe0, e=0xbff09884) at kernel/qapplication.cpp:4392
#25 0x01eb60e9 in QApplication::notify (this=0x96cede0, receiver=0xa1a3fe0, e=0xbff09884) at kernel/qapplication.cpp:4361
#26 0x011ac68a in KApplication::notify (this=0x96cede0, receiver=0xa1a3fe0, event=0xbff09884) at ../../kdeui/kernel/kapplication.cpp:310
#27 0x042adb3b in QCoreApplication::notifyInternal (this=0x96cede0, receiver=0xa1a3fe0, event=0xbff09884) at kernel/qcoreapplication.cpp:732
#28 0x01f14ee6 in sendSpontaneousEvent (this=0xa1a02e8, pdev=0x9dffc24, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0xa1c8c60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#29 QWidgetPrivate::drawWidget (this=0xa1a02e8, pdev=0x9dffc24, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0xa1c8c60) at kernel/qwidget.cpp:5420
#30 0x02105bff in QWidgetBackingStore::sync (this=0xa1c8c60) at painting/qbackingstore.cpp:1320
#31 0x01f072b3 in QWidgetPrivate::syncBackingStore (this=0xa1e3728) at kernel/qwidget.cpp:1805
#32 0x01f0e466 in QWidget::event (this=0xa1ee500, event=0x9d3f710) at kernel/qwidget.cpp:8480
#33 0x00b80a43 in Plasma::Dialog::event (this=0xa1ee500, event=0x9d3f710) at ../../plasma/dialog.cpp:589
#34 0x01eaffdc in QApplicationPrivate::notify_helper (this=0x96ddea8, receiver=0xa1ee500, e=0x9d3f710) at kernel/qapplication.cpp:4396
#35 0x01eb60e9 in QApplication::notify (this=0x96cede0, receiver=0xa1ee500, e=0x9d3f710) at kernel/qapplication.cpp:4361
#36 0x011ac68a in KApplication::notify (this=0x96cede0, receiver=0xa1ee500, event=0x9d3f710) at ../../kdeui/kernel/kapplication.cpp:310
#37 0x042adb3b in QCoreApplication::notifyInternal (this=0x96cede0, receiver=0xa1ee500, event=0x9d3f710) at kernel/qcoreapplication.cpp:732
#38 0x042b0d8b in sendEvent (receiver=0x0, event_type=0, data=0x96b88a0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#39 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x96b88a0) at kernel/qcoreapplication.cpp:1373
#40 0x042b0f4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#41 0x042dca74 in sendPostedEvents (s=0x96df990) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#42 postEventSourceDispatch (s=0x96df990) at kernel/qeventdispatcher_glib.cpp:277
#43 0x04df7855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#44 0x04dfb668 in ?? () from /lib/libglib-2.0.so.0
#45 0x04dfb848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#46 0x042dc565 in QEventDispatcherGlib::processEvents (this=0x96ddc40, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#47 0x01f71be5 in QGuiEventDispatcherGlib::processEvents (this=0x96ddc40, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#48 0x042ac609 in QEventLoop::processEvents (this=0xbff0a4b4, flags=) at kernel/qeventloop.cpp:149
#49 0x042aca8a in QEventLoop::exec (this=0xbff0a4b4, flags=...) at kernel/qeventloop.cpp:201
#50 0x042b100f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#51 0x01eaee07 in QApplication::exec () at kernel/qapplication.cpp:3672
#52 0x0078886e in kdemain (argc=1, argv=0xbff0a6c4) at ../../../../plasma/desktop/shell/main.cpp:118
#53 0x080485bb in main (argc=1, argv=0xbff0a6c4) at plasma-desktop_dummy.cpp:3

Reported using DrKonqi
Comment 1 Jorma Hytonen 2010-12-26 10:18:09 UTC
Same happes in Linux 2.6.35-24-generic i686 kernel
Comment 2 Aaron J. Seigo 2010-12-26 10:24:36 UTC
probably already fix in 4.6 with Michael's updates/fixes, but he'll know for sure.
Comment 3 Dario Andres 2010-12-26 15:02:25 UTC
[Comment from a bug triager]
This seems to be related to bug 253795, which should be fixed in KDE SC 4.5.3 and later (but I can't confirm as the codepath is a bit different; I checked the lines on the backtrace)
Regards
Comment 4 Michael Pyne 2010-12-27 01:00:52 UTC
This should be the exact same bug as in bug 253795 (any codepath leading to removeEntry in a corrupt cache would give this crash). In fact it is the exact same line that is crashing too, the difference in line numbers between this 4.5.1 bug and the 4.5.2 report for bug 253795 is accounted for by other bugfixes applied between 4.5.1 and 4.5.2.

As always though, please reopen if this bug continues to be experienced with the current release of 4.5 branch, or the upcoming 4.6 release.

*** This bug has been marked as a duplicate of bug 253795 ***